Announcement

Collapse
No announcement yet.

Erreur Options "Impossible de valider, un ou plusieurs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Erreur Options "Impossible de valider, un ou plusieurs

    bonjour,

    j'ai un petit souci (encore un diront certains), dans le menu Options de Oreon à chaque fois que je modifie un paramètre Nagios, RRD ou autre quand je valide j'ai le message d'erreur suivant qui apparait :

    "Impossible de valider, un ou plusieurs champs sont erronés"

    les nouveaux paramètres ne sont donc pas pris en compte et pourtant tous les champs d'options sont bien renseignés...

    j'ai fait une recherche sur le forum et apparement je ne suis pas le seul avec ce souci, par contre je n'ai trouvé aucune réponse qui règle le problème.

    merci d'avance pour votre aide et à très bientot :wink:

  • #2
    quelle version de oreon ? tu dois normalement dans un des onglets avoir une messages d'erreur pres d'un input ou un select du formulaire....

    regarde bien
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      merci pour la reponse, j'utilise la derniere version d'oreon (1.3.1-1) et j'ai encore regardé je n'ai pas de message d'erreurs ou qoi que ce soit du genre, j'avoue que je suis un peu perdu ?!

      Comment


      • #4
        tu utilise IE ? ou Firefox ?
        Julien Mathis
        Centreon Project Leader
        www.merethis.com |

        Comment


        • #5
          en fait je suis sous debian sarge 3.1 donc pas de IE, juste firefox.
          de plus tout est installé en local (c'est un pc de "test").

          voila :wink:

          Comment


          • #6
            Bonjour,

            mois j'ai le même problème mais dans l'onglet 'Nagios' j'ai pour le répertoire images '/usr/nagios/share' le répertoire n'est pas en écriture.

            un ls xls me donne :

            4 drwxrwxrwx 9 nagios nagios 4096 2006-09-07 15:38 share

            donc tout le monde a accès dessus et moi je ne vois pas ou est mon erreur

            Merci

            Patrick

            Comment


            • #7
              Je me demande si le code php ne se base pas sur le proprietaire.

              Si tu remplace ton groupe nagios par ton groupe apache(httpd,www-data ou autre), t'auras tjs l'erreur ?
              Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
              Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
              Fedora Core 5 - 2.6.20-1.2320

              Comment


              • #8
                ben oui j'ai changé le group puis le user et j'ai toujours la même erreur

                Patrick

                Comment


                • #9
                  T certains que ce n'est pas /usr/local/nagios/share ???
                  Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                  Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                  Fedora Core 5 - 2.6.20-1.2320

                  Comment


                  • #10
                    non j'ai même essayé de créer un dossier /images à la racine avec les droits pour www-data:nagios mais c'est toujours la même erreur.

                    Tu as quoi comme droits sur ce dossier et que doit il contenir ?

                    Merci

                    Patrick

                    Comment


                    • #11
                      Je ne peu pas te repondre car je suis pas dans ma société :wink:
                      Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                      Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                      Fedora Core 5 - 2.6.20-1.2320

                      Comment


                      • #12
                        bon j'ai toujours pas trouvé le pb

                        si qq peut me donner sa conf sur ce dossier ?

                        Merci

                        Patrick

                        Comment


                        • #13
                          Bonjour,

                          voila le résultat de la commande :

                          ??????:/usr/local/nagios# ls -al share
                          total 68
                          drwxrwxr-x 9 nagios nagios 4096 2006-07-13 18:01 .
                          drwxrwxr-x 8 nagios nagios 4096 2006-07-12 17:27 ..
                          drwxrwxr-x 2 nagios nagios 4096 2006-07-13 18:01 contexthelp
                          drwxrwxr-x 3 nagios nagios 4096 2006-07-13 18:01 docs
                          -rwxrwxr-x 1 root nagios 109 2006-07-12 17:27 .htaccess
                          drwxrwxr-x 3 nagios nagios 4096 2006-07-13 19:43 images
                          -rwxrwxr-x 1 nagios nagios 658 2006-07-13 18:01 index.html
                          drwxrwxr-x 4 root nagios 4096 2006-07-12 17:27 locale
                          -rwxrwxr-x 1 nagios nagios 2406 2006-07-13 18:01 main.html
                          drwxrwxr-x 2 nagios nagios 4096 2006-07-13 18:01 media
                          -rwxrwxr-x 1 nagios nagios 26 2006-07-13 18:01 robots.txt
                          -rwxrwxr-x 1 nagios nagios 12729 2006-07-13 18:01 side.html
                          drwxrwxr-x 2 nagios nagios 4096 2006-07-12 17:26 ssi
                          drwxrwxr-x 2 nagios nagios 4096 2006-07-13 18:01 stylesheets

                          En esperant que cela peut aider
                          Oreon 1.4
                          Débian Etch
                          Nagios 2.9

                          Comment


                          • #14
                            merci

                            En mettant les mêmes droits j'ai toujours le messages : Le répertoire n'est pas en écriture.

                            Donc je suppose que ce n'est pas une question de droits mais un fichier ou une définition qui manque.

                            Je ne connais pas grand chose en php et je ne sais pas ou chercher pour vérifier quels sont les contrôles effectués quand on valide les options générales pour Nagios.

                            Merci

                            Patrick

                            Comment


                            • #15
                              Juste une 'tite question : tu es sûr que le rep que tu paramètres existe bien ???

                              Moi, j'avais ce message après l'install car par défaut le chemin qui était renseigné était :

                              /usr/local/nagios/share/images/logo/

                              au lieu de

                              /usr/local/nagios/share/images/logos/

                              Comment

                              Working...
                              X