Announcement

Collapse
No announcement yet.

SimpleGraph Renderer is NOT working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SimpleGraph Renderer is NOT working

    Hello,

    I have got a problem with the SimpleGraphRenderer. When I follow the Action Link of the Monitoring Page, everything is fine, but when I 'm at Oreon Views and want to get a Graph from the same service and host, then I get NO graph. When I let my Browser show the picture (broken Link), then I can read the Message:ERROR: start time: unparsable time:
    What does that mean?
    What is going wrong?

    Can anybody PLEASE help me?
    Regards,

    Ira

  • #2
    I'm experiencing the same problem myself. I see rrd files in /usr/oreon/rrd, but when I try to display a graph it's broken. I do see a status message of 56/56 Graphed values, which seems to say that it is able to read the database. Very confusing.

    Comment


    • #3
      I've found out, that there is a problem with the variables $start and $end. In the source there is a if-clause that matches, when you don't put any values in them by calender or so. But if you look at the broken link to the graph then there stands: Unparseable time

      You can check that, when you look at the URL of that site. When you use the calendar function, then end and start are having values in the URL.

      So there is a problem with parsing the time given by oreon's source code.
      When i found any solution, i will post it here.

      bye Ira

      Comment


      • #4
        I've found the problem and solved it. It was a php-problem.

        Solution:
        please check your php.ini for the apache. You must turn the variable global register to OFF. And that's it. (under SuSE: /etc/php5/apache2/)

        If they are on, then Php interprets the $end and $start Variables as global and as global variables, they don't have a value - they are empty.

        I hope this will help others too.
        Bye,

        Ira

        Comment


        • #5
          Thank you very much

          Oreon developper, is their a way to permit use of register global ? a workaround ?
          Because i think some people may have other web service on same apache that need this.
          Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
          Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
          Fedora Core 5 - 2.6.20-1.2320

          Comment


          • #6
            Unfortunately, I've got not that much time - at the moment that works for me - but when I've got a little more time, I will figure that out.
            On the other side the preference of setting register_globals to on is deprecated since PHP 4.
            See ya,

            Ira

            Comment

            Working...
            X