Announcement

Collapse
No announcement yet.

[resolu] pas de bulle d'aide dans la rubrique Configuration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [resolu] pas de bulle d'aide dans la rubrique Configuration

    Je n'ai pas de bulles d'aide qui s'affichent dans la rubrique Configuration (alors que dans la rubrique Options, j'en ai).
    ex : lors de la création d'un service, lorsque je survol la bulle contenant un ! de Check_command_arguments, rien n'apparait .
    alors que quand je visualise la page nagios.cfg, toutes les bulles s'affichent lors de leur survol.
    Est ce normal?

  • #2
    as tu une erreur javascript dans ton navigateur ?
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      rien dutout: pas l'ombre d'une erreur javascript ni dans les log, ni sur la page web...

      Comment


      • #4
        c'est peut etre un pb de droit finalement car qd je clique sur "Re-schedule an imediate check of this service (forced)" ou tout autre option via Oreon, ca ne marche pas alors qu'avec Nagios, cela marche.
        Vous en pensez koi?

        Comment


        • #5
          quelqu'un peut il me dire quels ont les fichiers qui s'occupent d'afficher les builles d'aide et d'executer les actions du type "Re-schedule an imediate check of this service (forced)"
          Merci d'avance :P

          Comment


          • #6
            Je dirais le cmd.php a la racine pour les commands, et le comment.php dans include/nagiocfg (pour les bulles de Nagios.cfg)
            Romain Le Merlus
            Centreon Forge
            MERETHIS

            Comment


            • #7
              j'ai des erreurs sur les pages hotes, services, les templates et autodetect.
              Est ce normal?
              Et quand je survole la bulle, le message est le suivant (dans IE en bas à gauche):
              ligne 1379
              car 181
              objet attendu
              http://monserveur/oreon/oreon.php?p=104&o=a

              Une idée?

              Comment


              • #8
                Non ce n'est pas normal, on essaie de vous donner des trucs qui ne font pas de grosses erreurs :roll:

                EN fait le systeme des textes de bulle ne sont pas geres pareil selon que tu sois dans Nagios.cfg ou dans la config.

                Regarde quand tu affiches la source de ta page si tu as bien une fonction javascript qui s'appelle "commands_arg", regarde si elle remplis bien les array.

                Et ensuite essaie de voir avec la fonction "montre_legende" qui se trouve dans include/infobulle
                Romain Le Merlus
                Centreon Forge
                MERETHIS

                Comment


                • #9
                  Dans le code source de ma page, j'ai :

                  <script language='javascript'>
                  function commands_arg(sel) {
                  var command_name = Array(48);
                  var command_line = Array(48);
                  var command_back = Array(2);
                  command_name[75] = 'check_by_ssh';
                  command_line[75] = '$USER1$/check_by_ssh -i /home/nagios/.ssh/id_rsa -l nagios -H $HOSTADDRESS$ -C $ARG1$';
                  ...

                  A priori, ca a pas l'air d'etre mal, non?

                  Comment


                  • #10
                    Oui donc maintenant essaie de voir pourquoi la fonction merde.
                    Romain Le Merlus
                    Centreon Forge
                    MERETHIS

                    Comment


                    • #11
                      ben je sais pas trop comment trouver l'erreur en fait... je suis pommee ds tt ce code

                      Comment


                      • #12
                        c'est bizarre: suite à la migration, j'ai tjs ces erreurs, et les bulles d'aide ne s'affichent pas. Pourtant j'ai bien remplacé le fichier oreon.php...
                        D'ou ca peut venir?

                        Comment


                        • #13
                          Change de navigateur pour voir ? essaie mozilla.
                          Romain Le Merlus
                          Centreon Forge
                          MERETHIS

                          Comment


                          • #14
                            j'ai les erreurs suivantes en visualisant la console javascript dans mozilla:

                            - "commands_arg is not defined" (en survolant la bulle d'aide de l'argu de la commande qui n'apparait pas dans la rubrique Config>service>add. Pourtant les bulles d'aide apparaissent bien dans les sous-rubriques d'Options)
                            - "unterminated string literal source file : http://localhost/oreon/oreon.php?p=104&o=à line 65 command_line[66] = '$USER1$/check_netscreen_vpn -H $HOSTADDRESS$ -C tst -n $ARG1$ -t "quand j'affiche les sous-rubriques de la Configuration[/list]
                            Bon la je vois bien qu'il y a un ' qui est ouvert et jamais fermé mais je ne sais pas ou le modifier.
                            Coté BDD tout à l air bon pourtant...
                            -"Error: uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIDOMHTMLElement.replaceChild]" nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)" location: "JS frame :: http://localhost/oreon/include/menu/dhtmlMenu.js :: showHide :: line 73" data: no]" quand je clique sur un graphe afin de le visualiser (IE me met a ce sujet : "le type ne correspond pas")

                            Comment


                            • #15
                              personne ne peut m'aider?

                              Comment

                              Working...
                              X