Announcement

Collapse
No announcement yet.

[Résolu] Problème formulaire

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Résolu] Problème formulaire

    Bonjour,

    Je viens de procéder à une installation d'Oreon (1.3.3) + Nagios (2.5).
    Mais dans l'interface d'Oreon, j'ai un problème avec les formulaires.
    Je ne peut pas utiliser les boutons "Ajouter" et "Supprimer"

    J'obtiens un message de ce type dans le debug javascript :
    "Erreur : qfamsMoveSelection is not defined
    Fichier source : http://[monip]/oreon/oreon.php?p=60302&o=c&contact_id=1
    Ligne : 1"

    Du coup, je ne peut pas modifier l'utilisateur existant, ni en créer d'autres.
    Et je pense que cela doit causer d'autres problèmes.

    Merci de votre aide.

  • #2
    quel navigateur utilise tu ?

    Merci
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      J'utilise Firefox. Mais j'ai le même résultat sous IE.

      Comment


      • #4
        J'ai le même souci que toi suite à mon install

        qfamsMoveSelection n'est pas défini,

        où se trouve cette fonction ? dans quel fichier ? car elle est en rapport avec les boutons ajouter ou supprimer.

        config : Fedora core 6 - php 5 - Mysql 5 - httpd - nagios 2.5 - oreon 1.3.3

        Comment


        • #5
          1.3.3 ??? sûr ? y a plus de boutons pour ajouter ou supprimer sur la 1.3.3. NE serait ce pas la 1.3.2 ?
          Julien Mathis
          Centreon Project Leader
          www.merethis.com |

          Comment


          • #6
            c'est la versuion télécharger à cet endroit oreon 1.3.3

            Comment


            • #7
              donne moi un screenshot de ta page stp

              merci.
              Julien Mathis
              Centreon Project Leader
              www.merethis.com |

              Comment


              • #8
                voilà

                Comment


                • #9
                  Les mêmes boutons pour moi aussi.

                  Version 1.3.3 (mais 1.3.2 affiché au login)

                  Comment


                  • #10
                    ha ok... mince c'est etrange ca... je jete un coup d'oeil...
                    Julien Mathis
                    Centreon Project Leader
                    www.merethis.com |

                    Comment


                    • #11
                      Y a de forte chance que cela vienne de "Quickform" le module php qui est utilisé pour generer les formulaire dans Oreon.

                      Peut être que vos version ne sont pas jours.. on va essayer de chercher de se coté.

                      Vous êtes tout les deux sous Fedora ?

                      Oreon-DevTeam

                      Comment


                      • #12
                        J'ai moi aussi le même probléme. Le bouton "Ajouter" ne semble ne rien faire du tout, alors que le reste de l'interface fonctionne correctement par rapport à ce que j'ai testé.

                        J'utilise Nagios 2.5 avec Oreon 1.3.3 mais j'ai aussi au login juste de marqué que c'est la version 1.3.2 bien que j'ai télécharger la 1.3.3 je viens de vérifier.

                        Edit:

                        Je suis sous Debian Sarge Kernel 2.6, Mysql 4.1, Apache2, Nagios 2.5 et Oreon 1.3.3 (normalement ^^")

                        Comment


                        • #13
                          Je suis sous Ubuntu 6.10 (Edgy).

                          Comment


                          • #14
                            J'ai fait en root un "pear list" afin de voir mes version de Quickform que voici:

                            HTML_QuickForm 3.2.7 stable
                            HTML_QuickForm_ElementGrid 0.1.0 alpha
                            HTML_QuickForm_advmultiselect 1.3.0 stable

                            Il faudrait comparer avec ceux qui on le même probléme. Je n'ai pas encore essayé de faire de mise à jours

                            Comment


                            • #15
                              Installed packages, channel pear.php.net:
                              =========================================
                              Package Version State
                              HTML_Common 1.2.3 stable
                              HTML_QuickForm 3.2.7 stable
                              HTML_QuickForm_advmultiselect 1.3.0 stable
                              HTML_Table 1.7.5 stable
                              HTTP 1.4.0 stable



                              je viens de rajouter celui-ci :
                              HTML_QuickForm_ElementGrid 0.1.0 alpha

                              mais rien n'a changé

                              Comment

                              Working...
                              X