Announcement

Collapse
No announcement yet.

problème avec les hôtes.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • problème avec les hôtes.

    J'ai ajouté des hôtes avec la commande check_graph_traffic. Malheureusement ils sont "down" avec pour messages d'erreur :
    ERROR: IN Bits : Received noSuchName(2) error-status at error-index 1. pour mon 1er hôte et ce message pour le second :
    ERROR: IN Bits : No response from remote host '19.0.0.220'.
    Merci d'avance pour votre aide

  • #2
    Please help!!!!

    Est ce que quelqu'un peut m'aider sur ces erreurs que je rencontre car du coup, j'ai du mal à avancer dans l'exploitation d'oreon si mes hôtes ne fonctionnent pas.
    Merci d'avance
    Last edited by chidori; 21 February 2007, 09:35.

    Comment


    • #3
      Les messages d'erreurs sont claires, non ?

      Sinon pense à arréter l'informatique !

      PS: Lis bcp de doc sur le snmp, cela t'aidera !
      Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
      Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
      Fedora Core 5 - 2.6.20-1.2320

      Comment


      • #4
        Sympa!!!

        Excuse moi de ne pas être un génie de l'informatique. Pour moi c'est pas clair du tout et je comprend rien.
        Et je vois pas en quoi le fait de rencontrer des problèmes en informatique ferait de moi une noeunoeu qui devrait arrêter.
        Merci pour tes conseils mais si c'est pour me dire ce genre de choses tu te les garde pour toi et la prochaine fois tu peux dire plus gentiment que je n'ai pas assez poussé mes recherches.
        En tout cas si j'ai bien compris,si mes recherches restent infructueuses, parce que entre parenthèses j'attends pas deux jours sans rien faire en attendant une réponse surtout dans ce genre là, je crois que je pourrai me gratter pour le coup de main.
        Merci encore.
        Vive l'entraide.

        Comment


        • #5
          L'installation et la configuration de Nagios-Oreon ne se fait pas en deux coups de cuillères à pot. Moi même ça fait plus d'un mois et demi que je suis dessus tous les jours, je suis parti de zéro et ce n'est pas facile.

          Je ne sais pas quelles sont tes compétences en supervision, si tu connaissais déjà Nagios à l'origine ou pas, le protocole SNMP, etc... Si ce n'est pas le cas, dis toi bien qu'avant toute chose tu dois connaître le principe de fonctionnement de ce protocole ainsi que de Nagios. Oreon ne fait que faciliter l'écriture des fichiers de configuration de Nagios et de tracer des graphiques...

          Avant toute chose, étudie bien la structure des plugins utilisés (le check_graph_traffic dans ton cas) et essaye d'abord de les lancer en ligne de commande. Ca prends du temps pour bien comprendre tout ça mais cela est nécessaire. Courage, parcours aussi ce forum qui est très instructif (même si pas mal de posts sont des liens morts) et bien organisé (la fonction Recherche du forum et Google sont tes amis ).

          J'ai compris que sur ce forum on était là pour te guider dans les réponses sans forcément te donner la réponse exacte. C'est très instructif, tu avances au fur et à mesure et au final tu ne fais pas un simple copier/coller d'un tutoriel mais tu as compris tout le fonctionnement de la supervision.
          Debian Etch - Nagios 2.5 - Oreon 1.4

          Comment


          • #6
            Originally posted by chidori View Post
            Excuse moi de ne pas être un génie de l'informatique. Pour moi c'est pas clair du tout et je comprend rien.
            Et je vois pas en quoi le fait de rencontrer des problèmes en informatique ferait de moi une noeunoeu qui devrait arrêter.
            Merci pour tes conseils mais si c'est pour me dire ce genre de choses tu te les garde pour toi et la prochaine fois tu peux dire plus gentiment que je n'ai pas assez poussé mes recherches.
            En tout cas si j'ai bien compris,si mes recherches restent infructueuses, parce que entre parenthèses j'attends pas deux jours sans rien faire en attendant une réponse surtout dans ce genre là, je crois que je pourrai me gratter pour le coup de main.
            « Aide-toi et le Ciel t'aidera ».
            Si tu ne nous en dis pas plus sur ton environnement, on ne peut pas deviner pourquoi ça ne marche pas. En tout cas, pour les erreurs de « check_graph_traffic », il est manifestement évident que les hôtes concernés ne répondent pas aux requêtes SNMP effectuées par ce plugin. Vérifie que l'agent est bien installé et, cas échéant, qu'il fournisse bien des informations sur la table « ifTable ».
            Pour finir : on ajoute des commandes pour vérifier si l'hôte est « DOWN » en utilisant généralement un test de PING. Est-ce que ta méthode consiste à vérifier la présence de ton hôte sur un port de switch ? Si tel est le cas, le plugin reste mal choisi.
            Raphaël 'SurcouF' Bordet
            Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
            Dons Paypal

            Comment


            • #7
              OK now??

              J'ai désormais attribué la commande check_host_alive à mes hôtes et là l'erreur a disparu et mes hôtes et services sont OK. Mais j'aimerais vraiment pouvoir obtenir un graphe du traffic de mes hôtes.
              Alors, il y a t-il un problème avec la commande check_graph_traffic???
              Merci d'avance

              Comment


              • #8
                New erreur!!!

                J'ai attribué la commande check_graph_process à mes hôtes pour voir si cela influerait sur le fait qu'ils soit down ou up et ils sont down avec l'erreur suivante :
                unable to update '/usr/local/oreon/rrd/2_1.rrd' : expected 2 data source readings (got 1) from 1172242886:1:...

                Vu que mes hôtes sont down chaque fois que je leur attribue une commande de type chek_graph_*, je me demande si je n'ai pas un problème par rapport à ces commandes.

                Peut être que je configure mal mes hôtes ainsi que les services associés.

                Et est ce que la commande associé joue un rôle important au niveau de la configuration de l'hôte, si oui lequel???

                Merci d'avance

                Comment


                • #9
                  check_graph_traffic

                  J'ai de nouveau mis un check_graph_traffic à un de mes hôtes ainsi que son service associé.
                  Les arguments que j'ai mis dans le service sont ceux proposés par défaut.
                  J'obtiens de nouveau l'erreur suivante :
                  ERROR: IN Bits : Received noSuchName(2) error-status at error-index 1.

                  Je sais pas si c'est possible, j'y connais absolument pas grand-chose mais j'ai essayé de lancer la commande à partir du terminal.

                  Voici ce que j'ai tapé :
                  ./check_graph_traffic_rrd.pl -H 19.0.0.240 -v 2 -C public -i 2 -w 80 -c 95 -g

                  C'est peut-être du grand n'importe quoi, c'est aussi peut-être la raison pour laquelle j'obtiens :
                  Argument "noSuchObject" isn't numeric in multiplication (*) at ./check_graph_traffic_rrd.pl line 171.
                  Argument "noSuchObject" isn't numeric in multiplication (*) at ./check_graph_traffic_rrd.pl line 177.
                  Use of uninitialized value in array element at /usr/local/nagios/libexec/oreon.pm line 149.
                  Argument "noSuchObject" isn't numeric in numeric eq (==) at ./check_graph_traffic_rrd.pl line 269.
                  CRITICAL: Interface speed equal 0! Interface must be down.

                  J'aimerais vraiment comprendre quel est le problème avec mes commandes check_graph_*

                  Aussi même si ce que j'ai fait peut vous paraître stupide, j'essaie de trouver la solution mais là, je bloque vraiment et obtenir un graph est très important pour mettre en oeuvre la suite de mon projet donc si quelqu'un peut m'aider ça serait vraiment sympa.

                  Encore merci d'avance.

                  Comment


                  • #10
                    salut,

                    essaye sans le -g en ligne de commande car de toute façon il doit toujours etre accompagné par un -S qui lui indique la base rrd associée au service.

                    essaye aussi de rajouter un -T avec le debit de ton interface Ex -T 100 pour une 100 baseTX.

                    la def de commande oreon doit ressembler à ça :

                    $USER1$/check_graph_traffic_rrd.pl -H $HOSTADDRESS$ -i $ARG1$ -T $ARG2$ -w $ARG3$ -c $ARG4$ -C $ARG5$ -v $ARG6$ -g -S $ARG7$

                    Comment


                    • #11
                      arguments!!

                      Coucou,
                      merci pour ta réponse, j'ai fait ce que tu m'as dit (enfin je crois lol) et j'ai tapé la commande suivante :
                      ./check_graph_traffic_rrd.pl -H 19.0.0.240 -v 2 -C public -i 2 -w 80 -c 95 -T 100

                      voici ce que j'obtiens :
                      Argument "noSuchObject" isn't numeric in multiplication (*) at ./check_graph_traffic_rrd.pl line 171.
                      Argument "noSuchObject" isn't numeric in multiplication (*) at ./check_graph_traffic_rrd.pl line 177.
                      Counter: IN = 0 bits and OUT = 0 bits - Traffic cannot be calculated when the last value from the rrdfile is `undef' (check if the `-g' option is enabled)

                      ou puis-je vérifier que la commande -g est dispo

                      merci d'avance.

                      Comment


                      • #12
                        new erreur!!

                        Voila une nouvelle erreur vient d'apparaitre sur l'interface d'oreon toujours pour la même configuration de mon hôte avec le check_graph_traffic. J'obtiens :

                        CRITICAL: Interface speed equal 0! Interface must be down.

                        Si quelqu'un a une idée merci d'avance.

                        Comment


                        • #13
                          Originally posted by chidori View Post
                          Voila une nouvelle erreur vient d'apparaitre sur l'interface d'oreon toujours pour la même configuration de mon hôte avec le check_graph_traffic. J'obtiens :

                          CRITICAL: Interface speed equal 0! Interface must be down.

                          Si quelqu'un a une idée merci d'avance.
                          Tu as dû te tromper d'interface. Celle-ci n'exprime pas de traffic.
                          Tu peux le vérifier avec une requête SNMP sur la table ifType.
                          Raphaël 'SurcouF' Bordet
                          Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
                          Dons Paypal

                          Comment


                          • #14
                            voici ce que j'obtiens :
                            Argument "noSuchObject" isn't numeric in multiplication (*) at ./check_graph_traffic_rrd.pl line 171.
                            Argument "noSuchObject" isn't numeric in multiplication (*) at ./check_graph_traffic_rrd.pl line 177.
                            Counter: IN = 0 bits and OUT = 0 bits - Traffic cannot be calculated when the last value from the rrdfile is `undef' (check if the `-g' option is enabled)
                            en fait, c'est le fonctionnement normal du plugin en ligne de commande ! (pas de bol )

                            car ce plug fait ses calculs à partir des valeurs précédentes qu'il a déja engrangé dans la base rrd.

                            en fait il faut le lancer plusieurs fois à la main ou mieux: l'utiliser directement sous oreon et le laisser tourner quelques minutes.

                            Comment


                            • #15
                              interface!!

                              Je ne comprends pas où j'ai pu choisir l'interface et comment la changer maintenant. J'avoue que plus ça va plus je suis perdu.
                              J'ai essayé de lancer une requête snmp.
                              voici ce que j'ai tapé :
                              snmpget 19.0.0.240 public 2 1.3.6.1.2.1.2.2.1.3
                              voilà ce que j'ai obtenu :
                              snmpget: No securityName specified (Sub-id not found: (top) -> public)

                              J'ai également regardé dans mon gestionnaire d'évènements et voici ce que j'ai :
                              Warning: Attempting to execute the command "/usr/local/nagios/libexec//process-service-perfdata "$LASTSERVICECHECK$" "hôte" "service" "$SERVICEOUTPUT$" "CRITICAL" "$SERVICEPERFDATA$"" resulted in a return code of 127. Make sure the script or binary you are trying to execute actually exists...
                              Last edited by chidori; 1 March 2007, 17:26.

                              Comment

                              Working...
                              X