Announcement

Collapse
No announcement yet.

Problème de graph dans les vues oreon

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    reiben
    Senior Member

  • reiben
    replied
    Salut, j'ai testé check_graph_ping, le graph se trouve dans Sondes Graphiques et non pas Graphs par Hosts. En principe tu pourras y trouver le graphe correspondant au service.

    Leave a comment:

  • glmrenard
    Junior Member

  • glmrenard
    replied
    Bonjour Ludo_X

    Oui, mais quand je vais sur graphe par host et qu'il me propose un ascenseur pour choisir un host, je n'en ai aucun ...
    Alors que je devrais en avoir au moins un :/

    Leave a comment:

  • ludo_x
    Senior Member

  • ludo_x
    replied
    Effectivement, comme tu n'as pas PerfParse, tu ne peux utiliser que les 2 menus du bas :

    Graphs Plugins
    Graphs By Hosts

    Quand tu auras PerfParse, ces menus s'activeront :

    Simple Graphs Renderer
    Custom Graphs

    Leave a comment:

  • glmrenard
    Junior Member

  • glmrenard
    replied
    Merci Ludo_X,

    Mais il y a des données dans mon rrd, j'ai fait un rrdtool dump pour le vérifier et effectivement les données sont là et régulièrement mises à jour ce qui prouve que mon check_graph_ping fonctionne (d'ailleurs le statut du service est vert dans le dashboard)
    Donc il faut que je sélectionne l'autre vue que graph simple ...

    Mais ne puis-je pas utiliser les deux, par exemple les plugins check_graph* pour ce qui existe et utiliser perparse pour grapher le résultat de mes propres checks ?

    Enfin, pour l'instant, ce que je souhaiterais, c'est au moins arriver à voir mon check_graph_ping et je m'attaquerais au perfparse plus tard.

    J'ai encore un nagios(1.2 avec mysql) + APAN avec 200 services qui tournent nickel mais c'est un peu fastidieux comme fonctionnement, je monte donc une maquette oreon+perfparse pour essayer mais j'ai un peu plus de mal.

    Bonne soirée

    Leave a comment:

  • ludo_x
    Senior Member

  • ludo_x
    replied
    Originally posted by glmrenard View Post
    Dans Vues Oreon, il me demande de choisir la ressource à grapher lorsque je veux voir le graphe du service et il n'y a rien dans host/service que je puisses sélectionner, je ne comprends pas pourquoi, j'ai réinstallé tout proprement pourtant :/ Quelqu'un a une idée ?
    Pour grapher, il faut des données.

    Attends un peu que des données arrivent.

    Par contre, dans le menu des vues (Oreon' views) : "Simple Graphs Renderer" tu ne pourras rien voir car il faut PerfParse.
    Mais tu peux grapher des choses avec les plugins check_graph_* et ceux-la s'affiche en RRD dans le menu "Graphs Plugins" de "Oreon' views"

    Leave a comment:

  • opensource
    Member

  • opensource
    replied
    je crois que c'est le fonctionnement d'oreon ...

    Leave a comment:

  • glmrenard
    Junior Member

  • glmrenard
    replied
    Dans Vues Oreon, il me demande de choisir la ressource à grapher lorsque je veux voir le graphe du service et il n'y a rien dans host/service que je puisses sélectionner, je ne comprends pas pourquoi, j'ai réinstallé tout proprement pourtant :/ Quelqu'un a une idée ?

    Leave a comment:

  • glmrenard
    Junior Member

  • glmrenard
    replied
    Je commence à comprendre mais je ne comprends quand même pas pourquoi ce rrd est créé à l'aide du plugin check_graph_ping alors que je n'arrive pas à afficher le moindre graphique, quand je clique sur l'icône graphique du service.

    Tout cela sans faire la moindre mention à perfparse

    Leave a comment:

  • DonKiShoot
    Senior Member

  • DonKiShoot
    replied
    rrd n a rien a voir avec perparse

    Essai encore

    Leave a comment:

  • glmrenard
    Junior Member

  • glmrenard
    started a topic Problème de graph dans les vues oreon

    Problème de graph dans les vues oreon

    Bonjour !!

    D'abord bravo pour Oreon, ensuite, voilà mon problème
    J'ai un nagios tout neuf (le 2.7) et pour l'instant, je ne surveille qu'un seul host avec un seul service (graph_ping). Je vois l'hiost et le service et dans l'interface nagios et dans l'interface oreon.

    J'ai activé le perfdata, configuré correctement (enfin je pense) oreon, la base est crée, le fichier rrd change bien d'heure régulièrement comme quoi il est upgradé, dans le fichier perfdata-service.log, je vois bien les résultats

    1172582742 goupilux graph ping GPING OK - rtt min/avg/max/mdev = 0.028/0.028/0.028/0.000 ms OK time=0.028ms;20;40;; ok=1
    1172582802 goupilux graph ping GPING OK - rtt min/avg/max/mdev = 0.029/0.029/0.029/0.000 ms OK time=0.029ms;20;40;; ok=1
    1172582862 goupilux graph ping GPING OK - rtt min/avg/max/mdev = 0.029/0.029/0.029/0.000 ms OK time=0.029ms;20;40;; ok=1
    Mais lorsque je vais sur Vues Oreon, c'est en 'rouge' et je ne vois aucun graphique, je ne peux rien faire pour choisir ma ressource à grapher.

    Merci d'avance de me mettre sur la voie et bonne journée
Working...
X