Announcement

Collapse
No announcement yet.

Oreon 1.4 : Pb avec liste des services.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oreon 1.4 : Pb avec liste des services.

    Bonjour,

    J'ai un problème concernant des services liés à la charge de systèmes NT.
    J'en avais raz-le-bol de ne pouvoir réussir à les faire pointer sur un fichier rrd autre que le 1_1.rrd (message d'impossibilité de le modifier car un autre service y fait appel, suppression des services + fichier 1_1.rrd mais rien n'y fait), donc je les ai supprimé sous Oreon.
    Le problème est que ces services "pourtant supprimés" apparaissent et disparaissent selon les refresh.
    Et le pire est qu'ils apparaissent que sur la console de monitoring d'Oreon et pas sous Nagios !

    Sur une ancienne version 1.2 de Nagios, lorsque j'avais ce type de problème, j'arrêtais le process de Nagios et je killais les process fantômes qui restaient, puis en relançant le process Nagios je supprimais ce pb.

    Merci de votre aide.
    RedHat AS4, Oreon 1.4, Nagios 2.8

  • #2
    Oreon est une copie de nagios pour la partie monitoring donc ton problème est étrange :confused:
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320

    Comment


    • #3
      Oreon 1.4 : Pb avec liste des services

      Je suis bien d'accord avec toi !!
      RedHat AS4, Oreon 1.4, Nagios 2.8

      Comment


      • #4
        t'as essayé de tout killer la et ca resoud pas le pb ?
        Julien Mathis
        Centreon Project Leader
        www.merethis.com |

        Comment


        • #5
          Oreon 1.4 : Pb avec liste des services.

          çà y est enfin !

          Alors voila comment j'ai pu résoudre le chimilimili !

          Le redémarrage de Nagios par Oreon ne s'était pas correctement fait (timeout dépassé à l'arrêt de Nagios).
          Je me suis connecter sur le serveur, j'ai arrété manuellement Nagios et fais un ps -eaf |grep "nagio*" afin de lister les process fantômes.

          J'ai exécuté un kill -9 des 8 process restant et redémarré Nagios manuellement.
          Résultat : toujours lors des refresh des serveurs et services qui apparaissaient et disparaissaient !
          J'ai lancé un ./nagios reload puis à nouveau un ./nagios stop, kill -9 des 3 process qui restaient puis redémarré Nagios.

          Résultat parfait !



          Comme çà je dirai qu'il y a eu un déphasage entre le transfert de la nouvelle conf entre Oreon et Nagios, et le redémarrage de Nagios !
          RedHat AS4, Oreon 1.4, Nagios 2.8

          Comment

          Working...
          X