Announcement

Collapse
No announcement yet.

Encore et toujours...des graphs vides

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Encore et toujours...des graphs vides

    Je comprends plus...
    J'ai du touche un truc qui fallait pas, et maintenant les graphs marchent plus. Ca me fait un point de temps en temps (voir capture), ou rien du tout en me mettant Nan.
    J'ai ODS qui tourne correctement puisque le repertoire OreonDataStorage est mis a jour correctement, et j'ai aussi RRDTOOL 1.2.18 donc normalement ca marche...
    J'ai mis un -f derriere les check_graph et dans les options de service j'ai mis traitement des donnees de performance. Est ce que c'est correct???

    Je vous met le rrdtool info d'un graph, je sais que c'est les Nan qui vont pas, mais ca vient d'ou?
    Code:
    [[email protected] OreonDataStorage]# /usr/local/rrdtool/bin/rrdtool info 642.rrd
    filename = "642.rrd"
    rrd_version = "0003"
    step = 250
    last_update = 1177593417
    ds[metric].type = "GAUGE"
    ds[metric].minimal_heartbeat = 250
    ds[metric].min = NaN
    ds[metric].max = NaN
    ds[metric].last_ds = "1.000000e+00"
    ds[metric].value = NaN
    ds[metric].unknown_sec = 167
    rra[0].cf = "AVERAGE"
    rra[0].rows = 126144
    rra[0].pdp_per_row = 1
    rra[0].xff = 5.0000000000e-01
    rra[0].cdp_prep[0].value = NaN
    rra[0].cdp_prep[0].unknown_datapoints = 0
    rra[1].cf = "MIN"
    rra[1].rows = 126144
    rra[1].pdp_per_row = 12
    rra[1].xff = 5.0000000000e-01
    rra[1].cdp_prep[0].value = NaN
    rra[1].cdp_prep[0].unknown_datapoints = 1
    rra[2].cf = "MAX"
    rra[2].rows = 126144
    rra[2].pdp_per_row = 12
    rra[2].xff = 5.0000000000e-01
    rra[2].cdp_prep[0].value = NaN
    rra[2].cdp_prep[0].unknown_datapoints = 1
    Attached Files
    Oreon 1.4
    Nagios 2.9
    RRDTool 1.2.18

  • #2
    tu fait un check_graph_ping ??
    et capte pas ou tu mais ton -f
    $USER1$/check_graph_ping.pl -H $HOSTADDRESS$ -w 200,20% -c 500,40% -f -n $ARG1$ -g -S $ARG2$
    tu le met dedans com ça? précise un peu
    bon moi j'promet rien j'ai jamais eu ce probléme
    Fedora 8
    Nagios 2.11
    Plugins-nagios 1.4.11
    Centreon 1.4.2.4
    Pour une bonne petite doc c'est ICI

    Comment


    • #3
      Oui voila je le mets comme ca, mais je sais vraiment pas si il sert a quelque chose...et pour le traitement des donnes de performance, faut il l'activer??
      Oreon 1.4
      Nagios 2.9
      RRDTool 1.2.18

      Comment


      • #4
        bin normalement par defaut je crois qu'il est actif.
        mais si tu ne le mais pas alors tu n'aura pas de graph.
        oreon utilise les données de perf pour grapher les donnée (d'apres ce que j'ai comprit et j'esper que ç juste!)
        Fedora 8
        Nagios 2.11
        Plugins-nagios 1.4.11
        Centreon 1.4.2.4
        Pour une bonne petite doc c'est ICI

        Comment


        • #5
          Non ca c'est sur qu'il utilise les perfdata mais il vaut mieux mettre l'option a oui, non ou defaut?
          Oreon 1.4
          Nagios 2.9
          RRDTool 1.2.18

          Comment


          • #6
            bin com je les dit plus haut si tu veu avoir des graph y faut mettre oui!
            sinon tu mais ce que tu veux.
            enfin je veu pas etre pessimiste mais a mon avi ça va pas changé grand chose a ton probléme...
            MAIS y faut tout testé!!
            Fedora 8
            Nagios 2.11
            Plugins-nagios 1.4.11
            Centreon 1.4.2.4
            Pour une bonne petite doc c'est ICI

            Comment


            • #7
              Par default sa doit etre à oui. Je l'ai jamais mis à oui et les services pouvant etre graphés sont tous graphés

              Comment

              Working...
              X