Announcement

Collapse
No announcement yet.

Reporting ->seulement le courant affiché

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Reporting ->seulement le courant affiché

    Bonjour, ce probleme a souvent été évoqué, j'ai avancé de ce coté la :

    J'ai modifier les fichier qu'il faut dans /usr/local/oreon/cron pour que les commande dans /etc/cron.d/oreon soient bien exécutée.

    Cepandant, si je comprend bien, le reporting se sert des tables log_archive_host et log_archive_service pour générer les résultats des dates précédentes.
    Probleme : c'est tables sont vides chez moi!
    J'ai regardé un peu, apperement c'est le script /usr/local/oreon/cron/api/host_service.php qui va remplir ces tables. Pourtant, je ne trouve nul part ou ce script est exécuté. Et quand je l'exécute à la main, la base ne se rempli pas.

    Quelqu'un a-t-il une solution?

  • #2
    Probleme réglé, j'ai édité la FAQ sur la manière dont j'ai réglé le probleme.

    Cepandant, un autre probleme est arrivé :

    Tous mes jours précédents ont 2 lignes d'état dans la timeline au lieu d'une. Des doublons ont donc du se créer dans la base.

    Quelqu'un a-t-il déja identifié le probleme?
    Attached Files

    Comment


    • #3
      Originally posted by kuroro View Post
      Probleme réglé, j'ai édité la FAQ sur la manière dont j'ai réglé le probleme.

      Cepandant, un autre probleme est arrivé :

      Tous mes jours précédents ont 2 lignes d'état dans la timeline au lieu d'une. Des doublons ont donc du se créer dans la base.

      Quelqu'un a-t-il déja identifié le probleme?
      Salut, effectivement, j'ai eu le même problème, ca vient du fait de lancer le script à la mano n'importe quand et non avec le cron.

      une solution : relancer le script avec l'option "-d" (si je me rapelle bien) qui va vider ta base pour la reremplir proprement. (Archive??.pl --help pour s'en assurer)

      attention, ca peut être long si tu as pas mal de log nagios à parser !!

      cordialement

      Gaé

      Comment


      • #4
        merci , j'ai lancé la commande :

        /usr/bin/php4-cgi -q /usr/local/oreon/cron/reporting/ArchiveLogInDB.php -d

        Ma base s'est vidée, mais elle ne s'est pas reremplie. elle se remplira demain?

        Comment

        Working...
        X