Announcement

Collapse
No announcement yet.

déplacement KO sur fichiers de config

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • déplacement KO sur fichiers de config

    Bonjour,

    Suite à ertains problème sous ma FreeBSD, j'ai reinstallé Oreon sous Fedora Core 7. Et la manque de bol encore des soucis mais je ne sait absolument pas d'où.

    En effet; j'ai commencé à configurer nagios sous Oreon et lorsque je veux déplacer mes fichiers de config (ou importé ma config nagios) j'ai le droit a un magnifique message qui dit: déplacement KO.

    J'ai fouillé sur vos forums et j'ai trouvé quelque réponse. J'ai donc vérifier les droits sur les répertoires Nagios et Oreon et tout est correcte.

    Code:
    [[email protected] ~]# ls -la /etc/ |grep nagios
    drwxrwxr-x   3 apache nagios   4096 jun  1 18:44 nagios
    [[email protected] ~]# ls -la /usr/local/ |grep oreon
    drwxrwxr-x 12 apache nagios 4096 jun  1 17:03 oreon
    Une idée?

  • #2
    Salut,

    Ok pour le répetoire /etc/nagios, mais les fichiers contenu dans ce répertoire, ils ont les bons droits ?
    Centreon 2.x

    Comment


    • #3
      Originally posted by WAtt View Post
      Salut,

      Ok pour le répetoire /etc/nagios, mais les fichiers contenu dans ce répertoire, ils ont les bons droits ?
      Oui

      Code:
      [[email protected] ~]# ls -la /etc/nagios/
      total 100
      drwxrwxr-x   3 apache nagios  4096 jun  1 18:44 .
      drwxrwxr-x 103 root   root   12288 jun  1 17:02 ..
      -rwxrwxr-x   1 apache nagios  9479 jun  1 18:57 cgi.cfg
      -rwxrwxr-x   1 apache nagios  8567 fév  6 18:22 commands.cfg
      -rwxrwxr-x   1 apache nagios 12469 fév  6 18:22 localhost.cfg
      -rwxrwxr-x   1 apache nagios 30895 fév  6 18:22 nagios.cfg
      -rw-r--r--   1 root   root      21 jun  1 18:45 passwd
      drwxrwxr-x   2 apache nagios  4096 jun  1 16:41 private

      Comment


      • #4
        vérifies si oreon pointe sur le bon répertoire nagios
        Last edited by netzuko; 4 June 2007, 11:24.

        Comment


        • #5
          Originally posted by netzuko View Post
          vérifies si oreon pointe sur le bon répertoire nagios
          Non non, tout est bon...

          Comment


          • #6
            Je viens de m'appercevoir que je n'arrive pas à crée mes graphes sous Cacti.
            Y aura pas une protection dans la config d'Apache pour l'écriture de fichiers?

            Comment


            • #7
              je ne connais pas vraiment cacti, désolé. mais, tu n'as toujours pas réussi a régler le KO?

              Comment


              • #8
                Bah en faites cacti n'arrive pas à faire crée ses fichiers de graph (.rrd)
                Donc je me suis dit que le problème étai peut être liée (apache qui arrive pas à ecrire sur le systeme de fichiers du a une restriction de sécurité ou autres).
                Bref, je creuse toujours...

                Comment


                • #9
                  Même si c'est un truc que je ne connais pas trop, t'as peut être un problème de droits SELINUX ??

                  Gaé

                  Comment


                  • #10
                    J'y ai pensé aussi, mais à l'install de Fedora j'ai désactivé SELinux car je savais que ca peut crée des soucis.
                    Y a peut être un autre paramètre à rentré mais je sais pas lequel...

                    Comment


                    • #11
                      as tu désactivé le perfparse?

                      Comment


                      • #12
                        Originally posted by netzuko View Post
                        as tu désactivé le perfparse?
                        Oui, je l'avais pas activer et je viens de vérifier.
                        On le voit aussi dans mon précedent screenshot.

                        Comment


                        • #13
                          yop,

                          les seuls pb que peut te causer fedora sont :
                          1) vi /etc/selinux/config, vérifie que tu as bien "SELINUX=disabled"
                          2) service iptables status pour vérifier si ton pare feu est activé ou pas, s'il l'est vérifie les règles...
                          Fedora 6 ( 2.6.20-1.2962 )
                          Nagios 2.9
                          Oreon 1.4.1-RC2
                          rrdtool 1.2.23

                          Comment


                          • #14
                            Originally posted by fan View Post
                            yop,

                            les seuls pb que peut te causer fedora sont :
                            1) vi /etc/selinux/config, vérifie que tu as bien "SELINUX=disabled"
                            2) service iptables status pour vérifier si ton pare feu est activé ou pas, s'il l'est vérifie les règles...
                            Bon je vient de vérifier SELINUX et il est bien "Disable".
                            Par contre pour le pare feu il etai bien activer et je l'ai donc coupé, et c'est toujours pareil...

                            Code:
                            [[email protected] ~]# service iptables status
                            Table : filter
                            Chain INPUT (policy ACCEPT)
                            num  target     prot opt source               destination
                            
                            Chain FORWARD (policy ACCEPT)
                            num  target     prot opt source               destination
                            
                            Chain OUTPUT (policy ACCEPT)
                            num  target     prot opt source               destination

                            Comment


                            • #15
                              Bon je viens de régler mon problème de cacti. En faites c'est le démon Cron qui crée les graph, et comme je l'avais pas redémarrer, il avait pas prit en compte la table de cacti.

                              Comment

                              Working...
                              X