Announcement

Collapse
No announcement yet.

Home (page d'accueil) graphiques indisponibles

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Home (page d'accueil) graphiques indisponibles

    Bonjour,

    La capture d'écran disponible à cette adresse :
    http://www.oreon.org/images/screenshots/home.jpg
    affiche des graphiques représentant l'état global du réseau,

    Dans mon cas, l'état des ressources et l'état des services est représenté par une barre de progression.

    Les graphiques générés sur cette capture d'écran n'apparaisse pas sur l'interface d'oreon.

    :?:comment générer ces graphiques sur cette page d'accueil
    :?:

    Merci pour votre aide

  • #2
    Si rien ne s'affiche et que tu as pourtant des logs de Nagios c'est qu'il te manque des trucs.
    Tes logs d'apache ?
    Romain Le Merlus
    Centreon Forge
    MERETHIS

    Comment


    • #3
      voila le contenu du fichier log de httpd,


      " Press ? for keyboard shortcuts
      " Sorted by name (.bak,~,.o,.h,.info,.swp,.obj at end of list)
      "= /var/log/httpd/
      ../
      access_log
      access_log.1
      access_log.2
      access_log.3
      error_log
      error_log.1
      error_log.2
      error_log.3
      ssl_access_log
      ssl_access_log.1
      ssl_access_log.2
      ssl_access_log.3
      ssl_error_log
      ssl_error_log.1
      ssl_error_log.2
      ssl_error_log.3
      ssl_request_log
      ssl_request_log.1
      ssl_request_log.2
      ssl_request_log.3
      ~
      ~

      Comment


      • #4
        le contenu de 'access_log' et 'error_log' juste après avoir accéder à la page d'acceuil Oreon ?

        genre 'tail -n 50 -f /var/log/httpd/acces_log'
        StatusMap Module - NDO Tools Module - ImportCSV Module - SNMP-UI Module - PDFReports Module
        Dons Paypal

        Comment


        • #5
          Et dans error_log plus precisement... (ct ca la question d'origine en fait)
          Romain Le Merlus
          Centreon Forge
          MERETHIS

          Comment


          • #6
            voila le contenu de error log à la date d'aujourd'hui,

            [Tue May 24 09:33:38 2005] [notice] Digest: generating secret for digest authentication ...
            [Tue May 24 09:33:38 2005] [notice] Digest: done
            [Tue May 24 09:33:39 2005] [notice] Apache/2.0.40 (Red Hat Linux) configured -- resuming normal operations
            [Tue May 24 09:36:19 2005] [notice] Digest: generating secret for digest authentication ...
            [Tue May 24 09:36:19 2005] [notice] Digest: done
            [Tue May 24 09:36:20 2005] [notice] Apache/2.0.40 (Red Hat Linux) configured -- resuming normal operations
            [Tue May 24 09:38:27 2005] [notice] Digest: generating secret for digest authentication ...
            [Tue May 24 09:38:27 2005] [notice] Digest: done
            [Tue May 24 09:38:28 2005] [notice] Apache/2.0.40 (Red Hat Linux) configured -- resuming normal operations
            [Tue May 24 09:41:28 2005] [notice] Digest: generating secret for digest authentication ...
            [Tue May 24 09:41:28 2005] [notice] Digest: done
            [Tue May 24 09:41:29 2005] [notice] Apache/2.0.40 (Red Hat Linux) configured -- resuming normal operations
            [Tue May 24 09:49:33 2005] [warn] child process 3376 still did not exit, sending a SIGTERM
            [Tue May 24 09:49:33 2005] [warn] child process 3377 still did not exit, sending a SIGTERM
            [Tue May 24 09:49:33 2005] [warn] child process 3378 still did not exit, sending a SIGTERM
            [Tue May 24 09:49:33 2005] [warn] child process 3379 still did not exit, sending a SIGTERM
            [Tue May 24 09:49:33 2005] [warn] child process 3380 still did not exit, sending a SIGTERM
            [Tue May 24 09:49:33 2005] [warn] child process 3381 still did not exit, sending a SIGTERM

            j'ai aussi ce message qui se répéte :
            cp: ne peut évaluer `./ressources/*': Aucun fichier ou répertoire de ce type
            cp: omission du répertoire `./etc/conf'

            Comment


            • #7
              Va sur la page ou tes images ne s'affichent pas, et va faire un tail sur error_log
              Romain Le Merlus
              Centreon Forge
              MERETHIS

              Comment


              • #8
                voila le résultat :

                [[email protected] logs]# tail error_log
                cp: omission du répertoire `./etc/conf'
                cp: ne peut évaluer `./ressources/*': Aucun fichier ou répertoire de ce type
                cp: omission du répertoire `./etc/conf'
                cp: ne peut évaluer `./ressources/*': Aucun fichier ou répertoire de ce type
                cp: omission du répertoire `./etc/conf'
                cp: ne peut évaluer `./ressources/*': Aucun fichier ou répertoire de ce type
                cp: omission du répertoire `./etc/conf'
                cp: ne peut évaluer `./ressources/*': Aucun fichier ou répertoire de ce type
                cp: omission du répertoire `./etc/conf'
                cp: ne peut évaluer `./ressources/*': Aucun fichier ou répertoire de ce type
                [[email protected] logs]#

                Comment


                • #9
                  Il faut que tu remplaces a la ligne 99 de exportDB :
                  system("cp ./ressources/* " . $oreon->optGen->get_nagios_pwd() . "share/images/logos/");

                  par :

                  system("cp ./img/ressources/* " . $oreon->optGen->get_nagios_pwd() . "share/images/logos/");

                  Ca va resoudre ton probleme de ressources, pour le reste je ne sais pas.


                  Pour les images, as tu bien qq chose dans le monitoring ? Nagios fonctionne avec les ressources que tu as declare ?
                  Romain Le Merlus
                  Centreon Forge
                  MERETHIS

                  Comment


                  • #10
                    encore merci,
                    Pour répondre à ta question, j'ai quelque chose dans le monitoring,
                    le problème de ressource est réglé,

                    j'ai redémarré apache, je t'envoie à nouveau les logs, j'ai tjs rien sur la page d'accueil,

                    [[email protected] logs]# tail error_log
                    [Tue May 24 15:01:38 2005] [warn] child process 3374 still did not exit, sending a SIGTERM
                    [Tue May 24 15:01:38 2005] [warn] child process 3375 still did not exit, sending a SIGTERM
                    [Tue May 24 15:01:38 2005] [warn] child process 3376 still did not exit, sending a SIGTERM
                    [Tue May 24 15:01:38 2005] [warn] child process 3377 still did not exit, sending a SIGTERM
                    [Tue May 24 15:01:38 2005] [warn] child process 3746 still did not exit, sending a SIGTERM
                    [Tue May 24 15:01:43 2005] [notice] Digest: generating secret for digest authentication ...
                    [Tue May 24 15:01:43 2005] [notice] Digest: done
                    [Tue May 24 15:01:44 2005] [notice] Apache/2.0.40 (Red Hat Linux) configured --
                    resuming normal operations
                    cp: omission du répertoire `./etc/conf'
                    cp: omission du répertoire `./etc/conf'
                    [[email protected] logs]#

                    est ce que tu sais à quoi correspond ce répertoire ./etc/conf pour apache :?:

                    encore merci

                    Comment


                    • #11
                      salut à tous,
                      à présent, je n'ai plus d'erreur dans le fichier error_log de apache mais toujours pas de graphiques sur ma page d'accueil.

                      Connaissez-vous les droits à attribuer, les packages nécessaires à l'affichage de ces graphiques si l'erreur vient de la ?

                      pour l'instant, je n'ai pas trouvé de réponse à ce problème.

                      merci

                      Comment


                      • #12
                        As tu installé perl-gd, gd, gd-devel, libpng, libpng-devel ?

                        Comment


                        • #13
                          oui c'est installé.
                          on m'a parlé de php-gd que je n'ai pas installé.
                          je suis entrain de le chercher en rpm. :? pour red hat 9.0

                          Comment


                          • #14
                            Bonjour,
                            J'ai installé php-gd 4.2.2-1j1.i686.rpm,
                            mais j'ai toujours le même problème.
                            je voulais savoir
                            :arrow: si il ya des droits spéciaux à attribuer à certains dossiers pour qu'il m'affiche ces graphs sur cette page d'accueil.

                            j'ai installé :
                            perl-gd-2.16-10.rh9.at.i386.rpm
                            gd 1.8.4.11
                            gd-devel 1.8.4.11
                            libgd-1.3.4.i386.rpm
                            libpng 1.2.2.16
                            libpng-devel 1.2.2.16
                            libjpeg-6b-26.i386.rpm
                            libjpeg-devel-6b-26.i386.rpm

                            merci

                            Comment


                            • #15
                              Logiquement non pas de droits speciaux a ce niveau...
                              J'ai une version de gd superieur a toi : gd-2.0.28-1
                              Romain Le Merlus
                              Centreon Forge
                              MERETHIS

                              Comment

                              Working...
                              X