Announcement

Collapse
No announcement yet.

pas de demande d'authentification nagios

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pas de demande d'authentification nagios

    voila, j'ai un soucis, quand j'ouvre nagios on ne me demande pas de me loguer.
    Ce qui fait que je n'ai pas acces au donnée de nagios. (pas les droits).
    Pour corriger ce petite probleme j'ai mis defaut users = nagiosadmin dans cgi.cfg
    mais je souhaite avoir une authentification pour ne pas que tous le monde accedde a nagios.
    j'ai configurer mon httpd.conf avec les ligne prévur , j'ai créer un users valid
    htpasswd –c /usr/local/nagios/etc/htpasswd.users nagiosadmin

    mais rien en authentioficaiton, je suis sous debian.
    merci de votre aide pour corrgier mon probleme qui doit etre un des dernier avant que ma configuration soient ok !
    Master Sécurité des Systèmes d' Information
    Nagios v2.9 ||Nagios-plugins 1.4.9 || snmp v2c || Oreon 1.4 INside || ODS || 59 hosts && 128 services
    || Nagios Checker


    [email protected] vs Jonhbob le choc des GDR ^^

  • #2
    Vérifie que tu as bien la directive "AllowOverride yes" car sinon il ne lis même pas ton fichier .htaccess.

    Vérifie aussi les droits sur celui çi (chmod 600 + chown apache:apache)
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320

    Comment


    • #3
      ok c'est fait, mais le truc c'est que j'ai pas de fichier htaccess en fait.
      Les restriction d'acces se font pas dans le httpd.conf ?
      par aileur petite info sous debian c'est pas apache mais www-data (mais ca change rien)
      en fait jai ma conf dans httpd.conf et mon htpasswd.user dans /usr/local/nagios/etc
      Master Sécurité des Systèmes d' Information
      Nagios v2.9 ||Nagios-plugins 1.4.9 || snmp v2c || Oreon 1.4 INside || ODS || 59 hosts && 128 services
      || Nagios Checker


      [email protected] vs Jonhbob le choc des GDR ^^

      Comment


      • #4
        Il est possible de mettre l'authentification directement dans httpd.conf dans la clause directory de ton dossier nagios je crois mais il me semblait que nagios faisait ca par fichier .htacess
        Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
        Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
        Fedora Core 5 - 2.6.20-1.2320

        Comment


        • #5
          je met ce que j'ai fais:

          dans le fichier >/etc/apache2/httpd.conf

          ScriptAlias /nagios/cgi-bin /usr/local/nagios/sbin

          <Directory “/usr/local/nagios/sbin�>
          Options ExecCGI
          AllowOverride AuthConfig
          Order allow,deny
          Allow from all
          AuthName “Nagios-Access�
          AuthType Basic
          AuthUserFile /usr/local/nagios/etc/htpasswd.users
          Require valid-user
          </Directory>

          Alias /nagios /usr/local/nagios/share

          <Directory “/usr/local/nagios/share�>
          Options None
          AllowOverride AuthConfig
          Order allow,deny
          Allow from all
          AuthName “Nagios-Access�
          AuthType Basic
          AuthUserFile /usr/local/nagios/etc/htpasswd.users
          Require valid-user
          </Directory>

          htpasswd avec la commande htpasswd
          nagiosadmin:JQvPJ0PN3r.FY

          Dans .htaccess dans /usr/local/nagios/share
          AuthName "Nagios-Access"
          AuthType Basic
          AuthUserFile /usr/local/nagios/etc/htpasswd.users
          Require valid-user
          Master Sécurité des Systèmes d' Information
          Nagios v2.9 ||Nagios-plugins 1.4.9 || snmp v2c || Oreon 1.4 INside || ODS || 59 hosts && 128 services
          || Nagios Checker


          [email protected] vs Jonhbob le choc des GDR ^^

          Comment

          Working...
          X