Announcement

Collapse
No announcement yet.

erreur lors de l'accès à l'interface d'Oreon

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • erreur lors de l'accès à l'interface d'Oreon

    Voila je travaille sous une Centos 4.5 et depuis la réinstallation de nagios/oreon (qui fonctionnait tres bien avant), je n'arrive plus à m'identifier à l'interface web d'oreon.
    A chaque fois, il me donne ce message d'erreur :Invalid User

    Pourtant j'ai défini lors de l'installation d'oreon (step 10 il me semble), mon login et mdp pour accéder à cette interface (admin:admin).
    Voila le contenu de mon fichier httpd.conf :

    #ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"

    ScriptAlias /nagios/cgi-bin "/usr/local/nagios/sbin"

    <Directory "/usr/local/nagios/sbin">
    Options ExecCGI
    AllowOverride None
    Order allow,deny
    Allow from all
    AuthName "Nagios Access"
    AuthType Basic
    AuthUserFile /usr/local/nagios/etc/htpasswd.users
    Require valid-user
    </Directory>

    Alias /nagios "/usr/local/nagios/share"

    <Directory "/usr/local/nagios/share">
    Options None
    AllowOverride None
    Order allow,deny
    Allow from all
    AuthName "Nagios Access"
    AuthType Basic
    AuthUserFile /usr/local/nagios/etc/htpasswd.users
    Require valid-user
    </Directory>

    Voici le contenu de mon fichier oreon.conf (si cela peut aider) :

    ##
    ## Section add by OREON Install Setup
    ##

    AddType application/x-java-jnlp-file .jnlp
    Alias /oreon/ /usr/local/oreon/www/
    <Directory "/usr/local/oreon/www">
    AllowOverride AuthConfig
    Options None
    Order allow,deny
    Allow from all
    </Directory>

    Et au cas ou le contenu du fichier oreon.conf.php

    // Database
    $conf_oreon['host'] = "localhost";
    $conf_oreon['user'] = "editus";
    $conf_oreon['password'] = "admin";
    $conf_oreon['db'] = "editus";
    $conf_oreon['ods'] = "editus_storage";


    // path to classes
    $classdir='./class';


    J'ai bien ajouter l'user admin avec la commande htpasswd..

    Merci de bien vouloir me donner un coup de main!
    Last edited by vins180; 18 July 2007, 11:59.
    Centos 4.4
    Nagios 2.9 / Oreon 1.4

  • #2
    Quelle est la version de Nagios installée ? car tes chemins laissent indiquer qu'il s'agit de Nagios v1.X...

    Sinon as-tu essayé de vider le cache de ton navigateur, de le quitter puis de relancer le tout ?

    Comment


    • #3
      Salut,

      [edit (cheers ccoulang )]

      Tu peux aller voir si ton user a toujours un mot de passe dans la bdd ?
      Sinon tu le reinitialises.

      [/edit]
      Last edited by NoS; 10 July 2007, 12:05.
      ..()_() .°("who | grep -i blonde | date; cd ~; unzip;")
      =(o_0)=
      *(() () Nicolas Verriest, France

      Comment


      • #4
        Pour information, l'authentification d'Oreon, n'est pas liée à celle de Nagios... L'utilisateur admin que tu as créé lors de l'install se trouve dans la table Contact dans la base de données d'Oreon...

        Tu peux regénérer le mot de passe de l'utilisateur si tu le souhaites mais je n'ai plus la commande sous la main... Je trouve ca et je te la poste...

        Comment


        • #5
          En attendant la reponse de ccoulang y a un post qui parle de ce probleme ici :

          http://forum.oreon-project.org/showthread.php?t=4085

          Y aura peut etre ton info.
          ..()_() .°("who | grep -i blonde | date; cd ~; unzip;")
          =(o_0)=
          *(() () Nicolas Verriest, France

          Comment


          • #6
            Yop me revoila...

            Tu te connectes a ton serveur mysql : mysql -u root (car je suis en local)

            mysql > use oreon;
            (Nom de la base de données d'Oreon)

            mysql > update contact set contact_passwd=md5("admin") where contact_name="admin";
            (regénération du mot de passe admin pour l'utilisateur admin)

            Je viens de faire un test et ca fonctionne...

            Comment


            • #7
              ca a marché

              merci de toutes ses reponses!
              Centos 4.4
              Nagios 2.9 / Oreon 1.4

              Comment


              • #8
                Invalid User

                Bonjour,

                J'ai supprimé hier un contact dans oreon et depuis je n'arrive plus à me connecter à Oreon avec les autres users.

                J'ai tenté de rajouter un user avec la commande:
                INSERT INTO contact VALUES ('1','5','5','admin','admin','ad','fr','d,u','w,u, c','[email protected]','06xxxxxxxx','30/10/2007 - 09:05:45','0','0','txt','1','local','NULL');

                J'ai ensuite tenter de réinitialiser les mots de passes de tous mes users avec la commande:
                UPDATE contact SET contact_passwd=md5("passwd") WHERE contact_id="id de mes users";

                Toujours pas moyen de se connecter.

                J'ai vider le cache de mon explorateur pour être sur.
                Ma version de MySql est 5.0.32

                Merci d'avance pour votre aide

                Comment

                Working...
                X