Announcement

Collapse
No announcement yet.

"Fiches d'identité" ne focntionnent pas

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • johnbob
    replied
    Non, pas d'autre application utilisées sur mon serveur de supervision.

    J'utilise bien NET-SNMP.

    Leave a comment:


  • wistof
    replied
    Hello,

    utilises-tu d'autres applis PHP + SNMP (cacti ?)

    Tu utilises NET-SNMP ou UCD SNMP ?

    Leave a comment:


  • johnbob
    replied
    C'est ce que je pensais aussi. Un conflit avec snmp et les mibs que je manipule ...

    Mais je viens de mettre en place un nouveau serveur de supervision avec les mêmes paramètres sans avoir touché quoi que se soit au niveau SNMP,
    et le problème reste le même !
    - le fichier de test me revoie aucune erreur de mibs, mais les crochets restent vides.
    - l'interrogation via les plugin SNMP (snmpwalk) fonctionne correctement.

    Leave a comment:


  • wistof
    replied
    Originally posted by johnbob View Post
    Voilà ce que j'obtien lors de l'execution du fichier php :

    Code:
    No log handling enabled - turning on stderr logging
    Unlinked OID in FDDI-SMT73-MIB: fddi ::= { transmission 15 }
    Undefined identifier: transmission near line 14 of /data/snmp-tmp/mibs_compaq/fddi-smt73-mib.mib
    Did not find 'fddimibPORTSMTIndex' in module FDDI-SMT73-MIB (/data/snmp-tmp/mibs_compaq/cisco-stack-mib.mib)
    Did not find 'fddimibPORTIndex' in module FDDI-SMT73-MIB (/data/snmp-tmp/mibs_compaq/cisco-stack-mib.mib)
    []
    Les mêmes erreurs de MIBs SNMP et rien entre les crochets.
    Hello,

    Apparement, tu as joué avec tes mibs, regarde de ce coté. Tant que les crochets seront vides, cela ne fonctionnera pas

    Leave a comment:


  • johnbob
    replied
    J'ai oublié de préciser au début, que mon prbolème est survenu à la suite d'une importation de la configuration d'Oreon.
    (après une importation de la BD "oreon").

    Est-ce que celà à une influence ?

    Leave a comment:


  • johnbob
    replied
    Voilà ce que j'obtien lors de l'execution du fichier php :

    Code:
    No log handling enabled - turning on stderr logging
    Unlinked OID in FDDI-SMT73-MIB: fddi ::= { transmission 15 }
    Undefined identifier: transmission near line 14 of /data/snmp-tmp/mibs_compaq/fddi-smt73-mib.mib
    Did not find 'fddimibPORTSMTIndex' in module FDDI-SMT73-MIB (/data/snmp-tmp/mibs_compaq/cisco-stack-mib.mib)
    Did not find 'fddimibPORTIndex' in module FDDI-SMT73-MIB (/data/snmp-tmp/mibs_compaq/cisco-stack-mib.mib)
    []
    Les mêmes erreurs de MIBs SNMP et rien entre les crochets.

    Leave a comment:


  • lowdata
    replied
    UP.

    Tout comme certains je n'ai pas acces non plus aux onglets Network Devices et Storage (Poste Windows XP).

    Un snmpget me donne :
    Code:
    :/usr/local/oreon/www # snmpget -v 1 -c public 192.168.193.35 1.3.6.1.2.1.1.3.0
    DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (9598731) 1 day, 2:39:47.31
    Dans le slogs d'apache, j'ai ca quand je clique sur une de ces zones :
    Code:
    [Tue Jul 31 11:50:27 2007] [error] [client 127.0.0.1] PHP Notice:  Undefined variable: ipInterface in /usr/local/oreon/www/include/inventory/IDCard_server/infosServerXML.php on line 365
    Quelqu'un aurait une idée ? Merci d'avance.

    Leave a comment:


  • wistof
    replied
    Originally posted by johnbob View Post
    Voici tous les paquets snmp installés :
    Code:
    net-snmp-libs
    net-snmp
    php-snmp
    net-snmp-utils
    net-snmp-perl
    Un coup de : snmpget -v 1 -c communaute_01 serveur_01.mon.domaine .1.3.6.1.2.1.1.3.0
    Code:
    Unlinked OID in FDDI-SMT73-MIB: fddi ::= { transmission 15 }
    Undefined identifier: transmission near line 14 of /data/snmp-tmp/mibs_compaq/fddi-smt73-mib.mib
    Did not find 'fddimibPORTSMTIndex' in module FDDI-SMT73-MIB (/data/snmp-tmp/mibs_compaq/cisco-stack-mib.mib)
    Did not find 'fddimibPORTIndex' in module FDDI-SMT73-MIB (/data/snmp-tmp/mibs_compaq/cisco-stack-mib.mib)
    RFC1213-MIB::sysUpTime.0 = Timeticks: (58622882) 6 days, 18:50:28.82

    Les erreurs sont dues aux mibs que je rajoute fréquement.
    Le problème était le même lorsque je n'avais aucune erreur de dépendance de fichiers MIB.

    fait un petit fichier php et mets ça dedans :
    Code:
    <?
    $str = @snmpget("serveur_01.mon.domaine", "communaute_01", ".1.3.6.1.2.1.1.3.0", 45 , 2);
    print "[".$str."]";
    ?>
    puis fait un "php snmp.php" et donnes nous le résultat.

    Leave a comment:


  • johnbob
    replied
    Voici tous les paquets snmp installés :
    Code:
    net-snmp-libs
    net-snmp
    php-snmp
    net-snmp-utils
    net-snmp-perl

    Un coup de : snmpget -v 1 -c communaute_01 serveur_01.mon.domaine .1.3.6.1.2.1.1.3.0
    Code:
    Unlinked OID in FDDI-SMT73-MIB: fddi ::= { transmission 15 }
    Undefined identifier: transmission near line 14 of /data/snmp-tmp/mibs_compaq/fddi-smt73-mib.mib
    Did not find 'fddimibPORTSMTIndex' in module FDDI-SMT73-MIB (/data/snmp-tmp/mibs_compaq/cisco-stack-mib.mib)
    Did not find 'fddimibPORTIndex' in module FDDI-SMT73-MIB (/data/snmp-tmp/mibs_compaq/cisco-stack-mib.mib)
    RFC1213-MIB::sysUpTime.0 = Timeticks: (58622882) 6 days, 18:50:28.82

    Les erreurs sont dues aux mibs que je rajoute fréquement.
    Le problème était le même lorsque je n'avais aucune erreur de dépendance de fichiers MIB.

    Leave a comment:


  • wistof
    replied
    Je ne pense pas que des droits de fichiers provoque ce type de problème.

    As tu installé php-snmp ?
    Donnes nous le résultat de ton snmpget sur l'uptime.

    Leave a comment:


  • johnbob
    replied
    Oui, les Uptimes fonctionnent sans problèmes, sur n'importe quelle marchine.
    Mais je pensais dès le départ à un problème de droits, comme j'en ai eu plusieurs.

    Quels sont les fichiers concernés par les fiches d'identité d'Oreon ?
    Que je vérifie les droit en lecture ...

    Leave a comment:


  • wistof
    replied
    Hummm, pas rassurant ton histoire...

    Tes machines ne répondent pas à l'OID .1.3.6.1.2.1.1.3.0 (Uptime).

    Peux-tu valider ça avec un petit snmpget ?

    Leave a comment:


  • johnbob
    replied
    Merci, je ne connaissais pas cette possibilité.

    J'ai donc activé le debug de l'inventaire, puis j'ai lancé la mise à jour manuelle pour les fiches d'identité.
    Le fichier inventory.log est apparu, avec les mêmes informations pour chacun de mes serveur et équipement :
    Code:
    [...]
    Inventory : Host : SNMP Community => communaute01, SNMP Version => 1
    [24/07/2007 09:08] Inventory : Host : Don't seems to have SNMP, no uptime retrieved
    [24/07/2007 09:08] Inventory : Host : Name => SRV_01, ID => 70, Address => SRV_01.mon.domaine
    [...]

    Leave a comment:


  • wistof
    replied
    Hello,

    active le debug de l'inventaire (dans les options > options generales), puis analyse le fichier /usr/local/oreon/log/inventory.log

    Leave a comment:


  • toshiro
    replied
    bah désolé j avais cru pouvoir t'aider,
    te reste a verifier que les fichier generer son correct

    genre le host.cfg,

    si cela ne vient pas de là, va falloir demander de l'aide plus haut !!

    Leave a comment:

Working...
X