Announcement

Collapse
No announcement yet.

Interface Oreon vide

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Interface Oreon vide

    Bonjour à tous,

    Je viens de récupérer un serveur sur lequel sont installés Nagios (2.6) et Oreon (1.4).

    Nagios fonctionne correctement, tout remonte sans aucun problème.
    Par contre Oreon ne fonctionne qu'à moitié...
    La personne qui l'a installé n'est plus là et personne d'autre ne s'y est intéressé.

    On m'a demandé du coup de reprendre le flambeau :rolleyes:

    Bref, la configuration d'Oreon semble correcte, j'ai vérifié la majorité des paramètres, ça a l'air OK.

    En fait l'interface reste "vide".

    Je m'explique, déjà rien qu'en haut dans le bandeau supérieur, je n'ai que des points d'interrogation. Quand je clique sur "Accueil", je devrais avoir les stats des hosts, mais c'est encore vide...

    Quasiment tout est vide. Je continue a chercher, mais si quelqu'un aurait une piste dans laquelle je pourrais "creuser"...

    Merci d'avance
    Last edited by Guigui2607; 29 December 2008, 09:44. Reason: Réglé
    Guigui

    > PAS DE SUPPORT VIA MP <

    "Ce n'est qu'en essayant continuellement que l'on finit par réussir. En d'autres termes, plus ça rate et plus on a de chances que ça marche !!" (Shadoks)

  • #2
    heu... mon conseil serait de reinstaller oreon, ca prend pas beaucoup de temps en plus.
    Avant cela tu fais un backup de la base de données oreon
    options -> database et tu fais extraire

    Tu relance le install.sh tu repond
    ensuite soit en mysql ou avec phpmyadmin tu importe ta nouvelle base, tu regenere les fichiers de conf de nagios via oreon
    configuration -> nagios

    Lancer le debug de Nagios (-v) Oui
    Déplacer les fichiers Oui
    Recharger Nagios Oui Restart
    Master Sécurité des Systèmes d' Information
    Nagios v2.9 ||Nagios-plugins 1.4.9 || snmp v2c || Oreon 1.4 INside || ODS || 59 hosts && 128 services
    || Nagios Checker


    [email protected] vs Jonhbob le choc des GDR ^^

    Comment


    • #3
      Merci pour ta réponse.

      En cherchant un peu, j'ai vu que ODS ne trouve pas de fichier suivant:
      "/usr/local/oreon/ODS/etc/conf.pm"

      Je pensais aussi réinstallé Oreon.

      L'installation déjà existante n'a jamais vraiment servie... La personne qui a "bossé" dessus n'a pas fait grand chose dedans. C'était plus pour tester.

      Toutes les modifications de hosts ou de services ont continué à se faire par l'intermédiaire de Nagios. :rolleyes:

      A mon avis parce que Oreon ne tournait pas rond

      Je viens de voir que la version "centreon-1.4.1" est sortie aujourd'hui.
      Je vais essayé de réinstaller celle là... On verra bien.

      Je peux réinstaller par dessus sans problème ?

      Merci d'avance !
      Guigui

      > PAS DE SUPPORT VIA MP <

      "Ce n'est qu'en essayant continuellement que l'on finit par réussir. En d'autres termes, plus ça rate et plus on a de chances que ça marche !!" (Shadoks)

      Comment


      • #4
        ya une procédure de mise a jour sur le wiki

        http://wiki.oreon-project.org/index.php/SeTup

        en fonction la version que tu as suis le tuto, bon courage
        Master Sécurité des Systèmes d' Information
        Nagios v2.9 ||Nagios-plugins 1.4.9 || snmp v2c || Oreon 1.4 INside || ODS || 59 hosts && 128 services
        || Nagios Checker


        [email protected] vs Jonhbob le choc des GDR ^^

        Comment


        • #5
          Merci pour ce lien.

          Pour la base d'Oreon, je suis d'avis de repartir "à plat".

          Je sais que les fichiers de configurations actuels de Nagios sont OK.
          Vu qu'Oreon n'a jamais vraiment bien fonctionner, je voudrais repartir sur une base d'Oreon "vide" puis importer la configuration de Nagios.

          Je vais voir tout ça.
          Guigui

          > PAS DE SUPPORT VIA MP <

          "Ce n'est qu'en essayant continuellement que l'on finit par réussir. En d'autres termes, plus ça rate et plus on a de chances que ça marche !!" (Shadoks)

          Comment


          • #6
            Bon je galère

            J'ai récupéré la dernière version de Centreon. (1.4.1)

            J'ai lancé l'install.
            La partie "ligne de commande" se déroule bien, sans souci.

            Ensuite je passe à la fin de la configuration avec l'interface Web.

            C'est au moment où il veut upgrader la base Mysql que ça coince...
            La base n'est pas valide pour lui pas moyen de continuer...

            Y'a t'il moyen de recréer une nouvelle base oreon vierge?
            Si oui, comment ?

            Sinon, je ne vois pas comment faire :|

            Merci d'avance !
            Guigui

            > PAS DE SUPPORT VIA MP <

            "Ce n'est qu'en essayant continuellement que l'on finit par réussir. En d'autres termes, plus ça rate et plus on a de chances que ça marche !!" (Shadoks)

            Comment


            • #7
              Bon, ça y est, j'ai avancé...

              Pour repartir sur une base saine: (Merci à lindusfree )

              J'ai détruis le répertoire : /usr/local/oreon/
              J'ai détruis le fichier : /etc/oreon.conf
              J'ai détruis la base oreon dans Mysql.
              J'ai relancé l'installation de Centreon 1.4.1.

              Et voilà !

              Il ne me reste plus qu'à récupérer la conf existante de Nagios... :rolleyes:
              Guigui

              > PAS DE SUPPORT VIA MP <

              "Ce n'est qu'en essayant continuellement que l'on finit par réussir. En d'autres termes, plus ça rate et plus on a de chances que ça marche !!" (Shadoks)

              Comment

              Working...
              X