Announcement

Collapse
No announcement yet.

Nagios Reload/Restart

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ronanr
    replied
    etc/init.d/nagios2

    Hi

    I had the same problem, I wasn't able to restart nagios2 with centreon web interface.
    I tried many things..

    visudo was ok
    (I was able to restart in command line)

    Finally I checked options/nagios in centreon,
    I re entered something else in InitScript
    Then I re-entered /etc/init.d/nagios2
    And it worked !

    Hope That Helps !

    Thanks
    Ronan Reynaud

    Leave a comment:


  • Guigui2607
    replied
    Check rights on /etc/sudoers are 440 & Root Root
    I solved the same problem changing rights on this file...

    Leave a comment:


  • rsoares
    replied
    restart nagios

    I have a similar trouble.. when i ask to centreon restart nagios, nothing happens, no error has detectec by "nagios -v" only a few warnings, nothing appears in secure log... Im using nagios 2.0 and Centreon 1.4.1.. Some tip?

    Leave a comment:


  • sgrynd
    replied
    Please disregard the 1st part of my question about reloading/restarting nagios. I am simply either too fast or my server is to slow, probably the later, it is working fine.

    However I am curious about the service force check in the 2nd part of my post.

    Thanks for the help.

    Leave a comment:


  • sgrynd
    started a topic Nagios Reload/Restart

    Nagios Reload/Restart

    What is the proper way to place the cfg files and reload/restart nagios?

    I am setting to the following:
    Server - Localhost
    Generate Files - Yes
    Relations - Dependencies Management
    Include Comments - No
    Export in XML too - No
    Export Configuration Files (Traps SNMP) - No
    Nagios Debug - Yes
    Optimization - No
    Move Export Files - Yes
    Restart Nagios - Yes
    Reload - yes


    Sometimes I try restart instead of reload.

    After it runs through with out errors, my services/host changes aren't there. If I do a force refresh of the page they still don't show, but after trying the above serveral times in a row the changes show up. Is there a delay and I am just impatient?

    If I stop the nagios process and restart it at the CLI it seems to happen immediately.

    Also, if I tell a service to reschedule the next check or force the next check it still seems to take to when ever the original next check was schedule to happen. If I monitor the nagios.cmd file the entries are getting put in there.

    Thanks for the help!
Working...
X