Announcement

Collapse
No announcement yet.

Data not making it into the graphs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Data not making it into the graphs

    I am hoping someone can help me -
    When I originaly set everything up, things were working very well, about 10 hosts and 70 services.

    As everything was working I loaded up the server, I am now about an 1/8th of the way through the servers and currently have 102 hosts and 780 service checks. The check portion is working spot on.

    However my graphs have turned into a spotty mess. I did have some server troubles and had a few crashes which I fixed by adding some more ram and tweaking mySQL a bit.

    The ODS, nagios, mysqld services are all running. ODS is configured to work properly (was working with a small group).

    I have a ton of rrd files in /var/lib/ods/database that according to the time/date stamp are getting updated.

    I am using a drop file - (/usr/local/nagios/var/service-perfdata.tmp) which if I tail it shows recent entries. However the size to me seems wrong, not sure if this file is just supposed to grow or when it gets purged or if my problem is all the data is sitting in this file:

    -rw-r--r-- 1 nagios nagios 2223 Aug 21 10:32 service-perfdata
    -rw-r--r-- 1 nagios nagios 43513119 Aug 21 10:32 service-perfdata.tmp

    I have attached an image with what my graphs look like.

    Any help to get this working again or to get my graphs to catch up is greatly appreciated.

    Thanks,
    Sgrynd
    Attached Files

  • #2
    If no parsing is needed for perfdata after ODS job, don't use data retention in service-perfdata.tmp, it's useless.
    Put off the option, restart ODS and delete this file.

    For your graphs breakdown, just check if Centreon don't give you a too small heartbeat for your RRDsFile.
    For my experience "Normal check interval" equal "step" and "heartbeat" equal two "step".
    Last edited by DonKiShoot; 21 August 2007, 16:47.
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320

    Comment


    • #3
      Originally posted by DonKiShoot View Post
      If no parsing is needed for perfdata after ODS job, don't use data retention in service-perfdata.tmp, it's useless.
      Put off the option, restart ODS and delete this file.

      For your graphs breakdown, just check if Centreon don't give you a too small heartbeat for your RRDsFile.
      For my experience "Normal check interval" equal "step" and "heartbeat" equal two "step".
      Thanks, I have turned off that option and removed the file.

      I am a little confused about the 2nd part of what you said though.

      My check intervals are set to 5 mins on average, a few are 3 but those are a minority. I guess the part I am confused on is heartbeat? what or where is that setting.

      Thank you for your help, I can't tell you how much I appreciate it.

      Comment


      • #4
        You can use the command line :
        rrdtool info xxx.rrd

        where xxx.rrd is your rrd file in ./OreonDataStorage

        Comment


        • #5
          Can't help you much.
          You need to read rrdtool documentation to understand how Centreon and ODS deal with perfdata to give you graphics.
          Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
          Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
          Fedora Core 5 - 2.6.20-1.2320

          Comment


          • #6
            How does the stepping get set for the rrd file?

            Comment


            • #7
              stepping is setting by centreon and heartbeat too.
              Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
              Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
              Fedora Core 5 - 2.6.20-1.2320

              Comment


              • #8
                I am at a complete loss as to where that is set in centreon.

                Comment


                • #9
                  It's automaticly done by centreon you can't do anything.

                  You can only verify if parameters set by Centreon seems to be good for you and in case of no, open a bugtrack.

                  There is a lot of post who told about rrdbase problem and how to check how are formed this databases.
                  Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                  Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                  Fedora Core 5 - 2.6.20-1.2320

                  Comment


                  • #10
                    That is what I suspected, I believe that my problem is related to my server, as I wrote this mysql crashed on me again. It would appear I need to shore up the server better before I attempt to solve this issue.

                    Thanks for all the feedback.

                    Comment


                    • #11
                      I'm having the graph problems too after adding a lot of hosts. When increasing the interval of service checks, the graphs look better, when decreasing the interval they get worse.
                      When doing an rrddump on the file belonging to the corrupted graph, only 'NaN' is shown in the datarows instead of a valid value.

                      Also after upgrading 1.4.1_rc1 to 1.4.1 another graph problem occured. When opening 'Centreon View' I only see graphes after clicking on the 'magnifying glass' and then the graphs are splitted up now...
                      Not all values returned by a check in one graph - a single graph for each value.
                      Clicking on 'Centreon View' an error is displayed in Apache's logfile:
                      Code:
                      [Thu Aug 23 15:04:27 2007] [error] [client 10.15.49.113] PHP Notice:   
                      Undefined index:  base in /usr/local/oreon/www/include/views/graphs/graphODS/generateImages/generateODSImage.php on line 95, referer: ttp://myhost.mydomain/oreon/oreon.php?host_name=GB-FW-01&submitC=Graph&period=10800&start=&en
                      d=&o=&p=4&min=
                      Maybe somebody knows how to fix this... for problem#2 I'll take a look at it ASAP how to fix this and add a bug for it.

                      Regards, Elias P.

                      Comment


                      • #12
                        RRD database step is based on the normal_check_interval, when you add a service, we create the database according to it. If you change the normal_check_interval, the step became false, and you'll get 'nan' value.
                        To solve this problem, you have to generate again the rrd database in general options => centreon => manage. We'll take SQL datas, and create the rrd database with those values.
                        Romain Le Merlus
                        Centreon Forge
                        MERETHIS

                        Comment

                        Working...
                        X