Announcement

Collapse
No announcement yet.

'Run Nagios Debug' under Nagios>Generate gives no output

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 'Run Nagios Debug' under Nagios>Generate gives no output

    I've been running Nagios 2.9 and Oreon 1.4 on a Dell 2650 since May flawlessly. Since then I've been prepping the system to replace our current production system running Nagios 1.0.

    I habitually used the 'Run Nagios Debug (-v)' option under the Configuration>Nagios>Generate section to test my configs before I exported them and restarted Nagios. I went away for a week on vacation, now since I've come back the debug feature produces NO OUTPUT.

    Doing it manually on the box "./nagios -v ../etc/nagios.cfg" works fine and provides the expected debug output. Does anyone know what could cause this to mysteriously stop providing output?

    Appreciate the help (btw I leave my internship at the company this Friday Aug 24th, so any immediate input would be great)

    Thanks,
    P2iM0
    Last edited by p2im0; 22nd August 2007, 21:14.

  • #2
    First check your sudo configuration for Centreon.
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320

    Comment


    • #3
      Originally posted by DonKiShoot View Post
      First check your sudo configuration for Centreon.
      Care to elaborate a bit?
      Be sure the nagios user has sudo capabilities?

      Comment


      • #4
        Look your message and apache error file and with visudo check that :

        #Add by OREON
        User_Alias OREON=apache

        ## Nagios Restart
        OREON ALL = NOPASSWD: /etc/init.d/nagios restart
        ## Nagios reload
        OREON ALL = NOPASSWD: /etc/init.d/nagios reload
        ## Snmptrapd Restart
        OREON ALL = NOPASSWD: /etc/init.d/snmptrapd restart
        Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
        Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
        Fedora Core 5 - 2.6.20-1.2320

        Comment


        • #5
          Originally posted by DonKiShoot View Post
          Look your message and apache error file and with visudo check that :

          #Add by OREON
          User_Alias OREON=apache

          ## Nagios Restart
          OREON ALL = NOPASSWD: /etc/init.d/nagios restart
          ## Nagios reload
          OREON ALL = NOPASSWD: /etc/init.d/nagios reload
          ## Snmptrapd Restart
          OREON ALL = NOPASSWD: /etc/init.d/snmptrapd restart
          yes all of that is in the sudoers file.
          I wasn't sure if that was the default so I tried out adding

          Code:
          OREON ALL = NOPASSWD: /usr/local/nagios/bin/nagios -v
          just to see if it "should" have been there. Got nothing.

          Comment


          • #6
            BUMP.
            Any other suggestions? Reinstalling isn't an option as the box just went into production. Has anyone else even had this issue?

            Comment


            • #7
              same problem

              hello,
              My sudoers is correct but nagios dont restart through centreon. if you have a solution, please give me.
              do i restart my server after modify sudoers?
              thanks

              Comment


              • #8
                Hi,

                Check right on nagios binaries.

                all exec right for "Other" (chmod o+x /usr/bin/nagios)

                If you upgrade Nagios after install oreon/centreon, default right isn't 555.
                Centreon 2.x

                Comment


                • #9
                  'Run Nagios Debug' under Nagios>Generate gives no output

                  Hi,
                  right for binarie nagios is OK :
                  -rwxrwxr-x 1 nagios nagios 1453408 Oct 10 13:46 nagios
                  What else please ?

                  Comment


                  • #10
                    'Run Nagios Debug' under Nagios>Generate gives no output

                    the user nagios dont have password to be execute by the user apache. With solaris, the command is :
                    passwd -d nagios
                    It's OK now
                    good luck

                    Comment


                    • #11
                      You could also check that the path used by Centreon are the good ones:

                      Options -> General Options --> Nagios

                      Comment

                      Working...
                      X