Announcement

Collapse
No announcement yet.

Probléme de graph dans vue oreon

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Probléme de graph dans vue oreon

    Bonjour

    Faute d'expliquer je vous montre un screenshot.

    J'attends vos avis je vous donnerai toute les informations que vous avez besoin pour m'aider a trouver la solution du pourquoi ça n'affiche rien :d

    http://spx.hopto.org/oreon/graph.JPG

  • #2
    Salut,

    ods est-il lancé ?

    /etc/init.d/ods status

    et s'il n'y a rien :
    /etc/init.d/ods start

    @+
    ubuntu 7.04
    nagios 2.9
    Centreon 1.4.1

    Comment


    • #3
      Nous avons le même problème.
      http://forum.oreon-project.org/showthread.php?t=4747
      titou, j'ai déjà suivi de ce que tu m'as indiqué, mais ça ne donne toujours rien
      Ubuntu 7.04
      Centreon 1.4.1
      Nagios 2.6

      En cours de migration
      Ubuntu 7.10
      Centreon 1.4.1
      Nagios 2.9

      Comment


      • #4
        nagios:/# /etc/init.d/ods status
        PID TTY TIME CMD
        2416 pts/0 00:00:00 ods

        ods est bien démarré.

        Comment


        • #5
          Je ne trouve pas de précision sur le fonctionnement de ODS, qqn sait où je peux avoir quelques infos ?

          ça nous aiderait bien pour nous dépanner.
          Ubuntu 7.04
          Centreon 1.4.1
          Nagios 2.6

          En cours de migration
          Ubuntu 7.10
          Centreon 1.4.1
          Nagios 2.9

          Comment


          • #6
            Moi j'aimerai savoir pourquoi j'ai une page blanche...

            Est ce un problème avec RRDTOOL ?

            Comment


            • #7
              On est d'accord que nous avons tous une page blanche.
              Mais je pense que le problème est avant RRDTOOL. Car toi, comme moi, les hosts ne sont pas listés. C'est pour cette raison que j'ai demandé des infos sur ODS afin d'en savoir plus.

              Bien entendu, nous sommes tous impatient d'avoir un monitoring avec toutes les fonctionnalités.
              Ubuntu 7.04
              Centreon 1.4.1
              Nagios 2.6

              En cours de migration
              Ubuntu 7.10
              Centreon 1.4.1
              Nagios 2.9

              Comment


              • #8
                S'il n'y a aucun host de listé dans les vues Oreon c'est qu'aucune perfdata n'est remontée dans la base ODS. Vu que le service tourne apparemment bien c'est qu'il doit y avoir un problème au niveau de la génération ou de la prise en compte du fichier de données.

                - Est-ce que perfdata et le plugin/commande associés (process-service-perfdata) sont bien présents et activés dans Nagios ?
                - Est-ce que le chemin vers le fichier service-perfdata (nagios_dir/var/service-perfdata) et les droits sur celui-ci sont corrects ?
                - ODS et RRDTOOL sont-ils bien configurées dans Oreon ?

                Normalement avec une installation stardard via install.sh tout s'active correctement, il n'y a qu'à modifier un ou deux détails dans les options. Sinon en suivant le wiki ça devrait permettre de tout corriger : http://wiki.oreon-project.org/index.php/Graphs
                Système : Debian Etch 4.0r8 / Apache 2.2.3 / PHP 5.2.0 / MySQL 5.0.32
                Monitoring : Nagios 2.12 / Plugins 1.4.13 / Centreon 1.4.2.7

                Comment


                • #9
                  Originally posted by -Archi- View Post
                  S'il n'y a aucun host de listé dans les vues Oreon c'est qu'aucune perfdata n'est remontée dans la base ODS. Vu que le service tourne apparemment bien c'est qu'il doit y avoir un problème au niveau de la génération ou de la prise en compte du fichier de données.

                  - Est-ce que perfdata et le plugin/commande associés (process-service-perfdata) sont bien présents et activés dans Nagios ?
                  - Est-ce que le chemin vers le fichier service-perfdata (nagios_dir/var/service-perfdata) et les droits sur celui-ci sont corrects ?
                  - ODS et RRDTOOL sont-ils bien configurées dans Oreon ?

                  Normalement avec une installation stardard via install.sh tout s'active correctement, il n'y a qu'à modifier un ou deux détails dans les options. Sinon en suivant le wiki ça devrait permettre de tout corriger : http://wiki.oreon-project.org/index.php/Graphs

                  Effectivement cette page du wiki explique bien comment bien configurer Centreon pour l'obtention de graphiques.

                  J'ai répondu a Biowan dans un autre thread. J'y ai mis un lien vers un dossier d'exploitation en français pour les non bilingues :wink:
                  http://forum.oreon-project.org/showp...22&postcount=7
                  Guigui

                  > PAS DE SUPPORT VIA MP <

                  "Ce n'est qu'en essayant continuellement que l'on finit par réussir. En d'autres termes, plus ça rate et plus on a de chances que ça marche !!" (Shadoks)

                  Comment


                  • #10
                    Encore merci Messieurs.
                    SPX, ça fonctionne pour moi si jamais.
                    Ubuntu 7.04
                    Centreon 1.4.1
                    Nagios 2.6

                    En cours de migration
                    Ubuntu 7.10
                    Centreon 1.4.1
                    Nagios 2.9

                    Comment


                    • #11
                      Je vois cela demain matin je test tout ça et vous tiens au courant

                      Comment


                      • #12
                        Pour moi aussi c'est good thx a lot

                        Comment

                        Working...
                        X