Announcement

Collapse
No announcement yet.

Fatal error :)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • julio
    replied
    pour redemarrer nagios tu vas dans : monitoring -> process info -> redemarrer le serveur.

    La c'est une external command et donc plus besoin de sudo... je vauis passer l'autre aussi comme ca...

    Leave a comment:


  • gringo
    replied
    hmm ah oué .... pour que mes modifs soient prises en compte, il faut ke je kill -HUP nagios.
    Ya til moyen alors de configurer sudo manuellement ? et si oui, que faut-il faire ?

    merci

    Leave a comment:


  • julio
    replied
    A mon avis c le sudi qui n'a pas fonctionné ! quand tu redémarre a la main ton server (en ligne de commande ) est ce que ca prend bien en compte les modifs ? Si c'est ca c'est que l'install a pas su configurer le sudo .

    pour les droits dans l'interface nagios, c'est que tu te logue pas en nagiosadmin.

    Leave a comment:


  • gringo
    replied
    bon jme reponds a moi meme ... les explications sil yen a sont bien venues

    g restart nagios et hop tout est apparu ...... nice g cru ke jallais devenir fou sur cette erreur

    Leave a comment:


  • gringo
    replied
    Originally posted by gringo
    et me voila reparti pour toute une journee nagios/oreon

    bon, g changé les droits mais ca n'y fait rien ... je sais pas trop koi faire la ...

    parce que par ex, g editer le fichier /usr/local/nagios/etc/hosts.cfg
    et ya bien les modifs... jveux dire par la que ya bien les hosts que g adder par l'interface. donc il a bien pris en compte le "appliquer"


    petite question...
    comme je vous ai dit, ya aussi une base oracle sur la machine ou je test oreon et donc, oracle fonctionnait en premier avec apache. les owner dans le fichier httpd.conf est:
    User oracle
    Group dba
    alors g fait d test de chown avec apache, oracle mais marche pas
    jcommence un peu a me perdre ds les droits

    pt1 c'est rude dinstaller sur une machine ou ya deja pl1 de trucs

    1h plus tard ...
    Bon je viens réediter ce post
    Je crois que c vraiment que la page monitoring qui marche pas tres tres. Ya que le sample localhost qui fonctionne.
    G essayer dans "process info" d'executer une "process command" mais ca fait pas grand ... est normal ou ca chie ?



    i need u
    qq heures plus tard ... :lol: :twisted:
    je v ds monserver/nagios , je rentre mon log/pass pr le htaccess
    et je v voir la section hostdetail ... et la oh grande surprise mais pas tres ...
    It appears as though you do not have permission to view information for any of the hosts you requested...
    If you believe this is an error, check the HTTP server authentication requirements for accessing this CGI
    and check the authorization options in your CGI configuration file.

    hmmm ?

    Leave a comment:


  • gringo
    replied
    et me voila reparti pour toute une journee nagios/oreon

    bon, g changé les droits mais ca n'y fait rien ... je sais pas trop koi faire la ...

    parce que par ex, g editer le fichier /usr/local/nagios/etc/hosts.cfg
    et ya bien les modifs... jveux dire par la que ya bien les hosts que g adder par l'interface. donc il a bien pris en compte le "appliquer"


    petite question...
    comme je vous ai dit, ya aussi une base oracle sur la machine ou je test oreon et donc, oracle fonctionnait en premier avec apache. les owner dans le fichier httpd.conf est:
    User oracle
    Group dba
    alors g fait d test de chown avec apache, oracle mais marche pas
    jcommence un peu a me perdre ds les droits

    pt1 c'est rude dinstaller sur une machine ou ya deja pl1 de trucs



    i need u

    Leave a comment:


  • julio
    replied
    Ah ! a mon avis c apache qui n'a pâs les droits dans /usr/local/nagios/etc/ .

    fait un petit "chown apache:apache /usr/local/nagios/etc/*" et ca devrait marcher.

    Leave a comment:


  • gringo
    replied
    c'est ce que j'ai fait
    c pour ca g posté

    Nagios 1.2
    Copyright (c) 1999-2004 Ethan Galstad ([email protected])
    Last Modified: 02-02-2004
    License: GPL
    Reading configuration data...
    Running pre-flight check on configuration data...
    Checking services...

    Checked 10 services.

    Checking hosts...

    Checked 1 hosts.

    Checking host groups...

    Checked 1 host groups.

    Checking contacts...

    Checked 1 contacts.

    Checking contact groups...

    Checked 2 contact groups.

    Checking service escalations...

    Checked 0 service escalations.

    Checking host group escalations...

    Checked 0 host group escalations.

    Checking service dependencies...

    Checked 0 service dependencies.

    Checking host escalations...

    Checked 0 host escalations.

    Checking host dependencies...

    Checked 0 host dependencies.

    Checking commands...

    Checked 32 commands.

    Checking time periods...

    Checked 4 time periods.

    Checking for circular paths between hosts...
    Checking for circular service execution dependencies...
    Checking global event handlers...
    Checking obsessive compulsive service processor command...
    Checking misc settings...
    Total Warnings: 0
    Total Errors: 0
    Things look okay - No serious problems were detected during the pre-flight check

    Leave a comment:


  • julio
    replied
    apres il faut que tu generes les fichiers de configuration de nagios. Il ne suffit pas de les creer, il faut ensuite les extraire vers le rep de nagios.

    Pour ca tu vas dans Configuration->Appliquer et tu fais generer et appliquer.

    la tes fichiers seront alors déplacé dans le rep etc de nagios...

    Leave a comment:


  • gringo
    replied
    tu supposes bien

    mais c'est apres avoir générer les fichiers de conf.

    Ptit truc je pige pas:
    Dans le monitoring, meme apres avoir ajouter des services et des new hosts, je ne vois toujours que localhost dans la partie service details.
    C moi qui est fait n'importe quoi ou ... ?

    Je suis aller voir dans http://monserveur/nagios/ pour voir si yavé bien les hots que javais add sous /oreon mais je les vois pas a part localhost ( remarq: je sais pas si on peut verifier comme ca)

    Leave a comment:


  • julio
    replied
    je suppose biensur que une fois déloggué et reloggé, ca fonctionnait sans pb

    Sinon peux tu me dire si tu avais déjà généré les fichiers de configuration ou si ti etais encore avec les sample de test que nous avons mis de base ?

    Leave a comment:


  • gringo
    started a topic Fatal error :)

    Fatal error :)

    Bon, linstallation est finie non sans difficulté
    g commencer a naviguer dans l'interface oreon, à adder un host, admin etc ...
    puis en me rereballadant ,g trouver plusieurs erreurs:

    -Services Problems
    Fatal error: Call to a member function on a non-object in /usr/local/oreon/parselogfile.php on line 232Host Service Status Last Check Duration Attempts Status Information


    -Available Host
    Serveur_George
    Fatal error: Call to a member function on a non-object in /usr/local/oreon/host.php on line 229

    any ideas ?
Working...
X