Announcement

Collapse
No announcement yet.

[REGLE]PHP Warning: failed to open stream: Permission denied

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [REGLE]PHP Warning: failed to open stream: Permission denied

    Je suis sous Fedora 4 php5 j'ai installé nagios et oreon et lorsque je veux générer les fichiers de config nagios j'ai un message d'erreur !
    dans la log d'apache j'ai ca :
    PHP Warning: fopen(./nagios_cfg/misccommands.cfg) [function.fopen]: failed to open stream: Permission
    denied in /usr/local/oreon/include/export/functions.php on line 64

    sachant que les droits du repertoire oreon sont 775 et le group apache:apache
    est ce qu'il y a des modifs a faire sous apache (fichier de conf)???faut -il desactivé de module suexec ??
    ou alors modifier les comptes apache , nagios , nagiocmd ou oreon !!! les groupes ???
    ou peux etre encore le php.ini ???
    car je ne vois pas pourquoi il ne peux pas acceder au fichier ???
    Intel(R) Bi P3 CPU 2 GHz - Mem : 512 M
    Fedora Core 4 - Nagios 1.2 - Nagios Plugins 1.4.1 - Oreon 1.2.2RC3

  • #2
    le rep nagios_cfg existe bien ?
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      oui !
      Intel(R) Bi P3 CPU 2 GHz - Mem : 512 M
      Fedora Core 4 - Nagios 1.2 - Nagios Plugins 1.4.1 - Oreon 1.2.2RC3

      Comment


      • #4
        moi j'ai testé sous fedora core 4, j'ai pas eu ce pb. c'est a mon avis un pb de droit... si le fichier misscommands.cfg existe, degage le... mais je ne pense pas que ca vienne de la.
        Julien Mathis
        Centreon Project Leader
        www.merethis.com |

        Comment


        • #5
          et tu es egalement en php5 ??
          si non t'as pas une autre idée ??
          Intel(R) Bi P3 CPU 2 GHz - Mem : 512 M
          Fedora Core 4 - Nagios 1.2 - Nagios Plugins 1.4.1 - Oreon 1.2.2RC3

          Comment


          • #6
            Il y a t'il eu une suite à ce PB car je rencontre la meme erreure :

            Le rep nagios_cfg existe bien
            les fichiers sont la en 777 appartenant a apache:apache

            avez vous une soluce ?

            Comment


            • #7
              moi j'etais aussi en PHP5... mais comme ct une machine test donc g formaté... je vais recommencer demain sur un VM.... je vous tiens au courant.
              Julien Mathis
              Centreon Project Leader
              www.merethis.com |

              Comment


              • #8
                c'est bon j'ai trouve !
                c'etait un probleme de config de SELINUX !
                Intel(R) Bi P3 CPU 2 GHz - Mem : 512 M
                Fedora Core 4 - Nagios 1.2 - Nagios Plugins 1.4.1 - Oreon 1.2.2RC3

                Comment


                • #9
                  c'est à dire ?
                  il y a un processus qui réapplique des chmod/chown sur les répertoires régulierement ? (comme msec sous Mandrake) ?

                  explique-nous, ça peut en interresser d'autre

                  sinon, peux-tu rajouter [REGLE] dans ton titre

                  merci
                  StatusMap Module - NDO Tools Module - ImportCSV Module - SNMP-UI Module - PDFReports Module
                  Dons Paypal

                  Comment


                  • #10
                    ce serait cool que tu puisses nous expliquer ce que t'a fais car je commence à décourager...

                    Comment


                    • #11
                      Ok j'ai trouvé il faut mettre selinux en disabled dans /etc/sysconfig/ vi selinux

                      This file controls the state of SELinux on the system.
                      # SELINUX= can take one of these three values:
                      # enforcing - SELinux security policy is enforced.
                      # permissive - SELinux prints warnings instead of enforcing.
                      # disabled - SELinux is fully disabled.
                      SELINUX=disabled
                      # SELINUXTYPE= type of policy in use. Possible values are:
                      # targeted - Only targeted network daemons are protected.
                      # strict - Full SELinux protection.
                      SELINUXTYPE=targeted

                      Comment


                      • #12
                        [REGLE]

                        Sous fedora 4 ou 3 dans le menu parametres de systeme > niveau de securité> (onglet) SElinux >(fenetre du bas ) dans autre >cocher httpd_suexec_disable_trans
                        Voilou !
                        Intel(R) Bi P3 CPU 2 GHz - Mem : 512 M
                        Fedora Core 4 - Nagios 1.2 - Nagios Plugins 1.4.1 - Oreon 1.2.2RC3

                        Comment


                        • #13
                          Originally posted by wistof
                          sinon, peux-tu rajouter [REGLE] dans ton titre

                          merci
                          StatusMap Module - NDO Tools Module - ImportCSV Module - SNMP-UI Module - PDFReports Module
                          Dons Paypal

                          Comment

                          Working...
                          X