Announcement

Collapse
No announcement yet.

[REGLE] Surveillance des graphiques

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • inconnuflo
    replied
    Koool alors je vais rester avec rrdtool 1.2.11-0.2

    et merci encore :P :wink:

    Leave a comment:


  • wistof
    replied
    Originally posted by inconnuflo
    un peu lourd mais ca fonctionne
    c'est réparé pour la prochaine release

    Leave a comment:


  • inconnuflo
    replied
    pas mal l'astuce

    un peu lourd mais ca fonctionne

    bon je change l'intitulé pour dire que c'est réglé

    Leave a comment:


  • wistof
    replied
    ouais, c'est un chtit bug.... corrigé sur le cvs, et y a un workaround... mais je trouve pas le post...

    tu passe la version de rrdtool en 1.0 dans les opt_gen, puis tu passes tes graph en png, et en suite, tu repasse en 1.2...

    Leave a comment:


  • inconnuflo
    replied
    Originally posted by wistof
    yep !!! les scripts utilisent rrdtool 1.2 via librrds-perl, et Oreon rrdtool 1.0.49 via le binaire...

    (dans ton cas)
    Ok donc il ne faut pas que j'install RRDtool via nagios
    mais plutot que je le fasse à la mano

    par contre, là il faut que je vérifie
    maintenant j'ai bien mon graph qui apparait mais dès ue je veux faire une modif sur le titre vertical, sur la couleur de la trame de fond etc...

    je n'ai plus le graph et j'ai un nouveau msg d'erreur:
    ERROR: unsupported graphics format 'GIF'
    Or je n'ai pas trop le choix en rrdtool 1.2, ce n'est que du GIf, je ne peux pas mettre du PNG


    y a t il une raison ?

    Leave a comment:


  • WAtt
    replied
    C'est dommage parce que les graph avec rrdtool 1.2 sont super beau.

    je ... :arrow:

    Leave a comment:


  • wistof
    replied
    yep !!! les scripts utilisent rrdtool 1.2 via librrds-perl, et Oreon rrdtool 1.0.49 via le binaire...

    (dans ton cas)

    Leave a comment:


  • inconnuflo
    replied
    les test fonctionent tr-s bien. je créer bien le rrd
    et j'arrive à voir ces infos

    par contre le perl-rrdtool, ca doit surment correpondre à ca sous debian
    librrds-perl 1.2.11-0.2 Time-series data storage and display system
    ????

    et donc ca serait lui mon coupable !!!??????

    Leave a comment:


  • wistof
    replied
    si tu fais :
    /usr/local/rrdtool-1.0.49/bin/rrdtool create temperature.rrd --step 300 DS:temp:GAUGE:600:-273:5000 RRA:AVERAGE:0.5:1:1200 RRA:MIN:0.5:12:2400 RRA:MAX:0.5:12:2400 RRA:AVERAGE:0.5:12:2400
    puis
    /usr/local/rrdtool-1.0.49/bin/rrdtool info temperature.rrd
    filename = "temperature.rrd"
    rrd_version = "0001"
    step = 300
    last_update = 1124810191
    ds[temp].type = "GAUGE"
    ds[temp].minimal_heartbeat = 600
    ds[temp].min = -2.7300000000e+02
    ds[temp].max = 5.0000000000e+03
    ......
    c'est bon...

    sinon, c'est ton package perl-rrdtool qui est en 1.2 ??

    Leave a comment:


  • inconnuflo
    replied
    et ce ki est trop fort c'est qu'avec les versiosn précentes d'Oreon, je n'ai jamais eu ce pb là

    Leave a comment:


  • inconnuflo
    replied
    si je fais un find, je ne trouve que ca:

    #find / -name rrdtool -print
    /usr/local/rrdtool-1.0.49/bin/rrdtool
    #

    Leave a comment:


  • wistof
    replied
    bizarre, il me semble que la version 003 est généré par la 1.2...

    tu peux pas faire un
    slocate rrdtool
    pour voir

    Leave a comment:


  • inconnuflo
    replied
    non je n'ai que la version 1.0.49
    je viens de re-lister tous mes paquets installer, et je n'ai pas de rrdtool



    mes fichiers rrds se créent bien
    lorsque j'exécute la cmd:
    /usr/local/rrdtool-1.0.49/bin/rrdtool info /usr/local/oreon/rrd/1.rrd
    j'ai ce fameux msg d'erreur:
    ERROR: can't handle RRD file version 0003

    Leave a comment:


  • wistof
    replied
    tu n'aurais du rrdtool 1.2 et 1.0.49 sur la meme machine ?

    est ce que les fichier rrds sont créés ?

    si oui, peux tu faire un
    rrdtool info xx.rrd

    Leave a comment:


  • inconnuflo
    replied
    d'après le epu que je suis en train de lire, cette erreur viendrait du fait d'utiliser le rrdtoo d'un verison supérieur à 1.0.xx

    Or dans mon cas, je n'utilise que la version 1.0.49 qui s"install avec nagios

    je ne comprends pas !!

    Leave a comment:

Working...
X