Announcement

Collapse
No announcement yet.

Help me !!!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help me !!!!

    Oreonien, Oreonienne bonjour !

    En ce beau matin ensoleillé d'autonme, j'ai voulu rajouter un tout petit host a ma config oreon, mais voila j'y arrive pas !!!!! une fois que je rentre tout les indice pour la config je clique sur sauvegarder et la jarrive sur une page blanche ou seul les menus du haut et de gauche apparaisse !! Quand je veut retourner sur ma fenetre de surveillance il y a bien les premier service mais le soucis c'est que la barre de scrol a disparu ! meme probleme pour les fenetre dans configuration !

    pour info j'ai installer 84 services et 42 Hosts....

    A quoi cela peu etre du ? Oreon saturerait vite ???? ou alors est-ce que sa peut-etre du a ma machine ou est installer oreon qui n'est pas bien puissante ????????

    Merci d'avance

  • #2
    As tu un message relatif a la memeory limit ? Si oui elle est a combien sur ton poste ? On conseille de la monter au moins a 16, voir 32. On a identifie le probleme de cette monter en memoire importante et ca devrait etre resolu dans de futurs versions.

    Si ce n'est pas... et bien donne nous de nouveaux indices
    Romain Le Merlus
    Centreon Forge
    MERETHIS

    Comment


    • #3
      Hello,
      je vien de mettre ma memory limit a 32 et ye toujour rien !
      J'ai aucun message d'erreur alors je ne voi pas trop quoi donner de + comme indices....

      Comment


      • #4
        As tu restarte httpd ? sorti de l'interface et reloggé ? Lu les logs d'error de httpd ?
        Romain Le Merlus
        Centreon Forge
        MERETHIS

        Comment


        • #5
          oui j'ai restart httpd, oui je me suis reloguer après etre sorti de l'interface et le message d'erreur de mon log httpd est :
          PHP Fatal error: Call to a member function on a non-object in /usr/local/oreon/host.php on line 223, referer: http://nagios/oreon/oreon.php?p=102&o=a

          Comment


          • #6
            Bon tu es bien avec la version 1.2.2 ?
            Ca ressemble a une merde dans l'objet.
            Ton host que tu as cree est base sur un template isnt'it ? Alors comme solution je te propose d'aller modifier dans la base le fait que ton host est base sur un template. Pour la table host tu mets a vide le champ host_template_model_htm_id (car il doit y avoir une valeur), tu enregistres, tu te deloggues et reloggue.
            Normalement, cela doit fonctionner, ton host ne doit plus etre valide car il lui manque des valeurs (qui etaient dans le template).
            Tu l'effaces l'host en question (car maintenant tu peux utiliser Oreon sans que ca plante) et tu recommences ton action qui t'avait mene a ce bug. Si l'erreur persiste, merci de m'envoyer la conf de ton template et la conf de l'host que tu voulais saisir.

            :!:
            Romain Le Merlus
            Centreon Forge
            MERETHIS

            Comment


            • #7
              oui j'ai bien la version 1.2.2
              Et ma case host-template est vide !!!!

              Comment


              • #8
                Oui et bien je donne ma langue au chat, pour faire simple, tu vas aller supprimer ton host dans ta table (en prenant bien en note son ID), et ses relations.
                Execute ceci :

                DELETE FROM host WHERE host_id = ID;
                DELETE FROM host_hostparent_relation WHERE host_parent_hp_id = ID;
                DELETE FROM host_hostparent_relation WHERE host_host_id = ID;
                DELETE FROM host_service_relation WHERE host_host_id = ID;

                Pareil, deloggue, reloggue... Reesaie l'operation..

                Tu as voulu ajouter un host normalement en fait, sans template et ca n'a pas marché ??? etrange quand meme..
                Romain Le Merlus
                Centreon Forge
                MERETHIS

                Comment


                • #9
                  Tu as tout compris j'ai juste voulu installer un pti host de rien du tout sans model de template.
                  Etrange en effet c'est bien le mot....
                  Merci qd meme de ton aide si je parvien a faire quelque chose je te tien au courant

                  Comment

                  Working...
                  X