Announcement

Collapse
No announcement yet.

[2.2.2] COUNTER dont work ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [2.2.2] COUNTER dont work ?

    Centreon still dont create COUNTER rrds ? So, how can be standard traffic interpreted by COUNTER and not GAUGE method, but other rrds only as GAUGE ? Using graph template 'Traffic' only create in/out graph, but dont help to make COUNTER rrds.

    [[email protected] libexec]# ./check_centreon_snmp_traffic -H X.X.X.X -i eth1 -C X -v 1 -T 2
    Traffic In : 970.67 b/s (0.0 %), Out : 1.01 kb/s (0.1 %) |traffic_in=970,7Bits/s;1600000;1900000;0;2000000 traffic_out=1005,3Bits/s;1600000;1900000;0;2000000
    dcentreon-Traffic eth0.jpg
    [[email protected] libexec]# ./centreon_snmp_oracle_sqlnet1.php --host=X --sid=orcl --user=X--passwd=X
    ORCL:SQL*net OK - In: 3.42 Mb/s Out: 2.73 Mb/s Roundtrips: 14 kb/s|traffic_in=3584330c traffic_out=2865016c roundtrips=14049c
    X-ORCL SQLnet traffic2.jpg
    [[email protected] libexec]# ./centreon_snmp_oracle_sqlnet.php --host=X --sid=orcl --user=X --passwd=X
    ORCL:SQL*net OK - In: 3.42 Mb/s Out: 2.73 Mb/s Roundtrips: 14 kb/s|traffic_in=3582017Bits/s traffic_out=2861629Bits/s roundtrips=14034
    X-ORCL SQLnet traffic.jpg

    How i can translate those counters to gauge by the same way standard centreon plugin for traffic do ? All rrds created for those services are GAUGE (centreon plugin traffic too!)
    Last edited by czairwolfoc; 17th October 2011, 16:40.

  • #2
    I would love to know the answer to this too. There was a patch provided for previous versions. Why hasn't that been incorporated into the code base?

    Comment


    • #3
      Hi,

      Did you try this::

      Administration=>Options=>Centstorage=>Manage

      Choose your metric and in actions menu you can set rrd DataSource type to COUNTER.
      Open Source Monitoring Addict
      OS: Ubuntu / Debian / CentOS / RedHat / Solaris / Arch Linux / Open Suse


      ! NO SUPPORT IN PRIVATE MESSAGE !

      Comment


      • #4
        Originally posted by cjudith View Post
        Hi,

        Did you try this::

        Administration=>Options=>Centstorage=>Manage

        Choose your metric and in actions menu you can set rrd DataSource type to COUNTER.
        In Centreon 2.3 solved with quote, probably "c" in perfdata will work too automatically.

        Comment

        Working...
        X