Announcement

Collapse
No announcement yet.

Problème de service centreon sur un host

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problème de service centreon sur un host

    Bonjour,

    Voici ma config :
    Debian lenny
    nagios 3.0.6
    centreon 2.1.4

    Alors tout fonctionne bien depuis 1 ans avec une vingtaine d'hôtes et une centaine de services.... jusqu'à aujourd'hui !
    J'ajoute un service à un hôte (cet hôte est ma machine de monitoring, où centreon & nagios sont installés, peut être c'est lié...)
    dans nagios tout va bien le service est bien ajouté à l'interface web.
    Par contre dans centreon aucun ligne correspondant à ma sonde !

    si j'ajoute ce service à une autre machine là ça marche.

    J'ai tenté de renommer le service, de delete les bases rrd liés à mon hôte, de rebuilder les bases RRD de tous les services mais ça ne fait rien ....
    Pourtant dans service state (en haut a droite) j'ai bien un service en plus, et il est marqué comme "ok"
    dans le dashboard le service est listé aussi ...

    J'ai regardé les logs mais je ne trouve rien d'inhabituel....

    Une idée ?

    Merci
    Debian Lenny / Nagios 3.0.6 / Centreon 2.1.4

  • #2
    Hello,

    Quel est ce service ?

    Quelle version de centreon ? nagios ?

    Quel OS ?
    Open Source Monitoring Addict
    OS: Ubuntu / Debian / CentOS / RedHat / Solaris / Arch Linux / Open Suse


    ! NO SUPPORT IN PRIVATE MESSAGE !

    Comment


    • #3
      Très étrange en effet de voir ton service dans service state et dashboard ainsi que sur un autre hôte :/

      Pas de double instance de Nagios ?
      Centreon Syslog Module Manager/Developper
      Centreon E2S Module Manager/Developper
      Centreon Enterprise Server (2.x / 3.x) : Centreon Engine 1.3.x / 1.4.x, Centreon Broker 2.6.x / 2.8.x , Centreon 2.x, Centreon-Syslog 1.5.x, Centreon E2S 2.0
      Nagios 3.x et NDOutil 1.x

      Comment


      • #4
        Merci pour vos réponses

        "double instance"
        tu demandes si nagios aurait été lancé deux fois par erreur ?

        monitor:~# ps aux | grep -i nagios
        nagios 2673 0.0 0.0 4552 356 ? Ss Nov16 0:00 /usr/sbin/ndo2db -c /etc/nagios3/ndo2db.cfg
        nagios 2815 0.0 0.1 9692 4804 ? SN Nov16 0:01 /usr/bin/perl -w /usr/local/centreon/bin/centcore
        nagios 14045 0.0 0.0 4684 1484 ? S Nov16 1:56 /usr/sbin/ndo2db -c /etc/nagios3/ndo2db.cfg
        nagios 14046 0.0 0.0 14524 1784 ? SNsl Nov16 1:10 /usr/sbin/nagios3 -d /etc/nagios3/nagios.cfg
        nagios 22425 0.0 0.1 13768 3160 ? S 02:00 0:00 /usr/bin/perl -w /usr/local/centreon/bin/centstorage
        root 30889 0.0 0.0 3148 848 pts/1 S+ 12:45 0:00 grep -i nagios

        Apres reboot j'ai la même chose.

        (Au niveau du service il s'agit de check_linux_raid pour surveiller un raid 1 avec mdadm
        ça fait la même chose avec n'importe quel service, cela est lié a mon host.)
        Last edited by magic_swamp; 18th November 2011, 14:12.
        Debian Lenny / Nagios 3.0.6 / Centreon 2.1.4

        Comment


        • #5
          Le service est bien présent dans la configuration de nagios ?

          Dans le fichier services.cfg
          Open Source Monitoring Addict
          OS: Ubuntu / Debian / CentOS / RedHat / Solaris / Arch Linux / Open Suse


          ! NO SUPPORT IN PRIVATE MESSAGE !

          Comment


          • #6
            Je n'ai aucun soucis avec nagios comme cité plus haut.
            Debian Lenny / Nagios 3.0.6 / Centreon 2.1.4

            Comment


            • #7
              Si les information sont dans Nagios et pas dans Centreon regarde plutot vers to broker.

              Tu peux aussi regarder si les services sont bien en base de données.
              Open Source Monitoring Addict
              OS: Ubuntu / Debian / CentOS / RedHat / Solaris / Arch Linux / Open Suse


              ! NO SUPPORT IN PRIVATE MESSAGE !

              Comment


              • #8
                Alors les infos sont bien dans la base ....

                Je viens de dupliquer mon host et tout les services s'affichent correctement pour celui ci.
                Je n'ai donc pas trouvé pourquoi mais cela à réglé mon problème.
                Je vais donc supprimer l'ancien host.

                Merci pour vos pistes

                ######################################
                Affichage centreon
                ######################################

                "Monit" est mon host qui bug, "monitor" est mon nouveau host dupliqué à partir de "Monit"; ils ont donc exactement les même services associés mais on voit bien qu'il en manque sur "Monit"

                Monit Disk-/ OK 7M 4d 20h 38m 53s 18/11/2011 14:42:36 1/3 (H) Disk OK - / TOTAL: 70.847GB USED: 14.577GB (20%) FREE: 56.270GB (80%)
                Load OK 7M 4d 20h 37m 25s 18/11/2011 14:44:17 1/3 (H) load average: 0.09, 0.09, 0.08.
                Memory OK 7M 4d 20h 35m 57s 18/11/2011 14:45:57 1/3 (H) total memory used : 3% ram used : 12%, swap used 0%
                Nodal_temp OK 3M 1w 6d 12h 14m 4s 18/11/2011 14:48:41 1/3 (H) OK Nodal Temp is 20
                Ping OK 7M 4d 20h 33m 18/11/2011 14:44:40 1/3 (H) GPING OK - rtt min/avg/max/mdev = 0.012/0.014/0.016/0.001 ms
                swap OK 7M 4d 20h 38m 49s 18/11/2011 14:48:01 1/3 (H) Disk OK - Swap space TOTAL: 2.528GB USED: 0.000GB (0%) FREE: 2.528GB (100%)

                monitor check_mdadm_monit OK 1h 33m 26s 18/11/2011 14:46:18 1/3 (H) OK md0 status=[UU].
                Disk-/ OK 1h 31m 49s 18/11/2011 14:47:55 1/3 (H) Disk OK - / TOTAL: 70.847GB USED: 14.577GB (20%) FREE: 56.270GB (80%)
                Load OK 1h 30m 6s 18/11/2011 14:42:38 1/3 (H) load average: 0.04, 0.10, 0.09.
                Memory OK 1h 28m 23s 18/11/2011 14:44:21 1/3 (H) total memory used : 3% ram used : 12%, swap used 0%
                Nodal_temp OK 1h 26m 40s 18/11/2011 14:46:04 1/3 (H) OK Nodal Temp is 20
                Nodal_temp_test2 OK 1h 24m 57s 18/11/2011 14:47:47 1/3 (H) OK Nodal Temp is 20
                Ping OK 1h 35m 9s 18/11/2011 14:44:35 1/3 (H) GPING OK - rtt min/avg/max/mdev = 0.010/0.014/0.017/0.004 ms
                swap OK 1h 31m 43s 18/11/2011 14:48:01 1/3 (H) Disk OK - Swap space TOTAL: 2.528GB USED: 0.000GB (0%) FREE: 2.528GB (100%)

                ######################################
                Last edited by magic_swamp; 18th November 2011, 15:52.
                Debian Lenny / Nagios 3.0.6 / Centreon 2.1.4

                Comment


                • #9
                  C'était vraiment étrange comme problème, j'avais jamais vu ça. :/
                  Open Source Monitoring Addict
                  OS: Ubuntu / Debian / CentOS / RedHat / Solaris / Arch Linux / Open Suse


                  ! NO SUPPORT IN PRIVATE MESSAGE !

                  Comment


                  • #10
                    Je serai curieux de savoir si des ACLs s'appliquait à cet host (ou au moins au login de connexion) ?
                    Centreon 2.3.9 - Nagios 3.3.1 - 1800 hosts - 7000 services - 15 pollers avec NDO.

                    Comment

                    Working...
                    X