Announcement

Collapse
No announcement yet.

Mes graphs ne fonctionnent pas et mes RRD ne contiennent que des NaN

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mes graphs ne fonctionnent pas et mes RRD ne contiennent que des NaN

    Bonjour,
    L'explication de mon problème tient dans le titre mais je vais exposer ma configuration. Je précise quand même que mes graphes fonctionnaient jusque fin avril puis ils se sont arrêtés, ont refonctionné pendant Juin puis se sont de nouveau arrêtés et depuis plus rien.
    Je suis sur Nagios 3.4.1 avec Centreon 2.3.9. Ceci est installé sur un serveur virtuel Centos 5.2 avec 4 proc et 3Go de Ram. Je monitore 1400 services au total sur 223 hotes dont certains sur des sites distants au travers de VPNs. J'ai opté, pour mes serveurs Linux, pour une vérification via des commandes ssh directes.
    La lecture de mon centstorage.log ne laisse rien voir de particulier. Par contre j'ai un load average entre 2 et 4 en permanence et je vois que MySQL est gourmand. J'ai déjà essayer d'effacer mes fichiers objects.cache et retention.dat, sans succès. J'ai aussi tenté de renommer mes répertoires "status" et "metrics" et donc "il" les a reconstruit, tjs sans succès.

    Maintenant les questions que je me pose:
    Ai je trop de services pour un seul serveur ? Si oui avez vous un tuto à m'indiquer pour installer un poller supplémentaire ?
    Puis je d'une façon ou d'une autre faire baisser mon load average ?

    Merci de votre aide. Cela fait 3 mois que je cherche.
    En informatique, il ne faut pas dire "ça ne marche pas" mais: "je n'y suis pas encore parvenu".

  • #2
    Bonjour,
    Je constate avec bonheur que ce matin tous mes graphes refonctionnent parfaitement. C'est donc la MAJ qui a résolu le problème ( nagios 3.1 vers 3.4 et centreon 2.1.15 vers 2.3.9 ). Si toutefois vous pouvez m'apporter une réponse concernant mon load average je suis preneur.
    Je ne sais pas non plus passer mon post en statut "résolu".
    Merci à tous.
    En informatique, il ne faut pas dire "ça ne marche pas" mais: "je n'y suis pas encore parvenu".

    Comment


    • #3
      La mise à jour de Centreon à changer la regexp d'extractino des données de performance et ceci à du corriger ton problème de graphique.

      Concernant le load elevé, tu devrais tunenr ta base MySQL entuilisant notemment le script https://github.com/rackerhacker/MySQLTuner-perl
      Centreon Syslog Module Manager/Developper
      Centreon E2S Module Manager/Developper
      Centreon Enterprise Server (2.x / 3.x) : Centreon Engine 1.3.x / 1.4.x, Centreon Broker 2.6.x / 2.8.x , Centreon 2.x, Centreon-Syslog 1.5.x, Centreon E2S 2.0
      Nagios 3.x et NDOutil 1.x

      Comment


      • #4
        Bonjour,
        merci pour ta réponse.
        En effet la mise à jour à règlé mon problème de graphs.
        Pour la suroccupation de mon serveur je vais explorer ce que tu me proposes.
        En informatique, il ne faut pas dire "ça ne marche pas" mais: "je n'y suis pas encore parvenu".

        Comment

        Working...
        X