Announcement

Collapse
No announcement yet.

[Résolu]fichiers de configuration nagios: des ^M de partout!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Résolu]fichiers de configuration nagios: des ^M de partout!

    Bonjour,

    Voulant changer le login administrateur par defaut de nagios (nagiosadmin), je me rends compte avec horreur, qu'avec vi, tous les retours à la ligne des fichiers de conf apparaissent en '^M' (notamment ~/nagios/etc/cgi.cfg, hosts.cfg, en fait tous les fichiers de conf modifiés par oreon) hock:! C'est grave docteur?

    Pour info:
    Nagios 1.3 plugins 1.4.2
    Oreon 1.2.3RC1
    Debian Sarge en 2.4.27-2-686-smp apache2 (classique quoi)

    Hormis cela, quelqu'un peut me confirmer la méthode pour changer ce login? (j'ai un gros doute que ce soit en le modifiant à la mano dans cgi.cfg, c'est pas un .htaccess?)

    Merci de votre aide!

  • #2
    il faut changer le login dans cgi.cfg pour l'admin et ensuite regener le htpasswd en lui mettant le passwd pour ton compte...

    je vais regarde rpour les ^M

    Merci
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      Ok, c'est vu pour le changement de login, merci!

      Tiens-moi (nous) au courant pour le pb des retours à la ligne. Ca n'a pas l'air de poser pb à nagios (sur ma config), ça doit juste être un pb de codage de caractères, mais niveau lisibilité, ça serait mieux sans!

      Hésite pas à me demander si tu veux faire des tests, mon nagios est en phase pré-prod, donc tout est permis!

      Comment


      • #4
        j'ai regardé je n'ai pas du tout le pb ni avec emacs ni vi... ca serait pas un pb de configuration de php ?
        Julien Mathis
        Centreon Project Leader
        www.merethis.com |

        Comment


        • #5
          Probablement, mais dans ce cas je vais avoir besoin d'aide! Je maîtrise pas du tout la configuration de php :?

          Tout comme les codages de caractères, c'est pas ma tasse de thé :roll:

          Si quelqu'un a le même problème, qu'il hésite pas à poster la solution, je doit surement pas être le seul, vu ma config bateau..

          (Pour info j'ai installé nagios et oreon en suivant la procédure du wiki)

          Comment


          • #6
            tu as donc une debian ?
            Julien Mathis
            Centreon Project Leader
            www.merethis.com |

            Comment


            • #7
              moi dans mon php.ini j'ai ca

              ; As of 4.0b4, PHP always outputs a character encoding by default in
              ; the Content-type: header. To disable sending of the charset, simply
              ; set it to be empty.
              ;
              ; PHP's built-in default is text/html
              default_mimetype = "text/html"
              ;default_charset = "iso-8859-1"



              y a qq chose a voir... au pire si on trouve ou ca va pas, on le setera en php dans oreon
              Julien Mathis
              Centreon Project Leader
              www.merethis.com |

              Comment


              • #8
                idem pour moi!

                Après investigation sur les fichiers de conf (nagios et oreon), il s'avère que seul cgi.cfg (des repertoires nagios et oreon) est incriminé, j'ai parlé trop vite tout à l'heure ops:

                Hors, ce fichiers ne fait pas parti des fichiers de conf générés par oreon. Est-il codé comme ça à l'install de nagios puis copié dans ~/oreon/nagios_cfg/conf/ ou mal codé par oreon et copié dans ~/nagios/etc/ :?:

                Pour être sûr que ça ne le fait pas qu'à moi, est-ce que d'autres pourraient faire un petit:
                Code:
                vi /usr/local/oreon/nagios_cfg/conf/cgi.cfg
                et
                Code:
                vi /usr/local/nagios/etc/cgi.cfg

                Comment


                • #9
                  nan j'ai pas le pb moi...
                  Julien Mathis
                  Centreon Project Leader
                  www.merethis.com |

                  Comment


                  • #10
                    Surement dû à la configuration de vi par défaut de débian, non?
                    Ca me le fait aussi avec tous les *.php de oreon

                    Je me suis un peu penché sur le sujet:
                    Il s'avère que les fichiers inclus dans le tarball d'oreon n'ont pas le même codage des retours à la ligne que ceux de nagios: le retour à la ligne est codé \r au lieu de \n , pas bien grave..
                    Pour ne pas se prendre la tête, j'ai tout bêtement installé vim et ça roule!

                    Comment


                    • #11
                      ha oauis on dirait..
                      Julien Mathis
                      Centreon Project Leader
                      www.merethis.com |

                      Comment


                      • #12
                        Bonjour,

                        Les problèmes de ^M viennent de l'édition de ce fichier dans le monde Windows puis réintégration dans le monde Linux. Pour supprimer ces ^M il faut utiliser dos2unix (paquet sysutils sous Debian).

                        Comment


                        • #13
                          ha... spécifique a debian alros ? car sous redhat like j'ai pas le pb...
                          Julien Mathis
                          Centreon Project Leader
                          www.merethis.com |

                          Comment


                          • #14
                            non, non: j'ai déjà eu le même problème sous RedHat ES3 et Fedora Core 3... Ce n'est pas bien grave, c'est plus ou bien moins géré selon les cas. Là c'est plus que moins, on ne va pas s'en pllaindre, ce n'est que du détail.

                            Comment


                            • #15
                              Puis, comme je l'ai marqué, seul vi (de base, quand vim n'est pas installé) se mélange les pinceaux avec les chariots windows, vim (qui est installé par défaut sur toutes les distros récentes: ubuntu, fedora, mandriva.. sauf Debian sarge hock, lui s'en sort très bien!

                              Il faut savoir que dès que vim est installé, la commande vi lance vim...

                              Comment

                              Working...
                              X