Announcement

Collapse
No announcement yet.

Problème interface Web / cgi

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problème interface Web / cgi

    Bonjour,
    Alors au debut j'avais un problème d'autentification web (http://localhost/nagios/), il voulait pas se connecter !
    Alors j'ai mis dans le fichier .htaccess tout en commentaires !
    Et j'accède à l'interface mais maintenant lorsque je clic sur les différents onglet j'ai un message :

    Code:
    It appears as though you do not have permission to view the configuration information you requested...
    
    If you believe this is an error, check the HTTP server authentication requirements for accessing this CGI
    and check the authorization options in your CGI configuration file.
    Je ne sais guère d'où cela peut venir !
    nagios user : Solaris 10 (SPARC),php4, apache 1.3

  • #2
    il faut que tu donne un pass a ton interface.. c'est marqué dans la doc nagios.

    la tu ne peux plus acceder a certaines pages de l'interface car tu n'as pas été authentifié. ...
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      OUi mais qd je m'identifie je met mon login et mon mot de passe il me relance la fenetre de connexion alors que je suis sur de mes identifiants !

      et j'ai bien fais la commande :
      /usr/local/apache/bin/htpasswd -c /usr/local/nagios/etc/htpasswd.users nagiosadmin
      nagios user : Solaris 10 (SPARC),php4, apache 1.3

      Comment


      • #4
        c ton fichier de conf de apache qui n'est pas bon. Il faut qu'il demande l'authentification.

        je suppose que c'est une version RPM. Le httpd n'est jamais bien configuré en RPM.

        essaye ca :

        <Directory "/usr/local/nagios/sbin/">
        AllowOverride AuthConfig
        Options ExecCGI
        Order allow,deny
        Allow from all
        </Directory>

        Alias /nagios/ /usr/local/nagios/share/
        <Directory "/usr/local/nagios/share">
        Options None
        AllowOverride AuthConfig
        Order allow,deny
        Allow from all
        </Directory>
        il faut qu'il y ai bien AllowOverride AuthConfig

        sinon c pas bon.

        voila
        Julien Mathis
        Centreon Project Leader
        www.merethis.com |

        Comment


        • #5
          Voilà ce que j'ai dans /usr/local/apache/conf/httpd.conf :


          Code:
          ScriptAlias /nagios/cgi-bin /usr/local/nagios/sbin
          <Directory "/usr/local/nagios/sbin">
                  AllowOverride AuthConfig
                  order allow,deny
                  allow from all
                  Options ExecCGI
          </Directory>
          
          
          Alias /nagios/ "/usr/local/nagios/share/"
          <Directory "/usr/local/nagios/share">
                  AllowOverride AuthConfig
                  order allow,deny
                  allow from all
                  Options ExecCGI
          </Directory>
          Jpense que c bon ?
          SInon je tiens à rapeler que je suis sous Solaris 10 - SPARC

          voilà :roll:
          nagios user : Solaris 10 (SPARC),php4, apache 1.3

          Comment


          • #6
            ton htaccess porte lebon nom pour que apache le detect ? est il lisible par apache ? la ca vient pas de nagios ni d'oreon, c'est un pb apache. Mais peut etre certains auront la reponse pour toi.
            Julien Mathis
            Centreon Project Leader
            www.merethis.com |

            Comment


            • #7
              autre problème :

              Code:
              Whoops!
              
              Error: Could not read host and service status information!
              
              The most common cause of this error message (especially for new users), is the fact that Nagios is not actually running. If Nagios is indeed not running, this is a normal error message. It simply indicates that the CGIs could not obtain the current status of hosts and services that are being monitored. If you've just installed things, make sure you read the documentation on starting Nagios.
              
              Some other things you should check in order to resolve this error include:
              
                 1. Check the Nagios log file for messages relating to startup or status data errors.
                 2. Always verify configuration options using the -v command-line option before starting or restarting Nagios!
                 3. Make sure you've compiled the main program and the CGIs to use the same status data storage options (i.e. text file or database). If the main program is storing status data in a text file and the CGIs are trying to read status data from a database, you'll have problems. 
              
              Make sure you read the documentation on installing, configuring and running Nagios thoroughly before continuing. If all else fails, try sending a message to one of the mailing lists. More information can be found at [url]http://www.nagios.org[/url].

              Super c'est la fete !

              et quand je fais un :

              /usr/local/nagios/bin/nagios restart il me met :

              Code:
              Nagios 1.2
              Copyright (c) 1999-2004 Ethan Galstad ([email protected])
              Last Modified: 02-02-2004
              License: GPL
              
              Error: Cannot open main configuration file '/usr/local/nagios/share/restart' for reading!
              Nagios 1.2 starting... (PID=1309)
              Bailing out due to one or more errors encountered in the configuration files.  Run Nagios from the command line with the -v option to verify your config before restarting. (PID=1309)
              bash-3.00#
              Yeah !!!
              nagios user : Solaris 10 (SPARC),php4, apache 1.3

              Comment


              • #8
                lance le en -v tu verra ce qui ne va pas...
                Julien Mathis
                Centreon Project Leader
                www.merethis.com |

                Comment


                • #9
                  J'avais des erreurs au debut et j'ai fais des modifs !
                  du coup :

                  Code:
                  bash-3.00# /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg
                  
                  Nagios 1.2
                  Copyright (c) 1999-2004 Ethan Galstad ([email protected])
                  Last Modified: 02-02-2004
                  License: GPL
                  
                  Reading configuration data...
                  
                  Running pre-flight check on configuration data...
                  
                  Checking services...
                          Checked 2 services.
                  Checking hosts...
                          Checked 2 hosts.
                  Checking host groups...
                          Checked 1 host groups.
                  Checking contacts...
                          Checked 2 contacts.
                  Checking contact groups...
                          Checked 1 contact groups.
                  Checking service escalations...
                          Checked 0 service escalations.
                  Checking host group escalations...
                          Checked 0 host group escalations.
                  Checking service dependencies...
                          Checked 0 service dependencies.
                  Checking host escalations...
                          Checked 0 host escalations.
                  Checking host dependencies...
                          Checked 0 host dependencies.
                  Checking commands...
                          Checked 23 commands.
                  Checking time periods...
                          Checked 4 time periods.
                  Checking for circular paths between hosts...
                  Checking for circular service execution dependencies...
                  Checking global event handlers...
                  Checking obsessive compulsive service processor command...
                  Checking misc settings...
                  
                  Total Warnings: 0
                  Total Errors:   0
                  
                  Things look okay - No serious problems were detected during the pre-flight check
                  :wink:
                  nagios user : Solaris 10 (SPARC),php4, apache 1.3

                  Comment


                  • #10
                    Personne ne voit ? :? j'ai toujours le meme problème, par contre j'ai réglé le problème de l'authentification et j'arrive à me connecter mais pares toujours la meme erreur cgi : up
                    nagios user : Solaris 10 (SPARC),php4, apache 1.3

                    Comment


                    • #11
                      Bonjour,

                      /usr/local/nagios/bin/nagios restart
                      C'est normal: l'option restart n'existe pas pour le programe nagios! Essaye plutôt de démarrer le démon comme ceci:
                      Code:
                      /etc/init.d/nagios restart

                      Comment


                      • #12
                        YEs ça commence à marcher mieux !
                        Cependant j'ai toujours des erreurs :
                        It appears as though you do not have permission to view the configuration information you requested...

                        If you believe this is an error, check the HTTP server authentication requirements for accessing this CGI
                        and check the authorization options in your CGI configuration file.
                        lorsque je veu ouvrir certain lien tels que :

                        -process info
                        -view config
                        -network outages
                        -Scheduling queue
                        -Event log

                        et pour :

                        -status map
                        -Trends
                        - Availability

                        ==> PAGE NOT FOUND !!

                        Comment se fesse ? :roll:
                        nagios user : Solaris 10 (SPARC),php4, apache 1.3

                        Comment


                        • #13
                          Bonjour,

                          It appears as though you do not have permission to view the configuration information you requested...
                          Il faut que tu autorises l'utilisateur à voir les parties indiquées. Pour cela, il faut que tu modifies le fichier cgi.cfg (directives authorized_for*).

                          ==> PAGE NOT FOUND !!
                          Qaund tu as compilé Nagios, lors du ./configure une erreur c'est affichée (si si, je t'assure). Cette erreur t'indiquait qu'ils te manquaient les fichiers include (fichiers .h) et/ou les librairies libpng, libjpeg ou autre. Recommence la compilation et vérifie lentement les messages warning!

                          Comment


                          • #14
                            OUais mais si je relance un ./configure je perd toutes mes configs !!! :?
                            nagios user : Solaris 10 (SPARC),php4, apache 1.3

                            Comment


                            • #15
                              les confs d'Oreon ? Non elles sont en base de données, tu regenerera
                              Julien Mathis
                              Centreon Project Leader
                              www.merethis.com |

                              Comment

                              Working...
                              X