Announcement

Collapse
No announcement yet.

Pb avec l'interface web

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pb avec l'interface web

    BOnjour à tous,

    Je viens d'installer le package Nagios 2.0
    et quand je veux aller sur la page

    /@ip/nagios ou
    /@ip/nagios/cgi-bin/

    il me met :

    Forbidden
    You don't have permission to access /nagios/ on this server.

    Je ne suis pas en root sur l'ordi, c'est mon maitre de stage qui m'a ouvert un Putty ou j'ai juste certains droits. Comment puis-je faire pour acceder a cette page ?

  • #2
    .htaccess and RTFM
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320

    Comment


    • #3
      J'ai la doc sous les yeux mais ce n'est pas évident

      J'ai bien configuré le access.conf avec les lignes suivantes :

      <Directory /usr/local/nagios/sbin>
      AllowOverride AuthConfig
      order allow,deny
      allow from all
      Options ExecCGI
      </Directory

      <Directory /usr/local/nagios/share>
      AllowOverride AuthConfig
      order allow,deny
      allow from all
      </Directory>

      J'ai crée le .htaccess mais je ne peux le mettre dans

      /usr/local/nagios/sbin
      /usr/local/nagios/share

      Puisque ces dossier n'existe pas......

      cd /usr/local/nagios/sbin
      -sh: cd: /usr/local/nagios/sbin: Aucun fichier ou répertoire de ce type

      C'est pas pour vous embetez ce post, c'est parce que je suis perdu...

      Comment


      • #4
        Re: Pb avec l'interface web

        Originally posted by funkyfing
        BOnjour à tous,

        Je viens d'installer le package Nagios 2.0
        et quand je veux aller sur la page

        /@ip/nagios ou
        /@ip/nagios/cgi-bin/

        il me met :

        Forbidden
        You don't have permission to access /nagios/ on this server.

        Je ne suis pas en root sur l'ordi, c'est mon maitre de stage qui m'a ouvert un Putty ou j'ai juste certains droits. Comment puis-je faire pour acceder a cette page ?
        Comment as-tu installé ce "package" de nagios 2.0 ?
        C'était une archivce des sources que tu as compilé ou un paquet binaire au format RPM ou debian ?
        Raphaël 'SurcouF' Bordet
        Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
        Dons Paypal

        Comment


        • #5
          J'ai installé le RPM avec yum. Hier j'ai essayé de compiler mais j'avais des erreurs dès le ./configure --prefix.....etc

          Comment


          • #6
            Originally posted by funkyfing
            J'ai installé le RPM avec yum. Hier j'ai essayé de compiler mais j'avais des erreurs dès le ./configure --prefix.....etc
            Si tu as installé un RPM, alors nagios devrait se trouver dans /usr/share/nagios et ses cgi dans /usr/lib/nagios/cgi/
            Quant aux plugins, ils sont dans /usr/lib/nagios/plugins/ et la configuration dans /etc/nagios/
            Il faudra modifier les options dans Oreon.
            Raphaël 'SurcouF' Bordet
            Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
            Dons Paypal

            Comment


            • #7
              Merci pour les infos surcouf,

              mais alors du coup il faudra aussi que je change le access.conf car les noms des repertoires ne seront pas bon ?

              et le .htaccess je dois le mettre ou ? je ne trouve pas les dossiers ..../nagios/sbin et dans /usr/share/nagios il n'y a que HTML

              Vue comme je suis perdu maintenant, je n'arriverai pas à configurer le reste si au départ je n'ai pas compilé la programme. Il vaudrait peut etre mieux que je reéssaye la compilation non .?

              VOila l'erreur que j'ai quand je lance ./configue...

              ./configure --prefix=/usr/local/nagios --with-cgiurl=/nagios/cgi-bin --with-htmurl=/nagios/ --with-nagios-user=nagios --with-nagios-group=nagios --with-command-group=nagios

              checking for a BSD-compatible install... /usr/bin/install -c
              checking build system type... i686-pc-linux-gnu
              checking host system type... i686-pc-linux-gnu
              checking for gcc... no
              checking for cc... no
              checking for cc... no
              checking for cl... no
              configure: error: no acceptable C compiler found in $PATH
              See `config.log' for more details.

              Comment


              • #8
                Originally posted by funkyfing
                mais alors du coup il faudra aussi que je change le access.conf car les noms des repertoires ne seront pas bon ?
                Bien évidemment qu'il faudra les modifier en conséquence.

                Originally posted by funkyfing
                et le .htaccess je dois le mettre ou ? je ne trouve pas les dossiers ..../nagios/sbin et dans /usr/share/nagios il n'y a que HTML

                Vue comme je suis perdu maintenant, je n'arriverai pas à configurer le reste si au départ je n'ai pas compilé la programme. Il vaudrait peut etre mieux que je reéssaye la compilation non .?
                Non, ce n'est pas nécessaire.
                Puisque tu as du mal, voici ce que tu devrais avoir comme fichier de configuration pour Apache (à noter que je préfère mettre les directives du .htaccess directement dans la structure Directory) :

                Code:
                ScriptAlias /nagios/cgi-bin/ /usr/lib/nagios/cgi/
                <Directory /usr/lib/nagios/cgi/>
                 AllowOverride AuthConfig
                 order allow,deny
                 allow from all
                 Options ExecCGI
                 AuthName "Nagios Access"
                 AuthType Basic
                 AuthUserFile /etc/nagios/htpasswd.users
                 require valid-user
                </Directory>
                
                Alias /nagios/ /usr/share/nagios/
                <Directory /usr/share/nagios/>
                 AllowOverride AuthConfig
                 order allow,deny
                 allow from all
                 AuthName "Nagios Access"
                 AuthType Basic
                 AuthUserFile /etc/nagios/htpasswd.users
                 require valid-user
                </Directory>
                Tu devrais trouver normalement ce genre de fichiers avec /etc/httpd/conf.d/nagios.conf
                Raphaël 'SurcouF' Bordet
                Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
                Dons Paypal

                Comment


                • #9
                  Effectivement j'ai bien ces lignes dans mon nagios.conf :

                  Code:
                  ScriptAlias /nagios/cgi-bin/ /usr/lib/nagios/cgi-bin/
                  <Directory /usr/lib/nagios/cgi-bin/>
                     Options ExecCGI
                     order deny,allow
                     deny from all
                     allow from 127.0.0.1
                     AuthType Basic
                     AuthUserFile /etc/nagios/passwd
                     AuthName "nagios"
                     require valid-user
                  </Directory>
                  
                  Alias /nagios/ /usr/share/nagios/html/
                  <Directory /usr/share/nagios/html/>
                     Options None
                     order deny,allow
                     deny from all
                     allow from 127.0.0.1
                     AuthType Basic
                     AuthUserFile /etc/nagios/passwd
                     AuthName "nagios"
                     require valid-user
                  </Directory>

                  En fait j'ai la doc en anglais de nagios 2.0 et j'ai du mal à comprendre tout.... je sais pas trop a quoi ca sert ce que je suis en train de faire (je parle des lignes de code que je recopie comme au dessus, je ne comprend pas ce que ca veut dire) c'est pour ca que j'arrive pas à adapter par rapport à ce que j'ai...


                  J'ai recopié le code ci dessus dans mon httpf.conf et j'ai tout de meme une erreur :

                  Arrêt de httpd : [ OK ]
                  Démarrage de httpd :[Fri Mar 03 14:36:40 2006] [warn] The ScriptAlias directive in /etc/httpd/conf/httpd.conf at line 984 will probably never match because it overlaps an earlier ScriptAlias.
                  [Fri Mar 03 14:36:40 2006] [warn] The Alias directive in /etc/httpd/conf/httpd.conf at line 996 will probably never match because it overlaps an earlier Alias.
                  [ OK ]


                  Je l'ai mis a la fin du fichier, il fallait peut etre pas ?
                  J'ai une ligne en commentaire dans httpd.conf aussi :

                  # Include /etc/httpd/conf.d/nagios.conf

                  Je dois la laisser comme ca ?

                  Je suis vraiment désolé, j'aimerai bien comprendre.

                  Merci.

                  Je vais continuer de lire la doc pour comprendre comment ca marche tout ce bazar. :?

                  Comment


                  • #10
                    il ne faut pas avoir des directives identiques dans httpd.conf ainsi que dans conf.d/*.conf
                    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                    Fedora Core 5 - 2.6.20-1.2320

                    Comment


                    • #11
                      arf décidement je suis largué...

                      J'aimerai bien trouvé les équivalents chez moi de /usr/local/nagios/sbin et /usr/local/nagios/share pour mettre le .htaccess.
                      J'aimerai aussi comprendre ces lignes de codes...

                      Comment


                      • #12
                        Originally posted by funkyfing
                        arf décidement je suis largué...

                        J'aimerai bien trouvé les équivalents chez moi de /usr/local/nagios/sbin et /usr/local/nagios/share pour mettre le .htaccess.
                        J'aimerai aussi comprendre ces lignes de codes...
                        Tu fais un blocage:

                        - /usr/local/nagios/share -> /usr/share/nagios
                        - /usr/local/nagios/sbin -> /usr/lib/nagios/cgi

                        Comme je l'ai déjà dit. Est-ce plus clair ainsi ?
                        Raphaël 'SurcouF' Bordet
                        Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
                        Dons Paypal

                        Comment


                        • #13
                          arf... vraiment dsl...

                          Ca fait deux jours que je fais que de lire de la doc de 8h du mat à 18h,
                          je melange tout.

                          Merci je vais essayé ca mais Lundi, la j'en peut plus je rentre chez moi.

                          Merci encore surcouf,

                          Je vous tiens au courant lundi.

                          Bon week end

                          Comment


                          • #14
                            D'après les conseils de surcouf, j'ai réussi a lancer le serveur apache sans erreur avec cette config qui me parait bonne :

                            Code:
                            ScriptAlias /nagios/cgi-bin /usr/lib/nagios/cgi-bin
                            
                            <Directory "/usr/lib/nagios/cgi"> 
                               Options ExecCGI
                                AllowOverride None
                                Order allow,deny
                                Allow from all
                                AuthName "Nagios Access"
                                AuthType Basic
                                AuthUserFile /etc/nagios/htpasswd.users
                                Require valid-user
                            </Directory>
                            
                            Alias /nagios /usr/share/nagios
                            
                            <Directory "/usr/share/nagios">
                                Options None
                                AllowOverride None
                                Order allow,deny
                                Allow from all
                                AuthName "Nagios Access"
                                AuthType Basic
                                AuthUserFile /etc/nagios/htpasswd.users
                                Require valid-user
                            </Directory>
                            J'ai ensuite editer l'access.conf pour le configurer lui aussi :

                            Code:
                            <Directory /usr/lib/nagios/cgi-bin>
                            AllowOverride AuthConfig
                            order allow,deny
                            allow from all
                            Options ExecCGI
                            </Directory>
                            
                            <Directory /usr/share/nagios>
                            AllowOverride AuthConfig
                            order allow,deny
                            allow from all
                            </Directory>
                            J'ai bien mis le .htaccess dans /usr/lib/nagios/cgi-bin et dans /usr/share/nagios

                            Code:
                            AuthName "Nagios Access"
                            AuthType Basic
                            AuthUserFile /etc/nagios/htpasswd.users
                            require valid-user
                            J'ai bien tapé htpasswd -c /etc/nagios/htpasswd.users nagiosadmin et enregistré mon mot de passe.

                            Et maintenant quand je vais sur :

                            http://@ip/nagios/ => Il me demande un log et mot de passe ( il me demandais deja avant de configurer httpd.conf... ) et quand je tape nagiosadmin et mon mot de passe ca ne marche pas........

                            http://@ip/nagios/cgi-bin => erreur 404...

                            Pourtant j'ai suivi les instuctions de la doc a la lettre et j'ai adapté a mes dossiers nagios....
                            Je comprends pas d'ou ca peut venir cette fois.

                            Comment


                            • #15
                              Personne n'a d'idée ? :?

                              J'ai donné les droits au groupe Nagios auquel j'ai ajouté 2 users : nobody et apache.

                              Chown --recursive nagios /etc/nagios
                              Chown --recursive nagios /usr/lib/nagios
                              Chown --recursive nagios /usr/share/nagios

                              J'ai crée le .htaccess le user nagiosadmin :

                              htpasswd -c /usr/local/nagios/etc/htpasswd.users nagiosadmin

                              Quand je vais sur http://@ip_de_l'ordi_distant/nagios, je tape mon log et mon pass et il me met :

                              Forbidden
                              You don't have permission to access /nagios/ on this server.
                              .........

                              Pourtant je n'ai rien oublié !!! je suis allé voir tout les sites qui parle de Nagios et je n'ai rien vu que j'ai pu oublié.......
                              2 semaines de stage de perdues....

                              Comment

                              Working...
                              X