Announcement

Collapse
No announcement yet.

problème alerte par mail sous Nagios

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    <mode_troll=on>
    Bah sous Debian, debconf te propose de faire la configuration de ton postfix, ya juste a lui demander et mettre les bon elements lorsqu'il te les demandes...

    Dommage de ne pas avoir ailleur
    <mode_troll=off>

    Content que tu es réussi a tout config

    WAtt
    Centreon 2.x

    Comment


    • #17
      Dans ton autre post on a l'impression que tu envoi le mail a ton user root.

      mail -u root
      Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
      Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
      Fedora Core 5 - 2.6.20-1.2320

      Comment


      • #18
        et bien le truc c'est que je n'ai toujours pas réussi a recevoir mes mail...

        je pense que il y a un soucis avec postfix:
        -déja je ne peut pas envoyer de mail:

        [[email protected] ~]# mail -u [email protected]
        "[email protected]" is not a user of this system

        -en plus il ne semble pas etre démmaré:

        [[email protected] ~]# sudo /etc/init.d/postfix restart
        Arrêt de postfix : [ÉCHOUÉ]
        Démarrage de postfix : [ÉCHOUÉ]
        [[email protected] ~]# sudo /etc/init.d/postfix start
        Démarrage de postfix : [ÉCHOUÉ]

        Comment


        • #19
          Ton postfix est flingué ou sa conf et flingué.

          yum remove postfix
          yum install postfix

          devrait le rendre un peu plus stable.


          Pour info mail -u sert a lire ses mails pas a en envoyer :d
          Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
          Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
          Fedora Core 5 - 2.6.20-1.2320

          Comment


          • #20
            lol, merci... tu métonne que je ne reçoi rien, j'était déja en train de réinstaller postfix, a mon avis a force de le bricolé avec des apt et tout....

            Comment


            • #21
              Arf j'ai un gros soucis là, je viens de m'apercevoir que dans monitoring==>gestionnaire d'événement==> erreurs et avertissement j'avai :

              Attempting to execute the command "/usr/bin/printf "%b" "***** Oreon *****\n\nNotification Type: PROBLEM\n\nService: Espace disque C\nHost: serveur minitel\nAddress: 192.1.1.9\nState: WARNING\nDate/Time: $DATETIME$\n\nAdditional Info:\n\n$OUTPUT$" | /usr/bin/mail -s "** PROBLEM alert - serveur minitel/Espace disque C is WARNING **" [email protected]" resulted in a return code of 127. Make sure the script or binary you are trying to execute actually exists...

              dsl j'ai vraiment besoin de vous! sa signifie koi? a part qu'il ne trouve pas le binaire?? et ou est ce qu'il devrais être???

              Comment


              • #22
                Dans misccommands.cfg j'ai ceci:

                define command{
                command_name host-notify-by-email-ng1
                command_line /usr/bin/printf "%b" "***** Oreon *****Notification\nType:$NOTIFICATIONTYPE$\n Host: $HOSTNAME$\nState: $HOSTSTATE$Address: $HOSTADDRESS$\nInfo: $OUTPUT$\nDate/Time: $DATETIME$" | /usr/bin/mail -s "Host $HOSTSTATE$ alert for $HOSTNAME$!" $CONTACTEMAIL$
                }

                define command{
                command_name host-notify-by-email-ng2
                command_line /usr/bin/printf "%b" "***** Oreon Notification *****\n\nType:$NOTIFICATIONTYPE$\nHost: $HOSTNAME$\nState: $HOSTSTATE$\nAddress: $HOSTADDRESS$\nInfo: $HOSTOUTPUT$\nDate/Time: $DATE$" | /usr/bin/mail -s "Host $HOSTSTATE$ alert for $HOSTNAME$!" $CONTACTEMAIL$
                }

                define command{
                command_name host-notify-by-epager
                command_line /usr/bin/printf "%b" "Host $HOSTALIAS$ is $HOSTSTATE$\nInfo: $OUTPUT$\nTime: $DATETIME$\" | /usr/bin/mail -s \"$NOTIFICATIONTYPE$ alert - Host $HOSTNAME$ is $HOSTSTATE$\" $CONTACTPAGER$
                }

                define command{
                command_name notify-by-email-ng1
                command_line /usr/bin/printf "%b" "***** Oreon *****\n\nNotification Type: $NOTIFICATIONTYPE$\n\nService: $SERVICEDESC$\nHost: $HOSTALIAS$\nAddress: $HOSTADDRESS$\nState: $SERVICESTATE$\nDate/Time: $DATETIME$\n\nAdditional Info:\n\n$OUTPUT$" | /usr/bin/mail -s "** $NOTIFICATIONTYPE$ alert - $HOSTALIAS$/$SERVICEDESC$ is $SERVICESTATE$ **" $CONTACTEMAIL$
                }

                define command{
                command_name notify-by-email-ng2
                command_line /usr/bin/printf "%b" "***** Oreon Notification *****\n\nNotification Type: $NOTIFICATIONTYPE$\n\nService: $SERVICEDESC$\nHost: $HOSTALIAS$\nAddress: $HOSTADDRESS$\nState: $SERVICESTATE$\n\nDate/Time: $DATE$ Additional Info : $SERVICEOUTPUT$" | /usr/bin/mail -s "** $NOTIFICATIONTYPE$ alert - $HOSTALIAS$/$SERVICEDESC$ is $SERVICESTATE$ **" $CONTACTEMAIL$
                }

                define command{
                command_name notify-by-epager
                command_line /usr/bin/printf "%b" "Service: $SERVICEDESC$\nHost: $HOSTNAME$\nAddress: $HOSTADDRESS$\nState: $SERVICESTATE$\nInfo: $OUTPUT$\nDate: $DATETIME$" | /usr/bin/mail -s "$NOTIFICATIONTYPE$: $HOSTALIAS$/$SERVICEDESC$ is $SERVICESTATE$" $CONTACTPAGER$
                }

                define command{
                command_name process-service-perfdata
                command_line $USER1$/process-service-perfdata "$LASTSERVICECHECK$" "$HOSTNAME$" "$SERVICEDESC$" "$SERVICEOUTPUT$" "$SERVICESTATE$" "$SERVICEPERFDATA$"
                }

                Comment


                • #23
                  ok ok, oubliez les deux dernier post, du moins je pense pas que ce soit grave, par contre, en envoyant mon mail j'ai ceci:

                  [[email protected] ~]# mail -v [email protected]
                  Subject: nagios
                  .
                  Cc: [email protected]
                  Null message body; hope that's ok
                  WARNING: local host name (Srvalt) is not qualified; see cf/README: WHO AM I?
                  [email protected],[email protected] Connecting to [127.0.0.1] via relay...
                  220 Srvalt ESMTP Sendmail 8.13.8/8.13.8; Fri, 6 Apr 2007 17:00:51 +0200
                  >>> EHLO Srvalt
                  250-Srvalt Hello localhost [127.0.0.1] (may be forged), pleased to meet you
                  250-ENHANCEDSTATUSCODES
                  250-PIPELINING
                  250-8BITMIME
                  250-SIZE
                  250-DSN
                  250-ETRN
                  250-DELIVERBY
                  250 HELP
                  >>> MAIL From:<[email protected]> SIZE=66
                  250 2.1.0 <[email protected]>... Sender ok
                  >>> RCPT To:<[email protected]>
                  >>> RCPT To:<[email protected]>
                  >>> DATA
                  250 2.1.5 <[email protected]>... Recipient ok
                  250 2.1.5 <[email protected]>... Recipient ok
                  354 Enter mail, end with "." on a line by itself
                  >>> .
                  250 2.0.0 l36F0odO029012 Message accepted for delivery
                  [email protected],[email protected] Sent (l36F0odO029012 Message accepted for delivery)
                  Closing connection to [127.0.0.1]
                  >>> QUIT
                  221 2.0.0 Srvalt closing connection


                  alors j'ai bien l'impression qu'il l'envoi, mais je recoi rien du tout

                  Comment


                  • #24
                    Ton sendmail local a accepté le mail, mais il doit rester dans /var/spool/mqueue

                    Tu devrais regarder dans /var/log/maillog pour voir la suite...

                    Comment


                    • #25
                      et bien justement!:


                      Apr 6 17:11:07 Srvalt sendmail[30951]: l36FB7jc030951: from=<[email protected]>, size=294, class=0, nrcpts=2, msgid=<[email protected]>, proto=ESMTP, daemon=MTA, relay=localhost [127.0.0.1] (may be forged)
                      Apr 6 17:11:07 Srvalt sendmail[30947]: l36FB7vL030947: [email protected],[email protected], ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=60066, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (l36FB7jc030951 Message accepted for delivery)
                      Apr 6 17:11:08 Srvalt sendmail[30953]: l36FB7jc030951: to=<[email protected]>,<[email protected]>, ctladdr=<[email protected]> (0/0), delay=00:00:01, xdelay=00:00:01, mailer=esmtp, pri=150294, relay=mx.fr.oleane.com. [194.2.0.80], dsn=5.6.0, stat=Data format error
                      Apr 6 17:11:08 Srvalt sendmail[30953]: l36FB7jc030951: l36FB8jc030953: DSN: Data format error
                      Apr 6 17:11:08 Srvalt sendmail[30953]: l36FB8jc030953: to=<[email protected]>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=31494, dsn=2.0.0, stat=Sent


                      il a l'air de les envoyé! "stat=Sent" mais je n'ai rien dans ma boite, et les alertes de oreon ne sont pas dans maillog!
                      par contre data format error signifie le format de quoi?
                      ce qui m'inquiete c'est que je viens juste d'installer et de configurer postfix, et il utilise tjr sendmail!

                      Comment


                      • #26
                        le plus étonnant est que je ne peut pas démmarer postfix:

                        Arrêt de postfix : [ÉCHOUÉ]
                        Démarrage de postfix :^[[A [ÉCHOUÉ]
                        [[email protected] ~]# sudo /etc/init.d/postfix stop
                        Arrêt de postfix : [ÉCHOUÉ]

                        Comment


                        • #27
                          j'ai essaillé de le réinstaller mais il m'affiche trop de messages d'erreurs à l'installation... voyez vous même:

                          [[email protected] ~]# yum install postfix
                          Loading "installonlyn" plugin
                          Setting up Install Process
                          Setting up repositories
                          core 100% |=========================| 1.1 kB 00:00
                          extras 100% |=========================| 1.1 kB 00:00
                          updates 100% |=========================| 1.2 kB 00:00
                          Reading repository metadata in from local files
                          primary.xml.gz 100% |=========================| 1.6 MB 00:14
                          ################################################## 5031/5031
                          Parsing package install arguments
                          Resolving Dependencies
                          --> Populating transaction set with selected packages. Please wait.
                          ---> Downloading header for postfix to pack into transaction set.
                          http://sunsite.informatik.rwth-aache....3-2.i386.rpm: [Errno 4] IOError: [Errno ftp error] 421 There are too many connected users, please try later.
                          Trying other mirror.
                          postfix-2.3.3-2.i386.rpm 100% |=========================| 41 kB 00:01
                          ---> Package postfix.i386 2:2.3.3-2 set to be updated
                          --> Running transaction check

                          Dependencies Resolved

                          ================================================== ===========================
                          Package Arch Version Repository Size
                          ================================================== ===========================
                          Installing:
                          postfix i386 2:2.3.3-2 core 3.6 M

                          Transaction Summary
                          ================================================== ===========================
                          Install 1 Package(s)
                          Update 0 Package(s)
                          Remove 0 Package(s)

                          Total download size: 3.6 M
                          Is this ok [y/N]: y
                          Downloading Packages:
                          (1/1): postfix-2.3.3-2.i3 100% |=========================| 3.6 MB 01:40
                          Running Transaction Test
                          Finished Transaction Test
                          Transaction Test Succeeded
                          Running Transaction
                          Installing: postfix ######################### [1/1]
                          error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
                          error: error(-30987) getting "" records from Provideversion index
                          error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
                          error: error(-30987) getting "" records from Provideversion index
                          error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
                          error: error(-30987) getting "" records from Provideversion index
                          error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
                          error: error(-30987) getting "" records from Provideversion index
                          error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
                          error: error(-30987) getting "" records from Provideversion index
                          error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
                          error: error(-30987) getting "" records from Provideversion index
                          error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
                          error: error(-30987) getting "" records from Provideversion index

                          Installed: postfix.i386 2:2.3.3-2
                          Complete!


                          et ensuite le même problême, je ne peut pas démmarer postfix, alors pour configurer sendmail on ma dit que c'était galère....

                          Comment


                          • #28
                            Laisse tomber postfix, ton sendmail fonctionne et semble bien configuré...

                            Ton problème, c'est qu'oleane refuse [email protected]

                            Je pense que dans /etc/hosts, tu dois avoir un truc du genre :
                            127.0.0.1 localhost Srvalt

                            change-le pour avoir un domaine correct à la place de Srvalt.
                            Vu tes logs, je mettrais :
                            127.0.0.1 localhost radiante.fr

                            (et relance de sendmail + retest avec mail)

                            Comment


                            • #29
                              en fait j'ai:

                              # Do not remove the following line, or various programs
                              # that require network functionality will fail.
                              ::1 localhost.localdomain localhost

                              et j'ai essaillé de remplacer le localhost.localdomain par Srvalt.radiante ou radiante.fr et sa n'a rien changé, bien sur en redémmarrant sendmail.

                              et dans maillog:

                              Apr 6 18:05:51 Srvalt sendmail[9385]: l36G5px4009383: l36G5px4009385: DSN: Data format error
                              Apr 6 18:05:52 Srvalt sendmail[9385]: l36G5px4009385: to=<[email protected]>, delay=00:00:01, xdelay=00:00:00, mailer=local, pri=31494, dsn=2.0.0, stat=Sent
                              Apr 6 18:10:22 Srvalt sendmail[10265]: alias database /etc/aliases rebuilt by root
                              Apr 6 18:10:22 Srvalt sendmail[10265]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
                              Apr 6 18:10:22 Srvalt sendmail[10270]: starting daemon (8.13.8): [email protected]:00:00
                              Apr 6 18:10:22 Srvalt sm-msp-queue[10281]: starting daemon (8.13.8): [email protected]:00:00
                              Apr 6 18:10:38 Srvalt sendmail[10360]: l36GAbRt010360: from=root, size=66, class=0, nrcpts=2, msgid=<[email protected]>, [email protected]
                              Apr 6 18:10:38 Srvalt sendmail[10361]: l36GAcsh010361: from=<[email protected]>, size=294, class=0, nrcpts=2, msgid=<[email protected]>, proto=ESMTP, daemon=MTA, relay=localhost [127.0.0.1] (may be forged)
                              Apr 6 18:10:38 Srvalt sendmail[10360]: l36GAbRt010360: [email protected],[email protected], ctladdr=root (0/0), delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=60066, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (l36GAcsh010361 Message accepted for delivery)
                              Apr 6 18:10:38 Srvalt sendmail[10363]: l36GAcsh010361: to=<[email protected]>,<[email protected]>, ctladdr=<[email protected]> (0/0), delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=150294, relay=mx.fr.oleane.com. [194.2.0.80], dsn=5.6.0, stat=Data format error
                              Apr 6 18:10:38 Srvalt sendmail[10363]: l36GAcsh010361: l36GAcsh010363: DSN: Data format error
                              Apr 6 18:10:38 Srvalt sendmail[10363]: l36GAcsh010363: to=<[email protected]>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=31494, dsn=2.0.0, stat=Sent

                              il faut dire aussi que ce monsieur ne prend pas en compte mes modifications

                              250-localhost.localdomain Hello localhost [127.0.0.1] (may be forged), pleased to meet you

                              et évidemment je voit ou tu veut en venir :
                              553 5.5.4 <[email protected]>... Real domain name required for sender address
                              root... Using cached ESMTP connection to [127.0.0.1] via relay...

                              mais même après un reload de sendmail sa ne change rien!

                              Comment


                              • #30
                                Il faut lire ce qu'on te dit et essayer de comprendre, sinon tu n'arriveras jamais à rien sous Linux.

                                Je te disais que tu devais avoir une ligne du genre :
                                127.0.0.1 localhost Srvalt

                                Tu me dis "non, mais en bidouillant une autre ligne, ca ne change rien"
                                C'est un peu normal, tu ne crois pas ?

                                Pour information, tu as modifié la ligne IPV6 de ton hosts, ce qui ne t'avancera pas.

                                Comme la config manque, ajoutes cette ligne :
                                127.0.0.1 localhost radiante.fr


                                Tu dois donc avoir dans /etc/hosts :

                                # Do not remove the following line, or various programs
                                # that require network functionality will fail.
                                ::1 localhost.localdomain localhost
                                127.0.0.1 localhost radiante.fr

                                Comment

                                Working...
                                X