Announcement

Collapse
No announcement yet.

problème alerte par mail sous Nagios

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Azarius
    replied
    je suis trop en galère, je ne voit vraiment pas ce qui ce passe alors up

    Leave a comment:


  • Azarius
    replied
    Bon et bien voilà chose réglée, en fait il s'avère qu'il y ai plusieur domaine dans mon entreprise, enfin des domaine de mail...
    je sais c'est pas clair je m'explique:

    quand je met le domaine [email protected] je modifie mon hosts pour avoir domaine1.fr sa ne marche pas

    et quand je met [email protected] en modifiant mon host en consequence et bien sa marche.

    je fait un envoi de mail a travers la ligne de commande et je reçoi bien mes email.

    le soucis c'est que maintenant je ne reçoi pas les alertes d'oreon, j'arrive bien a recevoir mes mail manuellement (a travers la commande dans le terminal) mais j'aurai du recevoir des mail depuis hier soir et je n'ai toujours rien reçu, pourtant j'ai la bonne adresse et je n'ai pas la case None de cochée...

    Un problême similaire?
    merci

    Leave a comment:


  • Azarius
    replied
    Si par exemple, je modifie ce fameux /etc/hosts/ et que je met non pas radiante.fr mais cognon.fr (domaine de mon entreprise) le mail me parait etre beaucoup mieux envoyer:

    voici ce que m'affiche le terminal:
    Code:
    [[email protected] ~]# mail -v [email protected]
    Subject: test oreon
    test
    .
    Cc: [email protected]
    [email protected],[email protected] Connecting to [127.0.0.1] via relay...
    220 cognon.fr ESMTP Sendmail 8.13.8/8.13.8; Tue, 24 Apr 2007 11:06:54 +0200
    >>> EHLO cognon.fr
    250-cognon.fr Hello Srvalt [127.0.0.1], pleased to meet you
    250-ENHANCEDSTATUSCODES
    250-PIPELINING
    250-8BITMIME
    250-SIZE
    250-DSN
    250-ETRN
    250-DELIVERBY
    250 HELP
    >>> MAIL From:<[email protected]> SIZE=75
    250 2.1.0 <[email protected]>... Sender ok
    >>> RCPT To:<[email protected]>
    >>> RCPT To:<[email protected]>
    >>> DATA
    250 2.1.5 <[email protected]>... Recipient ok
    250 2.1.5 <[email protected]>... Recipient ok
    354 Enter mail, end with "." on a line by itself
    >>> .
    250 2.0.0 l3O96sLZ003411 Message accepted for delivery
    [email protected],[email protected] Sent (l3O96sLZ003411 Message accepted for delivery)
    Closing connection to [127.0.0.1]
    >>> QUIT
    221 2.0.0 cognon.fr closing connection
    Mais quand je vérifie dans mon maillog il me renvoie encore une erreur "Data format error"

    Code:
    Apr 24 11:06:54 Srvalt sendmail[3410]: l3O96sNA003410: [email protected],[email protected], ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=60075, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (l3O96sLZ003411 Message accepted for delivery)
    Apr 24 11:06:54 Srvalt sendmail[3413]: l3O96sLZ003411: to=<[email protected]>,<[email protected]>, ctladdr=<[email protected]> (0/0), delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=150314, relay=mx.fr.oleane.com. [194.2.0.80], dsn=5.6.0, stat=Data format error
    <==Dite moi si je me trompe, mais là il envoie bien le mail au relay local 127.0.0.1 puis le relay l'envoi à mx.fr.oleane.com , et là il ne veut rien savoir?
    C'est pas facile de comprendre tout ce foulli!
    Savez vous qu'est ce que represente "Data format error"?
    Après une recherche avec mon ami Google ,
    j'ai récupéré ceci:

    Plusieurs choses à vérifier:

    - Que le hostname de ta machine soit bien mis à nommachine.adressemachine.net
    - Que la machine puisse resolv nommachine.adressemachine.net (que celui-ci soit dans les /etc/hosts, typiquement pour 127.0.0.1, et qu'il soit le premier de la liste)
    - Si malgré tout quand tu envoies un mail il te laisse un localhost.localdomain comme domaine d'origine (ca devrait pas arriver, faudrait trouver pourquoi...), rajoute un


    define(`confDOMAIN_NAME', `nommachine.adressemachine.net')dnl



    dans ton sendmail.mc, et regénère le sendmail.cf


    A essayer...
    Mais ces modifications sont a faire dans /etc/hosts??
    Merci

    Leave a comment:


  • Azarius
    replied
    J'ai donc modifier mon /etc/hosts :

    avant j'avais ceci:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    ::1 localhost.localdomain localhost
    127.0.0.1 localhost radiante.fr

    et j'ai modifié la derniere ligne comme suit:

    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    ::1 localhost.localdomain localhost
    127.0.0.1 Srvalt radiante.fr

    je redémmarre donc mon sendmail et je refait un test d'envoi mail.

    j'envoi un mail sur une adresse email externe du genre mon adresse personelle [email protected] et je reçoi bien mon email, mais il ne trouve pas les utilisateur des boites mail de l'entreprise, hébergé sur oleane:

    Apr 24 10:00:40 Srvalt sendmail[21479]: l3O80e4h021479: from=root, size=75, class=0, nrcpts=2, msgid=<[email protected]>, [email protected]
    Apr 24 10:00:40 Srvalt sendmail[21483]: l3O80eg2021483: <[email protected]>... User unknown
    Apr 24 10:00:40 Srvalt sendmail[21483]: l3O80eg2021483: <[email protected]>... User unknown
    Apr 24 10:00:40 Srvalt sendmail[21479]: l3O80e4h021479: [email protected], ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=60075, relay=[127.0.0.1] [127.0.0.1], dsn=5.1.1, stat=User unknown
    Apr 24 10:00:40 Srvalt sendmail[21479]: l3O80e4h021479: [email protected], ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=60075, relay=[127.0.0.1] [127.0.0.1], dsn=5.1.1, stat=User unknown
    Apr 24 10:00:40 Srvalt sendmail[21483]: l3O80eg2021483: from=<[email protected]>, size=75, class=0, nrcpts=0, proto=ESMTP, daemon=MTA, relay=Srvalt [127.0.0.1]
    Apr 24 10:00:40 Srvalt sendmail[21479]: l3O80e4h021479: l3O80e4i021479: DSN: User unknown
    Apr 24 10:00:40 Srvalt sendmail[21483]: l3O80eg4021483: from=<>, size=2382, class=0, nrcpts=1, msgid=<[email protected]>, proto=ESMTP, daemon=MTA, relay=Srvalt [127.0.0.1]
    Apr 24 10:00:40 Srvalt sendmail[21479]: l3O80e4i021479: to=root, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=31099, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (l3O80eg4021483 Message accepted for delivery)
    Apr 24 10:00:40 Srvalt sendmail[21484]: l3O80eg4021483: to=<[email protected]>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=32555, dsn=2.0.0, stat=Sent

    Un pas en avant??

    Leave a comment:


  • Azarius
    replied
    Il faut lire ce qu'on te dit et essayer de comprendre, sinon tu n'arriveras jamais à rien sous Linux.

    Je te disais que tu devais avoir une ligne du genre :
    127.0.0.1 localhost Srvalt

    Tu me dis "non, mais en bidouillant une autre ligne, ca ne change rien"
    C'est un peu normal, tu ne crois pas ?
    désolé de mon manque de jujeotte, je tiendrai compte de ta remarque à l'avenir.

    Bon maintenant j'ai ceci dans mon /etc/hosts :

    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    ::1 localhost.localdomain localhost
    127.0.0.1 localhost radiante.fr

    je fait donc un restart de sendmail

    [[email protected] ~]# sudo /etc/init.d/sendmail restart
    Arrêt de sm-client : [ OK ]
    Arrêt de sendmail : [ OK ]
    Démarrage de sendmail : [ OK ]
    Démarrage de sm-client : [ OK ]
    You have new mail in /var/spool/mail/root

    je regarde quand même ce qu'il m'a envoyer dans /var/spool/mail/root:

    Date: Tue, 24 Apr 2007 08:55:00 +0200
    From: root <[email protected]>
    Message-Id: <[email protected]>
    To: [email protected]
    Subject: test

    essai

    --l3O6t1AZ007881.1177397701/Srvalt--

    From [email protected] Tue Apr 24 09:08:19 2007
    Return-Path: <[email protected]>
    Received: from localhost (localhost)
    by Srvalt (8.13.8/8.13.8) id l3O77WhR010465;
    Tue, 24 Apr 2007 09:07:32 +0200
    Date: Tue, 24 Apr 2007 09:07:32 +0200
    From: Mail Delivery Subsystem <[email protected]>
    Message-Id: <[email protected]>
    To: <[email protected]>
    MIME-Version: 1.0
    Content-Type: multipart/report; report-type=delivery-status;
    boundary="l3O77WhR010465.1177398452/Srvalt"
    Subject: Returned mail: see transcript for details
    Auto-Submitted: auto-generated (failure)

    This is a MIME-encapsulated message

    --l3O77WhR010465.1177398452/Srvalt

    The original message was received at Tue, 24 Apr 2007 09:07:32 +0200
    from localhost [127.0.0.1]

    ----- The following addresses had permanent fatal errors -----
    <[email protected]>
    (reason: 553 5.1.8 <[email protected]>... Domain of sender address [email protected] does not exist)

    ----- Transcript of session follows -----
    ... while talking to mx.fr.oleane.com.:
    >>> MAIL From:<[email protected]> SIZE=488
    <<< 553 5.1.8 <[email protected]>... Domain of sender address [email protected] does not exist
    501 5.6.0 Data format error

    --l3O77WhR010465.1177398452/Srvalt
    Content-Type: message/delivery-status


    apparement il es toujours gené par le domaine de [email protected], je ne suis pas sur de devoir utiliser ce format pour l'expéditeur, je vais donc rechercher ou le modifier et faire quelques tests.

    J'aurai quelques question:

    -faut il mettre une TLD sur [email protected]?
    -Srvalt n'est pas un domaine mais le nom du poste, n'est ce pas génant?
    -Faut t'il respecter la casse ? la majuscule de mon Srvalt peut elle causer problême?
    -En faisant marcher mon ami Google, je suis tombé sur un post qui disais de vérifier aussi le resolv.conf qui contient ceci:

    ; generated by /sbin/dhclient-script
    search COGNON
    nameserver 192.1.1.56

    ==>COGNON étant le domaine principale de mon réseau et 192.1.1.56 son adresse.

    Bon en éspèrant ne pas me faire taper sur les doigt parce que j'ai mal lu mes messages, merci.

    Leave a comment:


  • BubuLeMag
    replied
    Il faut lire ce qu'on te dit et essayer de comprendre, sinon tu n'arriveras jamais à rien sous Linux.

    Je te disais que tu devais avoir une ligne du genre :
    127.0.0.1 localhost Srvalt

    Tu me dis "non, mais en bidouillant une autre ligne, ca ne change rien"
    C'est un peu normal, tu ne crois pas ?

    Pour information, tu as modifié la ligne IPV6 de ton hosts, ce qui ne t'avancera pas.

    Comme la config manque, ajoutes cette ligne :
    127.0.0.1 localhost radiante.fr


    Tu dois donc avoir dans /etc/hosts :

    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    ::1 localhost.localdomain localhost
    127.0.0.1 localhost radiante.fr

    Leave a comment:


  • Azarius
    replied
    en fait j'ai:

    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    ::1 localhost.localdomain localhost

    et j'ai essaillé de remplacer le localhost.localdomain par Srvalt.radiante ou radiante.fr et sa n'a rien changé, bien sur en redémmarrant sendmail.

    et dans maillog:

    Apr 6 18:05:51 Srvalt sendmail[9385]: l36G5px4009383: l36G5px4009385: DSN: Data format error
    Apr 6 18:05:52 Srvalt sendmail[9385]: l36G5px4009385: to=<[email protected]>, delay=00:00:01, xdelay=00:00:00, mailer=local, pri=31494, dsn=2.0.0, stat=Sent
    Apr 6 18:10:22 Srvalt sendmail[10265]: alias database /etc/aliases rebuilt by root
    Apr 6 18:10:22 Srvalt sendmail[10265]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
    Apr 6 18:10:22 Srvalt sendmail[10270]: starting daemon (8.13.8): [email protected]:00:00
    Apr 6 18:10:22 Srvalt sm-msp-queue[10281]: starting daemon (8.13.8): [email protected]:00:00
    Apr 6 18:10:38 Srvalt sendmail[10360]: l36GAbRt010360: from=root, size=66, class=0, nrcpts=2, msgid=<[email protected]>, [email protected]
    Apr 6 18:10:38 Srvalt sendmail[10361]: l36GAcsh010361: from=<[email protected]>, size=294, class=0, nrcpts=2, msgid=<[email protected]>, proto=ESMTP, daemon=MTA, relay=localhost [127.0.0.1] (may be forged)
    Apr 6 18:10:38 Srvalt sendmail[10360]: l36GAbRt010360: [email protected],[email protected], ctladdr=root (0/0), delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=60066, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (l36GAcsh010361 Message accepted for delivery)
    Apr 6 18:10:38 Srvalt sendmail[10363]: l36GAcsh010361: to=<[email protected]>,<[email protected]>, ctladdr=<[email protected]> (0/0), delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=150294, relay=mx.fr.oleane.com. [194.2.0.80], dsn=5.6.0, stat=Data format error
    Apr 6 18:10:38 Srvalt sendmail[10363]: l36GAcsh010361: l36GAcsh010363: DSN: Data format error
    Apr 6 18:10:38 Srvalt sendmail[10363]: l36GAcsh010363: to=<[email protected]>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=31494, dsn=2.0.0, stat=Sent

    il faut dire aussi que ce monsieur ne prend pas en compte mes modifications

    250-localhost.localdomain Hello localhost [127.0.0.1] (may be forged), pleased to meet you

    et évidemment je voit ou tu veut en venir :
    553 5.5.4 <[email protected]>... Real domain name required for sender address
    root... Using cached ESMTP connection to [127.0.0.1] via relay...

    mais même après un reload de sendmail sa ne change rien!

    Leave a comment:


  • BubuLeMag
    replied
    Laisse tomber postfix, ton sendmail fonctionne et semble bien configuré...

    Ton problème, c'est qu'oleane refuse [email protected]

    Je pense que dans /etc/hosts, tu dois avoir un truc du genre :
    127.0.0.1 localhost Srvalt

    change-le pour avoir un domaine correct à la place de Srvalt.
    Vu tes logs, je mettrais :
    127.0.0.1 localhost radiante.fr

    (et relance de sendmail + retest avec mail)

    Leave a comment:


  • Azarius
    replied
    j'ai essaillé de le réinstaller mais il m'affiche trop de messages d'erreurs à l'installation... voyez vous même:

    [[email protected] ~]# yum install postfix
    Loading "installonlyn" plugin
    Setting up Install Process
    Setting up repositories
    core 100% |=========================| 1.1 kB 00:00
    extras 100% |=========================| 1.1 kB 00:00
    updates 100% |=========================| 1.2 kB 00:00
    Reading repository metadata in from local files
    primary.xml.gz 100% |=========================| 1.6 MB 00:14
    ################################################## 5031/5031
    Parsing package install arguments
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Downloading header for postfix to pack into transaction set.
    http://sunsite.informatik.rwth-aache....3-2.i386.rpm: [Errno 4] IOError: [Errno ftp error] 421 There are too many connected users, please try later.
    Trying other mirror.
    postfix-2.3.3-2.i386.rpm 100% |=========================| 41 kB 00:01
    ---> Package postfix.i386 2:2.3.3-2 set to be updated
    --> Running transaction check

    Dependencies Resolved

    ================================================== ===========================
    Package Arch Version Repository Size
    ================================================== ===========================
    Installing:
    postfix i386 2:2.3.3-2 core 3.6 M

    Transaction Summary
    ================================================== ===========================
    Install 1 Package(s)
    Update 0 Package(s)
    Remove 0 Package(s)

    Total download size: 3.6 M
    Is this ok [y/N]: y
    Downloading Packages:
    (1/1): postfix-2.3.3-2.i3 100% |=========================| 3.6 MB 01:40
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
    Installing: postfix ######################### [1/1]
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Provideversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Provideversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Provideversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Provideversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Provideversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Provideversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Provideversion index

    Installed: postfix.i386 2:2.3.3-2
    Complete!


    et ensuite le même problême, je ne peut pas démmarer postfix, alors pour configurer sendmail on ma dit que c'était galère....

    Leave a comment:


  • Azarius
    replied
    le plus étonnant est que je ne peut pas démmarer postfix:

    Arrêt de postfix : [ÉCHOUÉ]
    Démarrage de postfix :^[[A [ÉCHOUÉ]
    [[email protected] ~]# sudo /etc/init.d/postfix stop
    Arrêt de postfix : [ÉCHOUÉ]

    Leave a comment:


  • Azarius
    replied
    et bien justement!:


    Apr 6 17:11:07 Srvalt sendmail[30951]: l36FB7jc030951: from=<[email protected]>, size=294, class=0, nrcpts=2, msgid=<[email protected]>, proto=ESMTP, daemon=MTA, relay=localhost [127.0.0.1] (may be forged)
    Apr 6 17:11:07 Srvalt sendmail[30947]: l36FB7vL030947: [email protected],[email protected], ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=60066, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (l36FB7jc030951 Message accepted for delivery)
    Apr 6 17:11:08 Srvalt sendmail[30953]: l36FB7jc030951: to=<[email protected]>,<[email protected]>, ctladdr=<[email protected]> (0/0), delay=00:00:01, xdelay=00:00:01, mailer=esmtp, pri=150294, relay=mx.fr.oleane.com. [194.2.0.80], dsn=5.6.0, stat=Data format error
    Apr 6 17:11:08 Srvalt sendmail[30953]: l36FB7jc030951: l36FB8jc030953: DSN: Data format error
    Apr 6 17:11:08 Srvalt sendmail[30953]: l36FB8jc030953: to=<[email protected]>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=31494, dsn=2.0.0, stat=Sent


    il a l'air de les envoyé! "stat=Sent" mais je n'ai rien dans ma boite, et les alertes de oreon ne sont pas dans maillog!
    par contre data format error signifie le format de quoi?
    ce qui m'inquiete c'est que je viens juste d'installer et de configurer postfix, et il utilise tjr sendmail!

    Leave a comment:


  • BubuLeMag
    replied
    Ton sendmail local a accepté le mail, mais il doit rester dans /var/spool/mqueue

    Tu devrais regarder dans /var/log/maillog pour voir la suite...

    Leave a comment:


  • Azarius
    replied
    ok ok, oubliez les deux dernier post, du moins je pense pas que ce soit grave, par contre, en envoyant mon mail j'ai ceci:

    [[email protected] ~]# mail -v [email protected]
    Subject: nagios
    .
    Cc: [email protected]
    Null message body; hope that's ok
    WARNING: local host name (Srvalt) is not qualified; see cf/README: WHO AM I?
    [email protected],[email protected] Connecting to [127.0.0.1] via relay...
    220 Srvalt ESMTP Sendmail 8.13.8/8.13.8; Fri, 6 Apr 2007 17:00:51 +0200
    >>> EHLO Srvalt
    250-Srvalt Hello localhost [127.0.0.1] (may be forged), pleased to meet you
    250-ENHANCEDSTATUSCODES
    250-PIPELINING
    250-8BITMIME
    250-SIZE
    250-DSN
    250-ETRN
    250-DELIVERBY
    250 HELP
    >>> MAIL From:<[email protected]> SIZE=66
    250 2.1.0 <[email protected]>... Sender ok
    >>> RCPT To:<[email protected]>
    >>> RCPT To:<[email protected]>
    >>> DATA
    250 2.1.5 <[email protected]>... Recipient ok
    250 2.1.5 <[email protected]>... Recipient ok
    354 Enter mail, end with "." on a line by itself
    >>> .
    250 2.0.0 l36F0odO029012 Message accepted for delivery
    [email protected],[email protected] Sent (l36F0odO029012 Message accepted for delivery)
    Closing connection to [127.0.0.1]
    >>> QUIT
    221 2.0.0 Srvalt closing connection


    alors j'ai bien l'impression qu'il l'envoi, mais je recoi rien du tout

    Leave a comment:


  • Azarius
    replied
    Dans misccommands.cfg j'ai ceci:

    define command{
    command_name host-notify-by-email-ng1
    command_line /usr/bin/printf "%b" "***** Oreon *****Notification\nType:$NOTIFICATIONTYPE$\n Host: $HOSTNAME$\nState: $HOSTSTATE$Address: $HOSTADDRESS$\nInfo: $OUTPUT$\nDate/Time: $DATETIME$" | /usr/bin/mail -s "Host $HOSTSTATE$ alert for $HOSTNAME$!" $CONTACTEMAIL$
    }

    define command{
    command_name host-notify-by-email-ng2
    command_line /usr/bin/printf "%b" "***** Oreon Notification *****\n\nType:$NOTIFICATIONTYPE$\nHost: $HOSTNAME$\nState: $HOSTSTATE$\nAddress: $HOSTADDRESS$\nInfo: $HOSTOUTPUT$\nDate/Time: $DATE$" | /usr/bin/mail -s "Host $HOSTSTATE$ alert for $HOSTNAME$!" $CONTACTEMAIL$
    }

    define command{
    command_name host-notify-by-epager
    command_line /usr/bin/printf "%b" "Host $HOSTALIAS$ is $HOSTSTATE$\nInfo: $OUTPUT$\nTime: $DATETIME$\" | /usr/bin/mail -s \"$NOTIFICATIONTYPE$ alert - Host $HOSTNAME$ is $HOSTSTATE$\" $CONTACTPAGER$
    }

    define command{
    command_name notify-by-email-ng1
    command_line /usr/bin/printf "%b" "***** Oreon *****\n\nNotification Type: $NOTIFICATIONTYPE$\n\nService: $SERVICEDESC$\nHost: $HOSTALIAS$\nAddress: $HOSTADDRESS$\nState: $SERVICESTATE$\nDate/Time: $DATETIME$\n\nAdditional Info:\n\n$OUTPUT$" | /usr/bin/mail -s "** $NOTIFICATIONTYPE$ alert - $HOSTALIAS$/$SERVICEDESC$ is $SERVICESTATE$ **" $CONTACTEMAIL$
    }

    define command{
    command_name notify-by-email-ng2
    command_line /usr/bin/printf "%b" "***** Oreon Notification *****\n\nNotification Type: $NOTIFICATIONTYPE$\n\nService: $SERVICEDESC$\nHost: $HOSTALIAS$\nAddress: $HOSTADDRESS$\nState: $SERVICESTATE$\n\nDate/Time: $DATE$ Additional Info : $SERVICEOUTPUT$" | /usr/bin/mail -s "** $NOTIFICATIONTYPE$ alert - $HOSTALIAS$/$SERVICEDESC$ is $SERVICESTATE$ **" $CONTACTEMAIL$
    }

    define command{
    command_name notify-by-epager
    command_line /usr/bin/printf "%b" "Service: $SERVICEDESC$\nHost: $HOSTNAME$\nAddress: $HOSTADDRESS$\nState: $SERVICESTATE$\nInfo: $OUTPUT$\nDate: $DATETIME$" | /usr/bin/mail -s "$NOTIFICATIONTYPE$: $HOSTALIAS$/$SERVICEDESC$ is $SERVICESTATE$" $CONTACTPAGER$
    }

    define command{
    command_name process-service-perfdata
    command_line $USER1$/process-service-perfdata "$LASTSERVICECHECK$" "$HOSTNAME$" "$SERVICEDESC$" "$SERVICEOUTPUT$" "$SERVICESTATE$" "$SERVICEPERFDATA$"
    }

    Leave a comment:


  • Azarius
    replied
    Arf j'ai un gros soucis là, je viens de m'apercevoir que dans monitoring==>gestionnaire d'événement==> erreurs et avertissement j'avai :

    Attempting to execute the command "/usr/bin/printf "%b" "***** Oreon *****\n\nNotification Type: PROBLEM\n\nService: Espace disque C\nHost: serveur minitel\nAddress: 192.1.1.9\nState: WARNING\nDate/Time: $DATETIME$\n\nAdditional Info:\n\n$OUTPUT$" | /usr/bin/mail -s "** PROBLEM alert - serveur minitel/Espace disque C is WARNING **" [email protected]" resulted in a return code of 127. Make sure the script or binary you are trying to execute actually exists...

    dsl j'ai vraiment besoin de vous! sa signifie koi? a part qu'il ne trouve pas le binaire?? et ou est ce qu'il devrais être???

    Leave a comment:

Working...
X