Announcement

Collapse
No announcement yet.

cgi introuvable!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • cgi introuvable!

    Sur plusieurs pages, je me retrouve avec des messages de type :
    Code:
    Not Found
    
    The requested URL /nagios/cgi-bin/trends.cgi was not found on this server.
    Les CGI concernés sont pourtant bien présentes, je ne comprend pas vraiment pour quoi ça ne marche pas.
    Debian3.1r1 - Nagios 1.2 - Nagios Plugins 1.3.1 - Oreon 1.2.3RC4
    Status : OK
    Status information : NSCA OK.

  • #2
    Re: cgi introuvable!

    Originally posted by jigot
    Sur plusieurs pages, je me retrouve avec des messages de type :
    Code:
    Not Found
    
    The requested URL /nagios/cgi-bin/trends.cgi was not found on this server.
    Les CGI concernés sont pourtant bien présentes, je ne comprend pas vraiment pour quoi ça ne marche pas.
    Au bon endroit selon toi, mais manifestement pas là où Nagios s'attend à les y trouver...
    Raphaël 'SurcouF' Bordet
    Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
    Dons Paypal

    Comment


    • #3
      elle se trouvent pourtant toute dans /usr/lib/cgi-bin/ non?
      Debian3.1r1 - Nagios 1.2 - Nagios Plugins 1.3.1 - Oreon 1.2.3RC4
      Status : OK
      Status information : NSCA OK.

      Comment


      • #4
        ca depend de ton install et de ta config
        moi c'est dans /usr/local/nagios/sbin/
        RedHat Advanced Server 4.0
        Nagios 2.3.1
        Oreon 1.3b1

        Comment


        • #5
          Originally posted by jigot
          elle se trouvent pourtant toute dans /usr/lib/cgi-bin/ non?
          Dans /usr/lib/cgi-bin/nagios/ plus précisément mais ceci n'est valable qu'en utilisant les paquet debian ou RPM. En outre, il faut que l'URL /nagios/cg-bin/ soit définie pour employer ce répertoire-là comme CGI au niveau d'Apache, comme suit:

          Code:
              ScriptAlias /nagios/cgi-bin/ /usr/lib/cgi-bin/nagios/
              <Directory "/usr/lib/cgi-bin/nagios/">
                  AllowOverride AuthConfig
                  Options ExecCGI
                  Order allow,deny
                  Allow from all
              </Directory>
          Raphaël 'SurcouF' Bordet
          Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
          Dons Paypal

          Comment


          • #6
            et si ca se trouve, tu n'as pas installe tous les cgi de nagios.

            si tu veux les compléter, nu conseil regarde le wiki :

            http://wiki.oreon-project.org/wakka....tusMapNagiosFR

            :wink:
            Ubuntu 8.04
            Nagios 3.2 + nagios-plugins-1.4.14
            ndoutils-1.4b9
            Centreon 2.1.8
            centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

            Comment


            • #7
              Je pensait avoir vérifié si les scriptalias pointaint bien sur le répertoire cgi de nagios dans le fichier de conf d'apache.

              Mais bon entre toutes mes versions pour les tests je m'enbouille un peu

              Je vais regarder ça de nouveau, Merci.
              Debian3.1r1 - Nagios 1.2 - Nagios Plugins 1.3.1 - Oreon 1.2.3RC4
              Status : OK
              Status information : NSCA OK.

              Comment

              Working...
              X