Announcement

Collapse
No announcement yet.

Problème check_graph_load_average && check_graph_pro

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problème check_graph_load_average && check_graph_pro

    Bonjour,

    Je ne comprends pas bien pourquoi le service check_graph_load_average me retourne cette erreur : Unknown -S Service ID expected... or it doesn't exist, try another id - number alors que l'ID est bien présent dans le fichier service.cfg !!!!

    Quand je mets l'option en dur via l'interface php d'Oreon, il me répond que mon hôte ne répond pas aux requêtes SNMP (Même celui qui est en local) et pourtant SNMP marche bien puisque j'utilise d'autres services qui s'en servent.

    Le service check_graph_process me retourne la même erreur !!!

    Ensuite si je veux bidouiller, je modifie la ligne de commande dans l'interface php pour ce service et ensuite il me dit que c'est ma communauté SNMP qui n'est pas bonne !!! :? Et encore une fois, mes arguments sont dans le bon ordre !!!

    Par exemple : ./check_graph_load_average.pl -H 192.168.0.9 -C home -v 1 -g -S 4
    UNKNOWN: Received noSuchName(2) error-status at error-index 3.

    Et le Oreon index (Option -S) est celle que je trouve dans le fichier de conf service.cfg

    Quelqu'un a déjà eu ce problème ???

    Merci
    a+ hock:
    Nagios : 2.5
    Oreon : 1.3.3
    Mysql : 4.1

  • #2
    Donne nous donc
    1 - Ta version d'Oreon
    2 - La definition de ta commande
    3 - Les arguments que tu passes dans la definition du service
    4 - Ce qui est genere dans le services.cfg
    5 - Le retour dans le monitoring

    6 - Le resultat quand tu lances la commande en ligne de commande sans les options -S et -g
    Romain Le Merlus
    Centreon Forge
    MERETHIS

    Comment


    • #3
      et surtout c'est koi ta cible ? un machine windows ? un linux ? un routeur ?
      Ubuntu 8.04
      Nagios 3.2 + nagios-plugins-1.4.14
      ndoutils-1.4b9
      Centreon 2.1.8
      centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

      Comment


      • #4
        Bonjour,

        Désolé, j'ai pas été très réactif ! Voici les infos que j'avais homis :

        Ma machine supervisée : Debian sarge 2.6 (Sur laquelle tourne Oreon-Nagios)

        1 - Oreon Version v1.2.3
        2 - $USER1$/check_graph_load_average.pl -H $HOSTADDRESS$ -v $ARG1$ -W -C $ARG2$ -g -S $ARG3$
        3 - !192.168.0.9!1!home
        4 -

        define service{
        service_description Visualisation de la charge moyenne
        host_name unixserv
        is_volatile 0
        check_command check_graph_load_average!192.168.0.9!1!home!4
        max_check_attempts 5
        normal_check_interval 2
        retry_check_interval 1
        active_checks_enabled 1
        passive_checks_enabled 0
        check_period 24x7
        parallelize_check 1
        obsess_over_service 0
        check_freshness 0
        freshness_threshold 0
        event_handler_enabled 0
        low_flap_threshold 0
        high_flap_threshold 0
        flap_detection_enabled 0
        process_perf_data 0
        retain_status_information 1
        retain_nonstatus_information 1
        notification_interval 60
        notification_period 24x7
        notification_options w,c,r
        notifications_enabled 0
        contact_groups Maxence
        stalking_options w,c
        }

        5 - Unknown -S Service ID expected... or it doesn't exist, try another id - number

        6 - Je poserais un nouveau post pour cette étape, là je suis au taf et j'ai pas accès à ma machine !!!

        Merci
        a+
        Nagios : 2.5
        Oreon : 1.3.3
        Mysql : 4.1

        Comment


        • #5
          c'est le "home" qui merde il attend du chiffre

          met [0-9] ca ira mieux

          Comment


          • #6
            Excuse moi mais là je pige pas tout ! hock:

            Quand on regarde la commande :

            $USER1$/check_graph_load_average.pl -H $HOSTADDRESS$ -v $ARG1$ -W -C $ARG2$ -g -S $ARG3$

            En 1, il faut : l'adresse
            2 : Version SNMP
            3 : La communauté (Il me semble d'apès la commande que -W ne prend pas d'arguments)
            Et pis c'est tout !!!!

            Et c'est ce que j'ai mis : !192.168.0.9!1!home

            Donc je dis pas que tu as tort mais j'aimerais juste savoir pourquoi il pose pb et dans ce cas, comment je renseigne ma communauté.

            Merci
            a+
            Nagios : 2.5
            Oreon : 1.3.3
            Mysql : 4.1

            Comment


            • #7
              $HOSTADDRESS$ est une macro auto renseigne par Nagios, tu n'as pas a la renseigner dans la definition des arguments de ton service.

              De la meme maniere, le -S est genere automatiquement par Oreon.
              Le -W ne prend effectivement pas d'argument.

              Tu dois donc renseigner deux arguments dans la def de ton service
              -v $ARG1$ -C $ARG2$
              !1!home
              Romain Le Merlus
              Centreon Forge
              MERETHIS

              Comment


              • #8
                OK ! Merci mais sur tous les autres services, je renseigne ce paramètre et ça marche mais la effectivement c'est ça le prob !!! Merci

                Mais je ne vais pas me réjouir trop vite, le problème maintenant est exactement le même quand j'exécute la commande à la main !!! Et je ne comprend pas trop le message d'erreur :

                UNKNOWN: Received noSuchName(2) error-status at error-index 3.

                Et avec le service check_graph_load_process par contre il est différents :

                UNKNOWN: Requested table is empty or does not exist.

                Merci
                a+
                Nagios : 2.5
                Oreon : 1.3.3
                Mysql : 4.1

                Comment


                • #9
                  Originally posted by rom
                  Donne nous donc
                  6 - Le resultat quand tu lances la commande en ligne de commande sans les options -S et -g
                  Je n'avais pu répondre à cette question ce matin !

                  Quand je lance la commande : ./check_graph_load_average.pl -H 192.168.0.9 -C home -v 1

                  j'obtiens :
                  UNKNOWN: Received noSuchName(2) error-status at error-index 3

                  C'est à dire ce que j'ai dans Oreon maintenant que j'ai résolu mon prob d'argument !!!

                  Merci de me donner des infos.

                  a+
                  Nagios : 2.5
                  Oreon : 1.3.3
                  Mysql : 4.1

                  Comment


                  • #10
                    bah là ca veut dire que tu n'as pas d'accès à la mib SNMP

                    regarde ton fichier de conf comme indique dans le wiki:
                    http://wiki.oreon-project.org/wakka....ki=SnmpdConfFR
                    Ubuntu 8.04
                    Nagios 3.2 + nagios-plugins-1.4.14
                    ndoutils-1.4b9
                    Centreon 2.1.8
                    centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

                    Comment


                    • #11
                      Ok ! Merci c'est nikel ! En fait j'avais oublié de faire cette modification.

                      Y-a un seul truc quand même c'est que les fichiers *.rrd sont créer avec les droits nagios:nagios donc si on veut pouvoir les visualiser, il faut sur tous faire un chown nagios:www-data.

                      Encore un grand merci.

                      a+
                      Nagios : 2.5
                      Oreon : 1.3.3
                      Mysql : 4.1

                      Comment


                      • #12
                        Originally posted by Max
                        Ok ! Merci c'est nikel ! En fait j'avais oublié de faire cette modification.
                        de rien

                        Originally posted by Max
                        Y-a un seul truc quand même c'est que les fichiers *.rrd sont créer avec les droits nagios:nagios donc si on veut pouvoir les visualiser, il faut sur tous faire un chown nagios:www-data.
                        pas besoin
                        Ubuntu 8.04
                        Nagios 3.2 + nagios-plugins-1.4.14
                        ndoutils-1.4b9
                        Centreon 2.1.8
                        centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

                        Comment


                        • #13
                          Idem!!

                          J'ai la même erreur que max mais malheureusement le lien proposé pour l'aider est mort. Quelqu'un peut-il me renseigner??
                          Merci d'avance.

                          Comment


                          • #14
                            Bonjour, j'ai le meme probleme en utilisant ce plugin, le lien donné a l'air toujours mort.

                            Merci si vous avez des reponses.

                            Comment


                            • #15
                              Yop, moi aussi j'ai le même problème, j'aimerais bien savoir comment vous avez fait ???:confused: :confused:

                              Comment

                              Working...
                              X