Announcement

Collapse
No announcement yet.

check_graph_ping ne créer pas le fichier rrd

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • check_graph_ping ne créer pas le fichier rrd

    Bonjour,

    Mon problème est que le service check_graph_ping ne créer pas le fichier *.rrd dans /usr/local/oreon

    Pourtant j'ai d'autres service check_graph_* qui tourne et qui fonctionne.

    De ce fait quand je veux voir mon graph, j'obtiens : Le fichier /usr/local/oreon/rrd/29.rrd n’est pas accessible

    Ensuite si je le créer à la main avec les bon droits, nagios n'arrive pas à écrire dedans les infos !

    Quelqu'un peut m'aider ?

    Merci
    a+
    Nagios : 2.5
    Oreon : 1.3.3
    Mysql : 4.1

  • #2
    déjà ne le créé pas à la main, ca ne sert à rien juste qu'à empirer la situation.

    Ensuite regarde le path dans les options de ton binaire rrdtool
    enfin verifie aussi le paquet php-gd
    Ubuntu 8.04
    Nagios 3.2 + nagios-plugins-1.4.14
    ndoutils-1.4b9
    Centreon 2.1.8
    centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

    Comment


    • #3
      En fait j'ai les trois répertoire suivant avec un fichier php.ini dans chacun :

      drwxr-xr-x 2 root root 4096 Jun 4 18:29 apache2
      drwxr-xr-x 2 root root 4096 Jun 4 18:30 cgi
      drwxr-xr-x 2 root root 4096 May 25 15:57 cli

      Et gd est installé et dans mes trois fichiers php.ini, j'ai extension=gd.so


      Ensuite quand je cherche le gd.so dans le système, j'obtiens :

      /usr/lib/libgd.so.2
      /usr/lib/libgd.so.2.0.33
      /usr/lib/php4/20020429/gd.so

      Puis qu'est ce que t'appel les options de mon binaire rrdtool :?:

      Parce que dans la config d'oreon, j'ai que deux lignes pour le binaire rrdtool :

      RRDToolsPath/rrdtool : /usr/local/rrdtool/bin/rrdtool
      Bases RRDTool : /usr/local/oreon/rrd/

      hock:
      Nagios : 2.5
      Oreon : 1.3.3
      Mysql : 4.1

      Comment


      • #4
        Originally posted by Max
        Puis qu'est ce que t'appel les options de mon binaire rrdtool :?:

        Parce que dans la config d'oreon, j'ai que deux lignes pour le binaire rrdtool :

        RRDToolsPath/rrdtool : /usr/local/rrdtool/bin/rrdtool
        désole ops: , je me suis mal exprimé, mais tu m'as bien compris


        Ton check_graph_ping.pl fonctionne bien en ligne de commande ?
        http://wiki.oreon-project.org/wakka....eckGraphPingFR

        Si tu as d'autres graph, qui tourne bien et que tu visualises bien, cela veut dire que de ton coté toute est bien installé, c'est juste ton plugin et les arguments que tu passes, qui foirent qq part.

        Essaie de le supprimer, regenerer la conf nagios, redemarrer nagios.
        faire le test en shell sans le graph dans la ligne de commande

        voilà ce que je peux te donner comme piste :wink:
        Ubuntu 8.04
        Nagios 3.2 + nagios-plugins-1.4.14
        ndoutils-1.4b9
        Centreon 2.1.8
        centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

        Comment


        • #5
          Originally posted by inconnuflo

          désole ops: , je me suis mal exprimé, mais tu m'as bien compris
          T'inquiète c'est pas grave ! :wink:


          Sinon, j'obtiens bien ça dans mon interface d'Oreon :

          GPING OK - rtt min/avg/max/mdev = 0.327/0.349/0.450/0.043 ms

          Mais quand je veux voir le graphique j'ai : Le fichier /usr/local/oreon/rrd/29.rrd n'est pas accessible

          Bien que je l'ai supprimé de la config puis crée à nouveau après un redémarrage de Nagios !!!

          Je testerai ce soir directement en ligne de commande mais c'est assé bizzare comme bug, je pense qu'il va falloir que je creuse un peu en comparant avec les autres graph !!!

          a+
          Nagios : 2.5
          Oreon : 1.3.3
          Mysql : 4.1

          Comment


          • #6
            Donne la défnition du check, et les arguments que tu passes
            Ubuntu 8.04
            Nagios 3.2 + nagios-plugins-1.4.14
            ndoutils-1.4b9
            Centreon 2.1.8
            centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

            Comment


            • #7
              La définition de la commande est : check_graph_ping.pl -H $HOSTADDRESS$ -w 200,20% -c 500,40% -n $ARG1$ -g -S $ARG2$

              Et les arguments, j'en passe pas parce quand on fait un ./check_graph_ping -h les options w, c sont défini par défaut à 200,20% puis 500,40% et le -n est le nombre d'écho qui par défaut est 1.

              Faut'il quand même les mettre ???
              Nagios : 2.5
              Oreon : 1.3.3
              Mysql : 4.1

              Comment


              • #8
                Non t'es pas obligé de les mettres, mais je conseille de mettre au minimum 3 pings pour avoir un rta qui ressemble à quelquechose
                Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                Fedora Core 5 - 2.6.20-1.2320

                Comment


                • #9
                  OK c'est bon merci à tous :wink:

                  Avec les solutions que vous m'avez apporté, j'en conclus qu'il faut au moins mettre 2 échos icmp (Enfin moi j'ai mis !5) pour obtenir des graphs !

                  Sans ça nagios retourne bien Graph .... OK mais quand on veut les visualiser, il ne les graphs pas.

                  Maintenant avec !5, c'est bon mais graph sont créer.

                  Encore merci
                  a+
                  Nagios : 2.5
                  Oreon : 1.3.3
                  Mysql : 4.1

                  Comment


                  • #10
                    kool
                    :lol:
                    Ubuntu 8.04
                    Nagios 3.2 + nagios-plugins-1.4.14
                    ndoutils-1.4b9
                    Centreon 2.1.8
                    centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

                    Comment

                    Working...
                    X