Announcement

Collapse
No announcement yet.

Problème réponse SNMP hôtes windows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problème réponse SNMP hôtes windows

    Bonjour,

    Mon problème est que j'ai un hôte sous XP familiale + un sous pro.

    Sur les deux j'ai acitvé le protocole SNMP mais les deux ne réponde pas aux requêtes SNMP de nagios avec le plugin check_snmp_win.

    Pourtant SNMP marche bien sur mes hôtes :



    J'ai oreon 1.2.3. Voici les arguments de la commande : !192.168.0.3!public!ALL

    Voic le message d'erreur : ERROR: Process name table : No response from remote host '192.168.0.3'.

    Pour info, j'utilise également cacti et sous cacti j'ai SNMP error donc je ne pense pas que le pb vient d'oreon mais plutôt du SNMP sous windows !!!

    Si quelqun a déjà eu ce problème qu'il m'en fasse part !

    a+
    Max
    Nagios : 2.5
    Oreon : 1.3.3
    Mysql : 4.1

  • #2
    comment as-tu configurer ton agent dans les services ?
    Ubuntu 8.04
    Nagios 3.2 + nagios-plugins-1.4.14
    ndoutils-1.4b9
    Centreon 2.1.8
    centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

    Comment


    • #3
      Alors,

      Comme ceci sous windows :



      Et comme cela sous oreon :

      Check_command : check_snmp_win
      Check_command_arguments : !192.168.0.3!macommunaute!ALL

      a+
      Nagios : 2.5
      Oreon : 1.3.3
      Mysql : 4.1

      Comment


      • #4
        dans tes arguements, enlève l'@IP de la machine

        laisse juste
        !macommunaute!ALL
        Ubuntu 8.04
        Nagios 3.2 + nagios-plugins-1.4.14
        ndoutils-1.4b9
        Centreon 2.1.8
        centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

        Comment


        • #5
          Salut,

          J'ai enlevé l'IP dans le passage d'arguments mais j'ai toujours un message d'erreur : ERROR: Process name table : No response from remote host '192.168.0.3'.

          Je pense vraiment que le problème est plutôt du côté de windows qui ne répond pas aux requêtes SNMP mais je pige vraiment pas !!!! C'est avec tous mes postes Win XP pro ou familiale :?

          J'ai même fait le test sans firewall et dans les journaux d'évènement SNMP fonctionne bien ! Et d'après la capture d'ethereal plus haut on voit bien que le serveur nagios envoie des requêtes (C'est le 192.168.0.9 où j'ai nagios d'installé) et windows ne réponds jamais :!:

          Alors est-ce qu'il y aurait un souci avec le script perl check_snmp_win qui est pourtant conçu pour windows :?: :?: :?:

          Mais je ne pense pas parce que même avec cacti j'ai un SNMP error :twisted:

          Si quelqu'un à une idée je suis prenneur parce que là je commence à être en manque d'idée pour faire fonctionner SNMP !!!!

          Merci
          a+
          Nagios : 2.5
          Oreon : 1.3.3
          Mysql : 4.1

          Comment


          • #6
            Originally posted by Max
            Dans l'agent, coches toutes les cases services
            Ubuntu 8.04
            Nagios 3.2 + nagios-plugins-1.4.14
            ndoutils-1.4b9
            Centreon 2.1.8
            centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

            Comment


            • #7
              que ton service SNMP est démarré sous windows?
              Dans l'onglet sécurité rentre l'adresse IP de la machine qui peut accéder avec SNMP!

              ------
              OK j'avais pas vu les screenshot au dessus avec ca ca devrait marcher 8)
              Oreon 1.2.2 oOo Nagios 1.3 oOo Red Hat Enterprise Linux AS (v.4 for 32 bits x86)

              Proc: Intel Xeon 2,8Ghz oOo RAM: 1024Mb

              Comment


              • #8
                Originally posted by waltergin
                que ton service SNMP est démarré sous windows?
                Oui en automatique 8)

                Sinon j'ai coché toutes les cases et relancer le check sous oreon mais j'ai lu sur le net (Sur un site de supinfo) qu'il fallait seulement laisser les deux cases (celles qu'il y a sur le sreen) pour surveiller un hôte "simple" sous windows.

                Mais là j'aimerais bien comprendre pourquoi mon PC sous Windows ne répond pas aux requêtes ???? Ahhhhhh windaube :evil:
                Nagios : 2.5
                Oreon : 1.3.3
                Mysql : 4.1

                Comment


                • #9
                  Problème de Firewall? Mauvais adresse IP autorisée sur le serveur Windows (le serveur Nagios à une seule interface réseau d'adresse IP 192.168.0.9)? Le service SNMP sur Windows a été redémarré?

                  Comment


                  • #10
                    Je suis en test avec tout les firewalls de désactivé.

                    Comme le montre le screen ,le serveur nagios est sur 192.168.0.9 et il a qu'une interface réseau qui est celle ci.

                    Et SNMP démarrer en automatique.

                    Sinon j'ai peu être une piste :idea:

                    Moi je passe comme arguments : !macommunaute!ALL

                    USER1$/check_snmp_win.pl -H $HOSTADDRESS$ -C $ARG1$ -s -n $ARG2$

                    Le -n étant les services wins, dns (...) quelqu'un serait me dire où je peux trouver la liste des services existants ????? Parce que moi c'est juste des postes de travail.

                    Je pense que mon problème vient de là !
                    Nagios : 2.5
                    Oreon : 1.3.3
                    Mysql : 4.1

                    Comment


                    • #11
                      Y a du mieux !!!

                      J'ai mis !macommunaute!wins et j'obtiens comme message d'erreur : No data yet (service was in a soft problem state during state retention)

                      J'ai bien un partage WINS d'activé.

                      ça c'est pour la machine sous XP pro, maintenant je vais tester avec celle sous familiale

                      Quelq'un à une idée :?:
                      Nagios : 2.5
                      Oreon : 1.3.3
                      Mysql : 4.1

                      Comment


                      • #12
                        Je crois que j'ai parlé un peu vite !!! Le service oscille. Maintenant j'ai comme tout à l'heure : No data yet (service was in a soft problem state during state retention)
                        Nagios : 2.5
                        Oreon : 1.3.3
                        Mysql : 4.1

                        Comment


                        • #13
                          essaie avec un autre service
                          dhcp ou dns
                          Ubuntu 8.04
                          Nagios 3.2 + nagios-plugins-1.4.14
                          ndoutils-1.4b9
                          Centreon 2.1.8
                          centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

                          Comment


                          • #14
                            Ok Merci !!!! Avec service dhcp, il n'y a pas de souci. Maintenant je vais chercher sur le net les services à monitorer sous windows. Parce que ce que j'aimerais bien c'est grapher le traffic par poste.

                            Sinon celui sous familial, il est toujours malade :cry: Il reçoit les requêtes mais il ne répond pas ! Je pense que ça va être radical, je vais désinstaller tout les firewalls du poste (Enfin celui de windows + le miens)

                            Encore Merci à tous pour votre aide. Pour vous dire ce que je pense, ici c'est un vrai forum. Ce que j'entends par là c'est que quand quelqu'un à des petits soucis et ben y a toujours du monde pour l'aider. Et c'est pas comme ça dans tous les forums.

                            Généralement les mecs répondent à deux trois trucs et basta !!! Alors qu'ici on a un vrai soutien

                            Et je vous félicite tous de ce beau travail. Oreon marche nickel.

                            a+
                            Max
                            Nagios : 2.5
                            Oreon : 1.3.3
                            Mysql : 4.1

                            Comment


                            • #15
                              Originally posted by Max
                              Ok Merci !!!! Avec service dhcp, il n'y a pas de souci. Maintenant je vais chercher sur le net les services à monitorer sous windows. Parce que ce que j'aimerais bien c'est grapher le traffic par poste.
                              Si tu veux grapher le trafic réseau, regarde check_graph_traffic.pl
                              http://wiki.oreon-project.org/wakka....OreonPluginsFR
                              Ubuntu 8.04
                              Nagios 3.2 + nagios-plugins-1.4.14
                              ndoutils-1.4b9
                              Centreon 2.1.8
                              centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

                              Comment

                              Working...
                              X