Announcement

Collapse
No announcement yet.

Problème réponse SNMP hôtes windows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Max
    replied
    Originally posted by inconnuflo
    Si tu veux grapher le trafic réseau, regarde check_graph_traffic.pl
    http://wiki.oreon-project.org/wakka....OreonPluginsFR
    Ah oui !!! En plus je l'utilise déjà ce plugin ! Je sais pas trop ce que j'ai raconté, je me suis embrouillé ! C'est surement le fait de faire fonctionner SNMP sur mon hôte windows qui m'a rendu euphorique (Depuis le temps)

    Aller a+ :wink:

    Leave a comment:


  • inconnuflo
    replied
    Originally posted by Max
    Ok Merci !!!! Avec service dhcp, il n'y a pas de souci. Maintenant je vais chercher sur le net les services à monitorer sous windows. Parce que ce que j'aimerais bien c'est grapher le traffic par poste.
    Si tu veux grapher le trafic réseau, regarde check_graph_traffic.pl
    http://wiki.oreon-project.org/wakka....OreonPluginsFR

    Leave a comment:


  • Max
    replied
    Ok Merci !!!! Avec service dhcp, il n'y a pas de souci. Maintenant je vais chercher sur le net les services à monitorer sous windows. Parce que ce que j'aimerais bien c'est grapher le traffic par poste.

    Sinon celui sous familial, il est toujours malade :cry: Il reçoit les requêtes mais il ne répond pas ! Je pense que ça va être radical, je vais désinstaller tout les firewalls du poste (Enfin celui de windows + le miens)

    Encore Merci à tous pour votre aide. Pour vous dire ce que je pense, ici c'est un vrai forum. Ce que j'entends par là c'est que quand quelqu'un à des petits soucis et ben y a toujours du monde pour l'aider. Et c'est pas comme ça dans tous les forums.

    Généralement les mecs répondent à deux trois trucs et basta !!! Alors qu'ici on a un vrai soutien

    Et je vous félicite tous de ce beau travail. Oreon marche nickel.

    a+
    Max

    Leave a comment:


  • inconnuflo
    replied
    essaie avec un autre service
    dhcp ou dns

    Leave a comment:


  • Max
    replied
    Je crois que j'ai parlé un peu vite !!! Le service oscille. Maintenant j'ai comme tout à l'heure : No data yet (service was in a soft problem state during state retention)

    Leave a comment:


  • Max
    replied
    Y a du mieux !!!

    J'ai mis !macommunaute!wins et j'obtiens comme message d'erreur : No data yet (service was in a soft problem state during state retention)

    J'ai bien un partage WINS d'activé.

    ça c'est pour la machine sous XP pro, maintenant je vais tester avec celle sous familiale

    Quelq'un à une idée :?:

    Leave a comment:


  • Max
    replied
    Je suis en test avec tout les firewalls de désactivé.

    Comme le montre le screen ,le serveur nagios est sur 192.168.0.9 et il a qu'une interface réseau qui est celle ci.

    Et SNMP démarrer en automatique.

    Sinon j'ai peu être une piste :idea:

    Moi je passe comme arguments : !macommunaute!ALL

    USER1$/check_snmp_win.pl -H $HOSTADDRESS$ -C $ARG1$ -s -n $ARG2$

    Le -n étant les services wins, dns (...) quelqu'un serait me dire où je peux trouver la liste des services existants ????? Parce que moi c'est juste des postes de travail.

    Je pense que mon problème vient de là !

    Leave a comment:


  • templuche
    replied
    Problème de Firewall? Mauvais adresse IP autorisée sur le serveur Windows (le serveur Nagios à une seule interface réseau d'adresse IP 192.168.0.9)? Le service SNMP sur Windows a été redémarré?

    Leave a comment:


  • Max
    replied
    Originally posted by waltergin
    que ton service SNMP est démarré sous windows?
    Oui en automatique 8)

    Sinon j'ai coché toutes les cases et relancer le check sous oreon mais j'ai lu sur le net (Sur un site de supinfo) qu'il fallait seulement laisser les deux cases (celles qu'il y a sur le sreen) pour surveiller un hôte "simple" sous windows.

    Mais là j'aimerais bien comprendre pourquoi mon PC sous Windows ne répond pas aux requêtes ???? Ahhhhhh windaube :evil:

    Leave a comment:


  • waltergin
    replied
    que ton service SNMP est démarré sous windows?
    Dans l'onglet sécurité rentre l'adresse IP de la machine qui peut accéder avec SNMP!

    ------
    OK j'avais pas vu les screenshot au dessus avec ca ca devrait marcher 8)

    Leave a comment:


  • inconnuflo
    replied
    Originally posted by Max
    Dans l'agent, coches toutes les cases services

    Leave a comment:


  • Max
    replied
    Salut,

    J'ai enlevé l'IP dans le passage d'arguments mais j'ai toujours un message d'erreur : ERROR: Process name table : No response from remote host '192.168.0.3'.

    Je pense vraiment que le problème est plutôt du côté de windows qui ne répond pas aux requêtes SNMP mais je pige vraiment pas !!!! C'est avec tous mes postes Win XP pro ou familiale :?

    J'ai même fait le test sans firewall et dans les journaux d'évènement SNMP fonctionne bien ! Et d'après la capture d'ethereal plus haut on voit bien que le serveur nagios envoie des requêtes (C'est le 192.168.0.9 où j'ai nagios d'installé) et windows ne réponds jamais :!:

    Alors est-ce qu'il y aurait un souci avec le script perl check_snmp_win qui est pourtant conçu pour windows :?: :?: :?:

    Mais je ne pense pas parce que même avec cacti j'ai un SNMP error :twisted:

    Si quelqu'un à une idée je suis prenneur parce que là je commence à être en manque d'idée pour faire fonctionner SNMP !!!!

    Merci
    a+

    Leave a comment:


  • inconnuflo
    replied
    dans tes arguements, enlève l'@IP de la machine

    laisse juste
    !macommunaute!ALL

    Leave a comment:


  • Max
    replied
    Alors,

    Comme ceci sous windows :



    Et comme cela sous oreon :

    Check_command : check_snmp_win
    Check_command_arguments : !192.168.0.3!macommunaute!ALL

    a+

    Leave a comment:


  • inconnuflo
    replied
    comment as-tu configurer ton agent dans les services ?

    Leave a comment:

Working...
X