Announcement

Collapse
No announcement yet.

Nagios file configuration: max_check_interval

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Nagios file configuration: max_check_interval

    Hello!
    I have Nagios 2.3 installed together with Oreon 1.3.
    Installation went OK, during the configuration of Oreon I had problems with log_passive_service_checks and the other table, that doesn't exist in Nagios.cfg. I solved it by deleting them. Is this OK? Oreon is working, but I don't know if it's ok.
    I am getting other errors when I export Nagios files. In hosts.cfg there is error:
    Error: Invalid host object directive 'max_check_interval'.
    Error: Could not add object property in file '/usr/local/oreon/filesGeneration/nagiosCFG/hosts.cfg' on line 27.

    Is this because of deleting the two tables or is something else wrong. The table with this data is properly named: host_check_interval in host table but when I generate files it is somehow transformed into max_check_interval.
    Can somebody please help me?

  • #2
    Possible resolution?

    I found a file, responsible for file generation: www/include/configuration/configGenerate/genHosts.php

    There was a directive in/near line 109, that reffers to writing the host_check_interval value:

    if ($host["host_check_interval"]) $str .= print_line("max_check_interval", $host["host_check_interval"]);


    i changed to:

    if ($host["host_check_interval"]) $str .= print_line("check_interval", $host["host_check_interval"]);

    The file generation is working now. Is that OK? I am setting up Oreon for my company and I don't want to be in trouble in 6 months if this resolution is not correct.[/b]

    Comment


    • #3
      Good work !

      It was a bug we correct for the next release. You find it alone, congratulations.
      Romain Le Merlus
      Centreon Forge
      MERETHIS

      Comment

      Working...
      X