Announcement

Collapse
No announcement yet.

Importing/reading archive logs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Importing/reading archive logs

    Greetings,

    I would like for Oreon to display the history of a device from the Nagios archive logs. I have had Nagios 2.x installed for almost 6 months, I installed Oreon 1.3 last week, but when I go to view the history of a device anything older than the install date of Oreon shows as pending. Is there a way to import this data so that it will be shown properly?

    Thanks

    Joseph

  • #2
    yes you have to had a cron in our crontab... report you to the readme. All is explain in the readme..
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      Thank you for the reply, I do have the cron's setup for ArchiveLogInDB.php and deleteDB.pl. But I am still not seeing it displayed properly, anything older than the date I install Oreon is showing as Pending:

      Host state
      State Time Total Time Known Time
      Up 0 0
      Down 0 0
      Unreachable 0 0
      Pending 1M 13h 30m 57s 100 100

      That was for the last month on one host state, also I am not seeing how to pull reporting on services.

      I will go thru the README's and see what I can find out.

      Again, thanks for the quick response, you guys rock.

      Joe

      Comment


      • #4
        your scripts in crontab might be not launch ? launch it manually...
        Julien Mathis
        Centreon Project Leader
        www.merethis.com |

        Comment


        • #5
          I tried to launch it manually and get the following error:

          Connecting probems with oreon database : DB Error: extension not found

          I checked and php-db is there:
          ii php-db 1.7.6-2 PHP PEAR Database Abstraction Layer

          DB.php is in the php directory, and nothing else is having a problem connecting to the database.

          Comment


          • #6
            I wanted to thank you for your help, I found the problem. I have php4 loaded and that is what apache is using, however the /usr/bin/php on the server was pointing to a php5 install that has been there for months. I moved the link to point to php4 and it is now working.

            Thank you for all of your help.

            Joseph :P

            Comment


            • #7
              Hi, I've got exactly the same problem, I must have a php5 installation somewhere.
              I didn't understand what you were explaining. Where is the link you were talking about ?
              Anybody else could answer me ?

              Comment

              Working...
              X