Announcement

Collapse
No announcement yet.

[Résolu] impossible d'afficher la status map

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Résolu] impossible d'afficher la status map

    J'ai (enfin) réussi à installer nagios 2.5+oreon 1.3.3. A l'origine tout cela servira pour mon entreprise pour remonter les potentielles erreurs sur des routeurs et switchs. Là je l'ai seulement testé avec une imprimante réseau. Nagios me montre qu'il ping bien l'imprimante et que son statut est "OK" mais lorque je clique sur :
    -status map
    -trends
    -Alert Histogram

    il met met "Page web introuvable" HTTP 404

    D'ou peut venir l'erreur? je trouve cela bizarre car lorque je clique sur 3D status map, la carte apparait très bien.

    Merci d'avance
    Debian 3.1 - Nagios 2.5 - Nagios plugins 1.4.3 - oreon 1.3.3

  • #2
    personne ne sait?
    Debian 3.1 - Nagios 2.5 - Nagios plugins 1.4.3 - oreon 1.3.3

    Comment


    • #3
      L'url ?
      Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
      Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
      Fedora Core 5 - 2.6.20-1.2320

      Comment


      • #4
        pourquoi l'url?
        Debian 3.1 - Nagios 2.5 - Nagios plugins 1.4.3 - oreon 1.3.3

        Comment


        • #5
          Meme probleme lol sauf que moi il ne ping meme pas un host je crois, jvais me replonger dans les fichier de config ^^

          Comment


          • #6
            Re: impossible d'afficher la status map

            Originally posted by ptinico44
            J'ai (enfin) réussi à installer nagios 2.5+oreon 1.3.3. A l'origine tout cela servira pour mon entreprise pour remonter les potentielles erreurs sur des routeurs et switchs. Là je l'ai seulement testé avec une imprimante réseau. Nagios me montre qu'il ping bien l'imprimante et que son statut est "OK" mais lorque je clique sur :
            -status map
            -trends
            -Alert Histogram

            il met met "Page web introuvable" HTTP 404

            D'ou peut venir l'erreur? je trouve cela bizarre car lorque je clique sur 3D status map, la carte apparait très bien.
            La carte 3D utilise un fichier VRML là où mes trois pages que tu as cité utilisent des CGI dépendants de ... GD. Comment as-tu compilé Nagios (oui, parce qu'avec un paquet binaire, ceci ne serait pas arrivé) ?
            Raphaël 'SurcouF' Bordet
            Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
            Dons Paypal

            Comment


            • #7
              j'ai utilisé le nagios 2.5 disponible en téléchargement sur ce site et j'ai suvi la doc du wiki, ça restreint les erreurs je pense
              Debian 3.1 - Nagios 2.5 - Nagios plugins 1.4.3 - oreon 1.3.3

              Comment


              • #8
                en fait il me manque trois fichiers :

                -statusmap.cgi
                -trends.cgi
                -histogram.cgi

                quelqu'un sait-il comment faire pour récupérer ces fichiers sachant que j'ai déjà réinstallé trois fois et que le problème revient
                Debian 3.1 - Nagios 2.5 - Nagios plugins 1.4.3 - oreon 1.3.3

                Comment


                • #9
                  S'il manque des fichiers c'est qu'ils n'ont pas pu être compilés et donc copiés lors du make install. Regarde les messages d'erreur ou les warnings qui s'affichent lors du ./configure de Nagios. Il doit te manquer une dépendance, certainement un libgd2-* ou libgd2-*-dev comme l'a déjà souligné surcouf.
                  Système : Debian Etch 4.0r8 / Apache 2.2.3 / PHP 5.2.0 / MySQL 5.0.32
                  Monitoring : Nagios 2.12 / Plugins 1.4.13 / Centreon 1.4.2.7

                  Comment


                  • #10
                    c'est bon, en fait il me manquait les paquets DEVEL, je les ai installé et j'ai recréer les cgi
                    Debian 3.1 - Nagios 2.5 - Nagios plugins 1.4.3 - oreon 1.3.3

                    Comment


                    • #11
                      Originally posted by ptinico44 View Post
                      c'est bon, en fait il me manquait les paquets DEVEL, je les ai installé et j'ai recréer les cgi
                      Salut, j'etais aussi bloqué pour la map, j'ai fait un apt-get install libgd2-dev puis j'ai tout relancer.
                      comment recreer les cgi manquant pour la map et surtout ou se trouve la map dans oreon 1.3.3 ??

                      merci

                      Comment

                      Working...
                      X