Announcement

Collapse
No announcement yet.

Ou trouver des rpm's pour npre?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ou trouver des rpm's pour npre?

    Bonjour,

    Voila j'ai tourné dans tous les sens sur internet et je n'arrive pas a trouver les clients nrpe et plugins pour une RH 6.2.

    J'ai bien trouvé les rpms suivant : *

    - nagios-plugins-nrpe-2.0-3.rh62.dag.i386.rpm
    - nagios-nrpe-2.0-3.rh62.dag.i386.rpm

    Mais je n'arrive pas à les installer car cela me met une erreur de dépendance (Nagios). Apres avoir lu qq forum il faudrait installer le client nagios-plugins plutot que nagios-plugins-nrpe mais je ne le trouve pas.

    Donc que faire? Est il possible d'installer des rpm d'autres distributions? ou connaissez vous un lien pour les download?

    Merci par avnace.

  • #2
    Originally posted by Paulin View Post
    Bonjour,

    Voila j'ai tourné dans tous les sens sur internet et je n'arrive pas a trouver les clients nrpe et plugins pour une RH 6.2.

    J'ai bien trouvé les rpms suivant : *

    - nagios-plugins-nrpe-2.0-3.rh62.dag.i386.rpm
    - nagios-nrpe-2.0-3.rh62.dag.i386.rpm

    Mais je n'arrive pas à les installer car cela me met une erreur de dépendance (Nagios). Apres avoir lu qq forum il faudrait installer le client nagios-plugins plutot que nagios-plugins-nrpe mais je ne le trouve pas.
    Il s'agit de deux paquets distincts pour deux raisons :
    - le premier installe le plugin check_nrpe et dépend donc de nagios[1] ;
    - le second installe l'agent nrpe et n'a pas besoin de nagios. Tu installes celui-ci sur les systèmes où tu as besoin d'exécuter des plugins[2] de Nagios (ou écrits par des tiers) à DISTANCE par rapport à Nagios.


    PS: T'as pas trouvé plus ancien comme version de RedHat ?
    [1]: http://dag.wieers.com/rpm/packages/nagios/
    [2]: http://dag.wieers.com/rpm/packages/nagios-plugins/
    Raphaël 'SurcouF' Bordet
    Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
    Dons Paypal

    Comment


    • #3
      Le problème c'est que quand j'installe le rpm (nagios-nrpe-2.0-3.rh62.dag.i386.rpm) cela me met une dépendance sur nagios-plugins.

      Et pour la version de la machine je n'ai pas trop le choix c'est une machine critique que l'on ne peut pas migrer pour le moment.

      Donc est ce normal qu'il me demande une dépendance avec un rpm nagios-plugins?

      Merci par avance.

      edit : dans les liens que tu m'a donnés il n'y a aucun rpm pour RH62.Est cepossible de prendre les rpm autre que pour RH62?Si oui, ceux de quel version?

      Comment

      Working...
      X