Announcement

Collapse
No announcement yet.

Start nagios un peu bizarre

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Start nagios un peu bizarre

    Lorsque je fais etc/init.d/nagios start j'ai ce drole de message :
    Starting nagios:Pas de répertoire, connexion avec HOME=/
    done.

    Je comprends pas trop ce qu'il se passe, mais après lrosque je vais dans oréon nagios a bien démarré.

    Désolé si je reparle d'une chose qui a été traitée, si c'est le cas le lien du sujet en question ne suffira

  • #2
    probablement parcequ'il n'a pas de home de configuré
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320

    Comment


    • #3
      De home configuré ? C'est à dire ?
      En tout cas je ne peux pas accéder à http://127.0.0.1/nagios2 (j'ai essayé avec nagios cela ne fonctionne pas). Mais cela est dut au fait que je n'ai pas configuré le fichier httpd.conf de apache. Ca serai ca mon problème ?

      Comment


      • #4
        le home se configure dans le fichier passwd
        Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
        Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
        Fedora Core 5 - 2.6.20-1.2320

        Comment


        • #5
          Lors de mon installe sur kubuntu j'avais dans /etc/nagios un fichier htpasswd.users et un fichier apache.conf, la pour mon installe sur Debian Etch je ne les ai pas :?

          Pour le fichier passwd tu parles de htpasswd.users ?

          Désolé mais avec tous les fichiers par moment je suis un peu perdu ops:

          Comment


          • #6
            Si c'est le fichier htpasswd.users dont tu parles je ne trouve que dans /usr/bin/htpasswd et lorque je l'ouvre il est rempli de symbole bizarre :? Je ne pense pas que ca soit celui du coup. Je suis perdu

            Comment


            • #7
              Originally posted by klure View Post
              Si c'est le fichier htpasswd.users dont tu parles je ne trouve que dans /usr/bin/htpasswd et lorque je l'ouvre il est rempli de symbole bizarre :? Je ne pense pas que ca soit celui du coup. Je suis perdu
              Normalement, le fichier htpasswd.users, c'est toi qui le crée.
              Tu tapes :
              htpasswd -c /usr/local/nagios/etc/htpasswd.users admin
              Tu remplaces "admin" par l'utilisateur voulu et il te demanderas de saisir le mot de passe de cette utilisateur. htpasswd.users doit se trouver dans "/usr/local/nagios/etc/" avec tout les "*.cfg"

              Ensuite, tu édites "cgi.cfg" et tu rajoutes "admin" devant tous les lignes commençant par "authorized".

              Ensuite, tu édites ton httpd.conf (ou apache2.conf) en rajoutant :
              ScriptAlias /nagios/cgi-bin /usr/local/nagios/sbin

              <Directory "/usr/local/nagios/sbin">
              Options ExecCGI
              AllowOverride None
              Order allow,deny
              Allow from all
              AuthName "Nagios Access"
              AuthType Basic
              AuthUserFile /usr/local/nagios/etc/htpasswd.users
              Require valid-user
              </Directory>

              Alias /nagios /usr/local/nagios/share

              <Directory "/usr/local/nagios/share">
              Options None AllowOverride None
              Order allow,deny
              Allow from all
              AuthName "Nagios Access"
              AuthType Basic
              AuthUserFile /usr/local/nagios/etc/htpasswd.users
              Require valid-user
              </Directory>
              J'espère avoir répondu à ta question (pour htpasswd.users)
              Last edited by Dellrak; 19 June 2007, 14:41.

              Comment


              • #8
                Originally posted by Dellrak View Post
                Ensuite, tu édites "cgi.cfg" et tu rajoutes "admin" devant tous les lignes commençant par "authorized".
                exemple avec la création de l'utilisateur nagiosadmin ca me donne :
                Code:
                authorized_for_system_information=nagiosadmin

                Originally posted by Dellrak View Post
                J'espère avoir répondu à ta question (pour htpasswd.users)
                Merci bien pour ton aide j'ia bien mon fichier httpasswd.users avec mon utilisateur nagiosadmin maintenant

                Je vais redémarrer le tout pour voir si je peux enfin acceder à l'interface web de nagios

                Comment


                • #9
                  Bon c'est bon ca marche !!

                  Je peux enfin accéder à http://localhost/nagios et tout fonctionne correctement à priori

                  Mais y a encore un ptit hic Lorsque je fais etc/init.d/nagios start ile me redit la même chose qu'avant (voir mon 1er message du post) :
                  Starting nagios:Pas de répertoire, connexion avec HOME=/
                  done.

                  Mais bon ca marche quand même... :roll:

                  Comment


                  • #10
                    Je viens aussi de voir que lorsque je vais sur http:/localhost/nagios je ne peux pas voir mes hosts car nagios n'est pas lancé. Je suis donc obligé de lancé nagios en ligne de commande (etc/init.d/nagios start).
                    Cela serai t'il lié à mon problème que j'ai lorsque je fais /etc/init.d/nagios start :
                    Code:
                    Starting nagios:Pas de répertoire, connexion avec HOME=/
                    done.
                    :confused:

                    Il ne doit pas être configuré pour se lancer au démarrage lorsque je me log sur l'interface web de nagios.

                    Comment


                    • #11
                      Après quelques tentatives je n'ai toujours pas résolu mon problème Une idée ? :confused:

                      Comment


                      • #12
                        Quand tu redémarres ta machine, nagios ne se lance pas au démarrage? Si c'est le cas, va là :

                        http://forum.oreon-project.org/showthread.php?t=3894

                        Tu trouveras ton bonheur, j'espère .

                        Comment


                        • #13
                          Merci ca marche maintenant

                          J'ai juste fais
                          Code:
                          update-rc.d nagios defaults 20
                          et au redemarrage nagios marchait niquel

                          Par contre toujours ce ptit soucis lorsque nagios est relancé soit manuelle soit par oréon :
                          Code:
                          Starting nagios:Pas de répertoire, connexion avec HOME=/
                          done.
                          Mais malgrés ca tout fonctionne parfaitement, juste ca qui s'écrit lorsque je relance nagios :?

                          Comment

                          Working...
                          X