Announcement

Collapse
No announcement yet.

Problème avec Plugins

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problème avec Plugins

    Bonjour à tous !

    Voilà, j'ai des ptits probs avec certains plugins de Nagios/Oreon. :confused:

    Par exemple pour la commande check_graph_traffic

    Lorsque je lance cette commande dans le terminal :

    H : Ip du routeur
    C : Communauté
    v : version
    s : pour avoir les interfaces du routeur

    ./check_graph_traffic.pl -H 192.168.1.254 -C azqswx -v 2c -s

    J'obtiens ceci :

    Interface 1 :: FastEthernet0
    Interface 2 :: FastEthernet1
    Interface 3 :: FastEthernet2
    Interface 4 :: FastEthernet3
    Interface 5 :: Dot11Radio0
    Interface 6 :: ATM0
    Interface 7 :: Null0
    Interface 8 :: ATM0-atm layer
    Interface 9 :: ATM0.0-atm subif
    Interface 10 :: ATM0-aal5 layer
    Interface 11 :: ATM0.0-aal5 layer
    Interface 12 :: ATM0-adsl
    Interface 13 :: Vlan1
    Interface 14 :: ATM0.1-atm subif
    Interface 15 :: ATM0.1-aal5 layer
    Interface 16 :: Dialer0
    Interface 17 :: BVI1
    Interface 18 :: Virtual-Dot11Radio0
    Interface 19 :: Virtual-Access1


    Ensuite je regarde donc le traffic de l'interface 3 (qui correspond à FastEthernet2 je suppose) en faisant ceci :

    ./check_graph_traffic.pl -H 192.168.1.254 -C azqswx -v 2c -i 3

    Et j'obtiens ceci :

    Traffic In : 439.20 b/s (0.0 %), Out : 796.00 b/s (0.0 %) - Total RX Bits In : 163.29 MB, Out : 533.64 Mb|traffic_in=439,2Bits/s traffic_out=796,0Bits/s

    ----

    Maintenant je veux le faire dans Nagios/Oreon.
    La commande est la suivante :

    $USER1$/check_graph_traffic.pl -H $HOSTADDRESS$ -i $ARG1$ -w $ARG2$ -c $ARG3$ -C $ARG4$ -v $ARG5$ -g -S $ARG6$

    J'entre donc en arguments :

    !3!60!90!azqswx!2c

    Mais quand je regarde le monotoring, j'ai ceci :

    gw_iseos
    traffic_test_eth1
    traffic_test_eth1

    UNKNOWN

    12/07/07 09:25:54

    29s

    1

    Unknown - /tmp/traffic_if3_192.168.1.254 !


    Pourtant le "i" est la même dans les 2 cas ? Quelqu'un aurait une idée svp ?

    ---

    Autres problèmes :

    - Nagios Status Map
    - plugin link error pour cisco
    - plugin hp (imprimante)

    (mais j'attends de résoudre le premier avant ^^)


    ---

    Merci d'avance pour votre aide !

  • #2
    Personne ?

    Comment


    • #3
      Salut,

      Hey ouais c'est les vacances les geek lisent pas les fora

      Alors peux tu verifier que ton dossier /tmp/ voir si tu as bien des fichiers de type : "traffic_if*".
      Ces fichiers stockent les infos pour faire les stats.

      Peux etre que tu peux lancer la commance à la main en temps que root car tu peux ecrire dans /tmp/ mais peut etre que ton user nagios n'a pas le droit de le faire.
      ..()_() .°("who | grep -i blonde | date; cd ~; unzip;")
      =(o_0)=
      *(() () Nicolas Verriest, France

      Comment


      • #4
        le plugin trafiic créé un fichier temporaire dans /tmp/ effectivement. Et ce qu'il m'est arrivé, c'est que j'ai d'abord testé le plugin à la main, le fichier s'est créé avec comme propriétaire 'root' et comme les droit sont très restrictif, oreon ne pouvait pas le lire.

        Vérifie ces fichiers si tu a fait des tests à la main avant. Par contre, si tu as rebooté depuis, il doit pas y avoir de problème, parce qu'il se recréé après un reboot et si il sont créé par Oreon y'a pas de problème. Y'a juste lors du premier check d'Oreon/Nagios qu'ils sont en Unknow avec comme message un truc qui doit ressembler : first use, buffer in creation.
        Sir
        -------
        Red Hat 5.4.::. Nagios 3.1.2 .::. Centreon 2.1.8.::.2500 hosts.::.10000 services

        Comment

        Working...
        X