Announcement

Collapse
No announcement yet.

check_disk ne renvoit pas les bons résultats

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • check_disk ne renvoit pas les bons résultats

    Bonjour,

    je cherche à contrôler l'espace disque de mes machines (Debian et FreeBSD). J'utilise la commande:
    Code:
    check_disk -w 10% -c 5%
    Si je teste cette commande directement sur mes machines, j'ai un résultat du type:
    Code:
    DISK CRITICAL - free space: / 8593 MB (96% inode=99%); /dev 0 MB (0% inode=-); /var 10488 MB (35% inode=98%); /usr 9293 MB (35% inode=93%); /proc 0 MB (0% inode=0%);| /=314MB;8712;9196;0;9681 /dev=0MB;0;0;0;0 /var=18914MB;28763;30361;0;31959 /usr=16826MB;25551;26970;0;28390 /proc=0MB;0;0;0;0

    edit: en fait j'avais un problème avec nrpe, le check fonctionne maintenant.

    Lorsque cette commande est lancée par Centreon elle retourne:
    Code:
    DISK OK - free space: / 43982 MB (94% inode=98%): /dev 116 MB (99% inode=92%): /dev/shm 117 MB (100% inode=99%): /var/run 117 MB (99% inode=99%): /var/lock 117 MB (100% inode=99%): /lib/init/rw 117 MB (100% inode=99%):
    Et un df-h me donne:
    Code:
    Filesystem            Size    Used   Avail Capacity  Mounted on
    /dev/mirror/gm0s1a         9.5G    314M    8.4G     4%    /
    devfs                      1.0K    1.0K      0B   100%    /dev
    /dev/mirror/gm0s1b        31G     18G     10G    64%    /var
    /dev/mirror/gm0s1d        28G     16G    9.1G    64%    /usr
    procfs                     4.0K    4.0K      0B   100%    /proc

    Je ne comprends pas pourquoi les résultats en local et via centreon sont aussi différents...si vous pouviez m'éclairer ça serait vraiment sympa!
    Last edited by pausg; 13 September 2011, 17:41. Reason: RESOLU

  • #2
    Je rajoute sur ce fil pour éviter d'en créer un autre.
    Après avoir compris mon erreur avec NRPE, j'ai donc voulu faire des check_disk sur tous mes serveurs.

    Cela fonctionne sauf pour 2 d'entre eux, un FreeBSD et un Debian, ou les check sont "UNKNOWN". Mes autres serveurs sont des FreeBSD et tout fonctionne parfaitement. Le fichier de config est le même pour tous les serveurs.

    Le FreeBSD me renvoit: CHECK_NRPE: Received 0 bytes from daemon. Check the remote server logs for error messages.
    Le Debian renvoit: CHECK_NRPE: Error receiving data from daemon.
    Un netstat sur chacun des serveurs me renvoi bien : tcp 0 0 *:nrpe *:* LISTEN


    Savez vous d'ou peut venir le problème?
    Last edited by pausg; 14 September 2011, 14:12.

    Comment


    • #3
      Bonjour,

      question bete, tu as ete voir les logs du service NRPE sur tes 2 machines?
      Raphael
      --
      Bi Intel(R) Xeon(TM) CPU 3.06GHz - 3Gb ram
      Debian
      Nagios® Core™ Version 3.2.1 - Nagios Plugins 1.4.14 - NDO 1.4b9 patché
      Centreon 2.3.4 - Syslog Module 1.3.2 - StatusMap Module 2.5 - NDO Tools Module 0.4 SVN - Nagvis
      Beta tester : centreon-engine - centreon-broker

      Comment


      • #4
        Je ne sais pas exactement d'ou venait le problème mais ca devait venir d'un conflit de versions avec FreeBSD 8. J'ai réinstallé les plugins nagios et nrpe depuis les ports et ca a réglé le problème.

        Comment

        Working...
        X