Announcement

Collapse
No announcement yet.

RRD problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RRD problems

    Hello. First, I must say, nice looking. I installed it on a debian linux box and followed your instructions. I got version 1.2.2 working, however I am having problems with the graphs. I was able to set up hosts, contacts, and services. They show the nice pie graphs and everying. I tried setting up check_graph_ping. I get a response from the shell when I run the perl script:

    debian:/usr/local/nagios/libexec# ./check_graph_ping.pl -H 10.13.3.24
    GPING OK - rtt min/avg/max/mdev = 0.276/0.276/0.276/0.000 ms
    debian:/usr/local/nagios/libexec# ./check_graph_ping.pl -H 10.13.3.24 -g
    GPING OK - rtt min/avg/max/mdev = 0.285/0.285/0.285/0.000 ms

    When I check in /usr/local/oreon/rrd there are no rrd files. I use the web gui and I get File /usr/local/oreon/rrd/10.rrd is not accessible.

    I check permissions. oreon has wwwdata.wwwdata -rwxrwxrwx as well as its subfolders, except rrd which is nagios.nagios drwxrwxrwx.

    I used your nagios installation package, which included the rrdtool-1.0.49

    Any suggestions or help would be greatly appreciated. Thank you. 8)

  • #2
    additional info

    The only part which confused me was the symbolic link ln -s. Because I do not have a /usr/local/rrdtool folder. I have only a /usr/local/rrdtool-1.0.49 folder. Where should this symbolic go. At the root? Should I create an rrdtool folder and put it there. I did that the later. It did not do anything.

    Comment


    • #3
      i think it is for having /usr/local/rrdtool-1.0.49 and /usr/local/rrdtool to point to the same folder /usr/local/rrdtool-1.0.49

      ln -s /usr/local/rrdtool-1.0.49 /usr/local/rrdtool
      Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
      Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
      Fedora Core 5 - 2.6.20-1.2320

      Comment


      • #4
        Remove the created folder and ran symbolic cmd in the shell

        This created a link called rrdtool pointing back to the rrdtool-1.0.49 folder. I restarted nagios via shell. Still no rrd files are being generated. I still get /usr/local/oreon/rrd/##.rrd is not accessible.

        What am I missing. The plug in does return a value at shell. But it is not creating a rrd file and populating.

        Help Help......

        Comment


        • #5
          Maybe it is the permission on rrdtools folder itself

          What should the permission be on /usr/local/rrdtools-1.0.49?

          Mine reads drwxr-sr-x root staff. Should I change this????

          :?

          Comment


          • #6
            test from shell

            If I run from shell ./check_graph_ping.pl -H 10.13.5.105 -g -S 13. It creates the rrd file 13.rrd .

            Question then is the variable $USER1$?????? 8)

            Comment


            • #7
              I have the solution finally

              I browsed. Somewhere they mentioned an arguement. !10. This worked for me.

              Is there a page listing the check commands

              Comment


              • #8
                Re: test from shell

                Originally posted by keb
                If I run from shell ./check_graph_ping.pl -H 10.13.5.105 -g -S 13. It creates the rrd file 13.rrd .

                Question then is the variable $USER1$?????? 8)
                $USER1$ is a nagios specifique variable configure somewhere in nagios config file

                but for ./check_graph_ping.pl you don't have to specify -S 13 because oreon automatically generate this variable.
                Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                Fedora Core 5 - 2.6.20-1.2320

                Comment


                • #9
                  Re: test from shell

                  Originally posted by keb
                  If I run from shell ./check_graph_ping.pl -H 10.13.5.105 -g -S 13. It creates the rrd file 13.rrd .

                  Question then is the variable $USER1$?????? 8)
                  According to Oreon Wiki[1], you don't have to specify any argument to -S option.
                  $USER1$ is a Nagios macro used to store plugin's directory, by convention.
                  This macro is defined into resources.cfg file. You can change this value in Oreon via "Options" menu, then "resources.cfg" sub-menu.

                  [1]: http://wiki.oreon-project.org/wakka....kGraphPingEN#5
                  Raphaël 'SurcouF' Bordet
                  Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
                  Dons Paypal

                  Comment


                  • #10
                    Re: test from shell

                    Originally posted by keb
                    If I run from shell ./check_graph_ping.pl -H 10.13.5.105 -g -S 13. It creates the rrd file 13.rrd .

                    Question then is the variable $USER1$?????? 8)
                    I had the same troubles at first. The 'oreon service id' you have to give with the -S argument is passed by Oreon itself as the last argument. So for example if you have 2 arguments in your check_command_arguments (!arg1!arg2) you have to put '-S $ARG3$' on your command-line to let oreon automatically pass the service-id to the plugin. This way unique file-names for the RRD's can be made.
                    Your USER1 variable is normally set in resource.cfg and points to the plug-in dir.

                    Menno

                    Comment


                    • #11
                      Hi,

                      I had the same problem:
                      did you should check your Check_command_arguments line in the service configuration ?

                      exemple:
                      Check_command: check_graph_traffic
                      Check_command_arguments : !13!80!95!public!1

                      without the ending "!"

                      that was my typo!

                      hope this works for you

                      xspoon

                      Comment

                      Working...
                      X