Announcement

Collapse
No announcement yet.

check_http working in shell but not in oreon

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • check_http working in shell but not in oreon

    when I run a check such as ./check_http -H www.<WEBSITE>.net -u /monitoring.aspx -R HOSTUP I get the "200" response as expected. When running this in oreon (with arguements if that makes a difference) I get a "403 forbidden" error.

    Is there a reason why a check such as ./check_http would report different results on the command line v.s. in the GUI ?
    John Meek
    Systems IT Manager, CHP Productions, Inc.

  • #2
    Hello,

    did you have modify your check_http command in oreon ?

    by default, is
    Code:
    $USER1$/check_http -H $HOSTADDRESS$ -s $ARG1$ -v
    try
    Code:
    $USER1$/check_http -H $HOSTADDRESS$ -u $ARG1$ -R HOSTUP
    with this argument
    !/monitoring.aspx
    StatusMap Module - NDO Tools Module - ImportCSV Module - SNMP-UI Module - PDFReports Module
    Dons Paypal

    Comment


    • #3
      Yes, new check created based on the original

      I created two new checks, one as a host check (check_http -H $HOSTADDRESS$ -u /nagios.html) to establish host up and the service check (check_http -H $HOSTADDRESS$ -u /monitoring.aspx -R HOSTUP) for the service check. After I posted the original I changed the service check to remove the $ARG1$ and $ARG2$ and I still get in the log:

      HOST ALERT: WWW_<SITE>;UP;HARD;1;HTTP ok: HTTP/1.1 200 OK - 0.407 second response time

      SERVICE ALERT: WWW_<SITE>;WWW_check_http_OK;WARNING;SOFT;2;HTTP WARNING: HTTP/1.1 403 Forbidden
      John Meek
      Systems IT Manager, CHP Productions, Inc.

      Comment

      Working...
      X