Announcement

Collapse
No announcement yet.

[Résolu]problème : plugin perso et graph rrd

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • julio
    replied
    Originally posted by Mafalda
    Bon ben pardon alors. je :arrow:

    ops:
    OUAIS !!

    Leave a comment:


  • Mafalda
    replied
    Bon ben pardon alors. je :arrow:

    ops:

    Leave a comment:


  • templuche
    replied
    Ben... non ! Les plugins Oreon sont codés exprès pour ne pas générer de graphique lorsqu'ils sont utilisés par Nagios seul sans Oreon! Un plugin Oreon est un plugin Nagios spécifique à Oreon mais qui peut être utilisé sans Oreon. Dans le cas contraire, cela signifierait qu'on ne pourrait pas les utiliser en ligne de commande. Ce qui serait génant pour faire des tests

    Leave a comment:


  • Mafalda
    replied
    Ouais mais les plugin oreon sont pas forcement idéaux pour nagios : un plugin qui génère des graph en plus de monitorer un service, c'est du gaspillage de ressources si on n'utilise que nagios.

    Leave a comment:


  • templuche
    replied
    Disons que c'est pour éviter de poster à 2 endroits différents : une fois sur Oreon et une fois sur NagiosExchange. Enfin, je dis ça, je dis rien!

    Leave a comment:


  • julio
    replied
    et pourkoi pas donc ?

    Leave a comment:


  • templuche
    replied
    Bonjour,

    Et pourquoi donc? Pourquoi ne pas les déposer sur NagiosExhange? Et l'indiquer sur le forum d'Oreon si besoin il y a!

    Leave a comment:


  • julio
    replied
    Nous allons ouvrir prochainement, une rubrique sur le site pour déposer vos plugins. Vous pourrez ainsi les uploader et tout le monde pourra les telecharger. Un moyen simple de contribuer activement

    Merci d'avance

    Leave a comment:


  • proxyo
    replied
    Tu sais même si c'est basic, toute contribution est la bienvenue, à partir du moment ou cela permet à certaines personnes de gagner du temps et de ne pas avoir à redévelopper quelque chose qui l'est déjà



    Merci de la contribution


    Proxyo

    Leave a comment:


  • Mafalda
    replied
    Ok, ca reste assez basique vu que ca réponds à un besoin hyper spécifique mais pk pas.
    Attached Files

    Leave a comment:


  • proxyo
    replied
    j'ai fait la même erreur juste un ou deux posts en dessous...


    par contre n'hésite pas à partager ton plugin, ca peut intéresser les gens...




    ProXyo

    Leave a comment:


  • Mafalda
    replied
    Pourquoi 150, tout bêtement parce que on met une valeur aux arguements en général et que 150 m'allait bien comme serviceId.

    Ca semble bien marcher que tu dis.

    Merci bien.

    Leave a comment:


  • wistof
    replied
    pourquoi 150 ? tu le sors d'ou ?

    tu ne dois pas définir le $ARG1$, c'est oreon qui le fait pour toi

    donc

    $USER1$/check_graph_cisco_ppp_account.pl -H $HOSTADDRESS$ -g -S $ARG1$
    avec argument vide dans linterface oreon

    Leave a comment:


  • Mafalda
    replied
    Je me suis mal exprimé :

    ma commande est définie comme cela:
    Code:
    $USER1$/check_graph_cisco_ppp_account.pl -H $HOSTADDRESS$ -g -S $ARG1$
    mais pour un de mes hosts (celui de l'exemple) j'attribue '150' à $ARG1$ , càd que je rentre "!150" dans le champ argument.

    Leave a comment:


  • wistof
    replied
    Hello,

    tu retires ton 150 de ta commande et tu le remplaces par $ARG1$
    $USER1$/check_graph_cisco_ppp_account.pl -H mon_host -g -S $ARG1$
    et tu ne spécifies pas de valeur pour $ARG1$, c'est Oreon qui le fera pour toi

    Leave a comment:

Working...
X