Announcement

Collapse
No announcement yet.

Problème génération de graphes / acquisition de données

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problème génération de graphes / acquisition de données

    Bonjour

    J'ai finalement réussi à faire fonctionner (en partie) mon install de nagios/oreon. Il m'arrive des choses bizarres...
    Tout d'abord, sur les 25 hosts qui sont monitorés pour le moment, seuls 3 sont signalés up alors qu'ils le sont tous (la commande utilisée pour vérifier est la même pour toutes les machines - check-host-alive, j'ai essayé avec d'autres mais ça n'a pas l'air de changer grand chose). Ca déjà je trouve bizarre. Il n'y a rien marqué dans le log mais la page surveillance marque "No output!" (donc erreur).
    Ensuite j'ai créé un service de test pour vérifier que ça marchait bien. Il ne semble pas y avoir de problème, les bases rrd sont créées correctement et bien appelées (avec -S à la fin et tout). Les bases existent et sont accessibles, pas de message d'erreur. Mais lorsque je veux voir les graphiques de mes ping par exemple les images ne sont pas trouvées. J'ai vérifié les permissions sont correctes, je pense que ça vient de la génération de l'image (problème de librairie ?).

    Qu'en pensez-vous ? Comment pourrais-je faire pour voir tous mes hosts et mes graphiques de service ?

  • #2
    non non la generation de l'image n'a rien a voir. Tu as testé logué en user nagios ? Des fois ca change tout
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      Je comprends pas trop... A part en me loggant sur le serveur ce qui sert pas à grand chose vu qu'il n'y a pas de serveur grahique dessus (et comme links adore les images...), j'ai aucun moyen de passer en user nagios sur oreon, si ? J'ai un compte d'admin que j'utilise pour faire les paramétrages mais si ça s'affiche pas là ça s'affichera nulle part...

      Comment


      • #4
        oula.... nan nan .... euhhh tu attribut un mot de passe a ton user nagios et apres tu le log en nagios pour lancer tes commandes de test en ligne de commande... et tu verra ce que te donne le plugin. Si c'est des erreurs releve les et donnes les nous, qu'on t'aide un peu.
        Julien Mathis
        Centreon Project Leader
        www.merethis.com |

        Comment


        • #5
          Huhu j'avais mal compris.
          La compil de mes scripts en ligne de commande donne rien de particulier
          (par exemple ./check_graph_ping.pl -H *** -n 2 -S 15
          GPING OK - rtt min/avg/max/mdev = 1.388/1.620/1.852/0.232 ms -- qui marche mais qui donne pas d'image
          ou
          ./check_graph_ping.pl -H ***
          GPING OK - rtt min/avg/max/mdev = 6.941/6.941/6.941/0.000 ms -- qui marche mais qui marque quand même l'host down -_-). J'avais eu des problèmes avec mais j'ai réussi à les régler avec un export PERL5LIB dans mon bash.bashrc parce qu'il trouvait pas utils.pm et en supprimant le oreon.pm dans un use parce qu'il voulait un répertoire et pas un fichier.

          Comment


          • #6
            Pour les hosts qui ne sont jamais trouvés ça semble résolu... On dirait que si un host n'a pas de service associé il est considéré comme down. Bizarre.
            En revanche toujours pas de graphes... Pourtant la génération d'images en elle-même semble fonctionner. J'ai fait une traffic map de test et j'ai bien l'image avec les hosts positionnés dessus avec les flèches qui vont avec...

            Comment


            • #7
              Originally posted by _kezar_
              J'avais eu des problèmes avec mais j'ai réussi à les régler avec un export PERL5LIB dans mon bash.bashrc parce qu'il trouvait pas utils.pm et en supprimant le oreon.pm dans un use parce qu'il voulait un répertoire et pas un fichier.
              :? ça sent la bidouille cette histoire là...
              si tu vires le use oreon, tu mets tout les chances de ton coté pour que cela ne fonctionne pas
              StatusMap Module - NDO Tools Module - ImportCSV Module - SNMP-UI Module - PDFReports Module
              Dons Paypal

              Comment


              • #8
                J'ai juste modifié la ligne en fait. J'ai enlevé le nom du fichier à la fin du chemin qui était spécifié pour prendre le répertoire parent parce que quand je compilais il me disait qu'il voulait un répertoire et pas un fichier.
                Pour le export c'est la seule façon que j'ai trouvé pour qu'il trouve le fichier qui manquait sans avoir à modifier tous les plugins pour rajouter un use...

                Comment


                • #9
                  ptite up
                  en fait j'ai regardé le contenu des rrd (puisque c'est par là qu'il y a un problème) et à chaque ligne j'ai "NaN" (une ptite recherche m'a appris que ça correspondait à Not a Number). Je sais donc ce qui se passe mais je suis pas plus éclairé pour résoudre le problème... Si ça vous dit quelque chose...

                  Comment


                  • #10
                    regarde les droits sur ton fichier rrd
                    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                    Fedora Core 5 - 2.6.20-1.2320

                    Comment


                    • #11
                      Ben 777, et puis si il écrit des not a number dedans c'est bien qu'il peut y écrire autre chose normalement

                      Comment


                      • #12
                        De mon experience, c'est qu'il n'écrit pas dedans et que la valeur n'est pas initialisé.
                        Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                        Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                        Fedora Core 5 - 2.6.20-1.2320

                        Comment


                        • #13
                          Ben je sais qu'il n'arrive pas à écrire les bonnes données dedans sinon ça marcherait, mais il arrive bien à les avoir ces données vu que j'ai quand même les stats à l'instant t sans graphes :?
                          Comment je peux faire pour le faire écrire des choses plausibles dans les rrd ? (sachant que j'ai déjà essayé de les virer pour tout réinitialiser et qu'il a continué à ecrire des NaN dedans)...

                          Comment


                          • #14
                            Moi je ne précise pas le -S c oreon qui gère mais j'ai un -g que tu n'as pas apparement.

                            Ce qui expliquerai pourquoi il ne renseigne pas la base rrd ton plugin
                            Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                            Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                            Fedora Core 5 - 2.6.20-1.2320

                            Comment


                            • #15
                              Ben par exemple pour le ping j'ai ça :
                              $USER1$/check_graph_ping.pl -H $HOSTADDRESS$ -w 200,20% -c 500,40% -n $ARG1$ -g -S $ARG2$
                              (c'est la sonde par défaut il me semble, je ne dois pas l'avoir modifiée)
                              Pourtant je n'ai pas de graphe -_-

                              Comment

                              Working...
                              X