Announcement

Collapse
No announcement yet.

Random "Service/Hostcheck did not exit properly"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Random "Service/Hostcheck did not exit properly"

    Hi everyone.

    I've setup a distributed architecture with one central and 2 distributed. Everything it's working OK but sometimes (looks random) we have a lot of checks telling "Host check did not exit properly" or "Service check did not exit properly". Those messages are related to different checks (check_icmp and check_x224 i.e.), so I think they are not related to one check, they keep looking "random".

    If they where real problems, the message would look like "Critical - X.X.X.X: rta 333.283ms, lost 60%" or "x224 CRITICAL: Could not set up connection on port 3389: timed out", but no ".... check did not exit properly"

    As soon as this problems arises (on a lot of different hosts and services) it dissappears, but centreon sends me around 50 messages to scare me...

    żAny ideas? Thanks in advance

  • #2
    Originally posted by Maverick2k2 View Post
    Hi everyone.

    I've setup a distributed architecture with one central and 2 distributed. Everything it's working OK but sometimes (looks random) we have a lot of checks telling "Host check did not exit properly" or "Service check did not exit properly". Those messages are related to different checks (check_icmp and check_x224 i.e.), so I think they are not related to one check, they keep looking "random".

    If they where real problems, the message would look like "Critical - X.X.X.X: rta 333.283ms, lost 60%" or "x224 CRITICAL: Could not set up connection on port 3389: timed out", but no ".... check did not exit properly"

    As soon as this problems arises (on a lot of different hosts and services) it dissappears, but centreon sends me around 50 messages to scare me...

    żAny ideas? Thanks in advance
    I've got the same issue. I don't find a way to resolve this. If anyone could help ?

    Comment


    • #3
      Originally posted by majordom View Post
      I've got the same issue. I don't find a way to resolve this. If anyone could help ?
      I'm afraid that nobody has helped me and I've not found a solution. I'm still experiencing that problem randomly

      Comment


      • #4
        Same issue here. How can I make this an UNKNOWN instead of CRITICAL so I don't get hundreds of emails?

        Comment


        • #5
          Anyone can help?

          Comment


          • #6
            Same issue. Randomly hosts alerts "Host check did not exit properly" (check_icmp). But this host are not down.
            ccpr
            Junior Member
            Last edited by ccpr; 30 September 2013, 17:10.
            Centreon CES Standard 2.2.

            Comment


            • #7
              Hello,

              I've got the same
              Centreon Enterprise Server 3
              Centreon 3

              Comment


              • #8
                Same problem here! :?:

                Comment


                • #9
                  Same here!

                  Comment


                  • #10
                    Same... Randomly get machines showing 'Host Check Did Not Exit Properly' on ICMP ping checks. Very annoying... Is there no fix for this?

                    Comment

                    Working...
                    X