Announcement

Collapse
No announcement yet.

recherche plugin pour controler la BP par protocole

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • recherche plugin pour controler la BP par protocole

    Bonjour, est ce que avec la solution nagios oreon, je peux controler plusieur machine TSE sur le protocole 3380 et avoir des graphique de consommation de BP pour ces machines sur ce protocole 3389 en TCP ??
    merci

  • #2
    Terminal Server?

    Je graphe le nombre d'utilisateur ça me suffit. Pour la bande passante, aucune idée!
    RedHat Advanced Server 4.0
    Nagios 2.3.1
    Oreon 1.3b1

    Comment


    • #3
      TSE ne propose pas des compteurs de performances qui vont bien ?
      StatusMap Module - NDO Tools Module - ImportCSV Module - SNMP-UI Module - PDFReports Module
      Dons Paypal

      Comment


      • #4
        Originally posted by pepito
        Terminal Server?

        Je graphe le nombre d'utilisateur ça me suffit. Pour la bande passante, aucune idée!
        tu utilises quels plugin ??

        Comment


        • #5
          Code:
          define command{
                  command_name                    check_graph_utilisateurs_TSE
                  command_line                    $USER1$/check_graph_nt.pl -H $HOSTADDRESS$ -s $USER2$ -p $USER5$ -v COUNTER -l "\\Services Terminal Server\\Sessions actives" -g -S $ARG1$
          }
          :wink:

          pour pas mourir idiot, tu peux trouver "\\Services Terminal Server\\Sessions actives" dans
          outils d'administration -> Performances -> Moniteur système -> clic droit dans la table en bas a droite -> Ajouter compteur...

          T'es pas obligé d'en rajouter un, tu as juste besoin du nom.
          RedHat Advanced Server 4.0
          Nagios 2.3.1
          Oreon 1.3b1

          Comment


          • #6
            Originally posted by pepito
            Code:
            define command{
                    command_name                    check_graph_utilisateurs_TSE
                    command_line                    $USER1$/check_graph_nt.pl -H $HOSTADDRESS$ -s $USER2$ -p $USER5$ -v COUNTER -l "\\Services Terminal Server\\Sessions actives" -g -S $ARG1$
            }
            :wink:
            Merci pepito pour la rapidité, je vais essayer, j'ai des soucis d'affichage de mes graph avec la derniere version RC4, les images ne s affiche pas, est ce que ca te dis quelques chose ??

            Comment


            • #7
              Peut etre qu'il te faut attendre un peu tout simplement...
              Au début je voyais des erreurs au lieu des graphes. Du coup je changeais ma config et je relancais nagios... qui avait meme pas le temps de générer les fichiers rrds le pauvre

              Si tu tapes la commande:

              Code:
              /usr/local/rrdtool/bin/rrdtool info /usr/local/oreonbeta/rrd/xxx.rrd
              ca t'affiche pas une erreur?
              RedHat Advanced Server 4.0
              Nagios 2.3.1
              Oreon 1.3b1

              Comment


              • #8
                Originally posted by pepito
                Peut etre qu'il te faut attendre un peu tout simplement...
                Au début je voyais des erreurs au lieu des graphes. Du coup je changeais ma config et je relancais nagios... qui avait meme pas le temps de générer les fichiers rrds le pauvre

                Si tu tapes la commande:

                Code:
                /usr/local/rrdtool/bin/rrdtool info /usr/local/oreonbeta/rrd/xxx.rrd
                ca t'affiche pas une erreur?
                Voila ce que ca m 'affiche, le fichier est bien la mais les images apparaissent sou forme de carré avec une croix rouge, comme si il arrivé pas à interpreter les jpg ou le type d'image ... et poutant il me fait bien les camembert sur la pages d'accueil, donc pas un probleme de lib .... !! je sais pas

                filename = "/usr/local/oreon/rrd/8.rrd"
                rrd_version = "0001"
                step = 300
                last_update = 1145691604
                ds[a].type = "GAUGE"
                ds[a].minimal_heartbeat = 600
                ds[a].min = NaN
                ds[a].max = NaN
                ds[a].last_ds = "UNKN"
                ds[a].value = 1.0960000000e+00
                ds[a].unknown_sec = 0
                rra[0].cf = "AVERAGE"
                rra[0].rows = 8640
                rra[0].pdp_per_row = 1
                rra[0].xff = 5.0000000000e-01
                rra[0].cdp_prep[0].value = NaN
                rra[0].cdp_prep[0].unknown_datapoints = 0
                rra[1].cf = "MIN"
                rra[1].rows = 8640
                rra[1].pdp_per_row = 12
                rra[1].xff = 5.0000000000e-01
                rra[1].cdp_prep[0].value = 2.7400000000e-01
                rra[1].cdp_prep[0].unknown_datapoints = 6
                rra[2].cf = "MAX"
                rra[2].rows = 8640
                rra[2].pdp_per_row = 12
                rra[2].xff = 5.0000000000e-01
                rra[2].cdp_prep[0].value = 2.7400000000e-01
                rra[2].cdp_prep[0].unknown_datapoints = 6

                Comment


                • #9
                  ca doit peut etre venir de la facon dont oreon génère le graphe...

                  Je ne sais pas comment ils s'y prennent mais en cherchant un peu dans les fichiers php tu dois pouvoir trouver la ligne de commande qu'ils utilisent.

                  Regarde aussi dans les logs (apache et autres) si tu y vois une erreur.
                  RedHat Advanced Server 4.0
                  Nagios 2.3.1
                  Oreon 1.3b1

                  Comment


                  • #10
                    Originally posted by pepito
                    ca doit peut etre venir de la facon dont oreon génère le graphe...

                    Je ne sais pas comment ils s'y prennent mais en cherchant un peu dans les fichiers php tu dois pouvoir trouver la ligne de commande qu'ils utilisent.

                    Regarde aussi dans les logs (apache et autres) si tu y vois une erreur.
                    j'ai ceci dans mes logs d'erreur APACHE :
                    sh: line 1: /usr/local/rrdtool/lib/perl: is a directory

                    Comment


                    • #11
                      c plutot que dans tes options generale t'as mal configuré le path de rrdtool... a mon avis..
                      Julien Mathis
                      Centreon Project Leader
                      www.merethis.com |

                      Comment


                      • #12
                        Originally posted by julio
                        c plutot que dans tes options generale t'as mal configuré le path de rrdtool... a mon avis..
                        j'ai ceci : pour le path rrdtool ...
                        /usr/local/rrdtool/lib/perl
                        j'ai pas d'erreur .. je vois pas la

                        Comment


                        • #13
                          ha bah oauis moi j'ai ca : "/usr/bin/rrdtool"

                          fait uen whereis -b rrdtool

                          et tu aura le path de ton binaire

                          et apres ca devrait fonctionner.
                          Julien Mathis
                          Centreon Project Leader
                          www.merethis.com |

                          Comment


                          • #14
                            Originally posted by julio
                            ha bah oauis moi j'ai ca : "/usr/bin/rrdtool"

                            fait uen whereis -b rrdtool

                            et tu aura le path de ton binaire

                            et apres ca devrait fonctionner.
                            Dac pour le binaire, il est dans /usr/local/rrdtool
                            c corrigé mais toujours pareil, des petits carré apparaisse, quand je clique sur un carré et que je fait afficher l'image, il me renvoi ca comme erreur
                            Warning: imagecreate(): Invalid image dimensions in /usr/local/oreon/include/graph/graph_image.php on line 70

                            Warning: imagecolorallocate(): supplied argument is not a valid Image resource in /usr/local/oreon/include/graph/graph_image.php on line 72

                            Warning: imagecolorallocate(): supplied argument is not a valid Image resource in /usr/local/oreon/include/graph/graph_image.php on line 73

                            Warning: imagecolortransparent(): supplied argument is not a valid Image resource in /usr/local/oreon/include/graph/graph_image.php on line 74

                            Warning: imagestring(): supplied argument is not a valid Image resource in /usr/local/oreon/include/graph/graph_image.php on line 77

                            Warning: imagepng(): supplied argument is not a valid Image resource in /usr/local/oreon/include/graph/graph_image.php on line 80

                            Ta une idée ??

                            Comment


                            • #15
                              passe à la vitesse supérieure, installe rrdtool 1.2...
                              RedHat Advanced Server 4.0
                              Nagios 2.3.1
                              Oreon 1.3b1

                              Comment

                              Working...
                              X