Announcement

Collapse
No announcement yet.

[REGLE]ENCORE UN PTIT SOUCIS AVEC LE SERVICES WIN

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [REGLE]ENCORE UN PTIT SOUCIS AVEC LE SERVICES WIN

    Bonjout, tout le monde je suis en train de tester le plugin : check windows services que j'ai trouvé sur :

    http://www.nagiosexchange.org/Window..._netnagext_pi1[p_view]=334

    Ca marche correctement pour par exemple les services IIS, je fais des tests sur Terminal Server aussi, enfin c'est pas la question.

    J'ai un probleme avec un hote je recois le message d'erreur suivant:

    ./check_services_win.pl -H IP -C Communauté -2 -n IIS
    ERROR: Process name table : Message size exceeded buffer maxMsgSize.

    Si qqun sait d'ou peut venir cette erreur il m'enlevera une épine du pied
    8)

    Merci d'avance
    Oreon 1.2.2 oOo Nagios 1.3 oOo Red Hat Enterprise Linux AS (v.4 for 32 bits x86)

    Proc: Intel Xeon 2,8Ghz oOo RAM: 1024Mb

  • #2
    augmente peut etre la valeur

    $session->max_msg_size(5000);
    :?:
    StatusMap Module - NDO Tools Module - ImportCSV Module - SNMP-UI Module - PDFReports Module
    Dons Paypal

    Comment


    • #3
      Je l'ai passé carrément a 10000 et ca marche, merci pour l'astuce
      Est-ce que cela peut avoir des `effets secondaires` sur le plugin?

      Par exemple je n'arrive plus a recevoir de reponse en verifiant les servers executant terminal server:

      ./check_services_win.pl -H IP -C Communauté -2 -n Terminal Server
      ERROR: Process name table : No response from remote host '10.54.10.203'.
      Oreon 1.2.2 oOo Nagios 1.3 oOo Red Hat Enterprise Linux AS (v.4 for 32 bits x86)

      Proc: Intel Xeon 2,8Ghz oOo RAM: 1024Mb

      Comment


      • #4
        J'ai un serveur recalcitrant Grrrrrrr
        Avec $session->max_msg_size(10000);

        Y me donne:
        ./check_service_test.pl -H IP -C Communauté -2 -n Terminal Server -s
        ERROR: Process name table : No response from remote host '10.54.10.63'.

        Avec $session->max_msg_size(5000);

        Y me donne:
        ./check_service_test.pl -H IP -C Communauté -2 -n Terminal Server
        ERROR: Process name table : Message size exceeded buffer maxMsgSize.

        C'est a perdre la boule ce truc

        hock: hock: hock: hock: hock: hock: hock: hock: hock:
        Oreon 1.2.2 oOo Nagios 1.3 oOo Red Hat Enterprise Linux AS (v.4 for 32 bits x86)

        Proc: Intel Xeon 2,8Ghz oOo RAM: 1024Mb

        Comment


        • #5
          Ca marche avec 7500 ca va pas etre drole si ils sont tous a faire ca :?
          Oreon 1.2.2 oOo Nagios 1.3 oOo Red Hat Enterprise Linux AS (v.4 for 32 bits x86)

          Proc: Intel Xeon 2,8Ghz oOo RAM: 1024Mb

          Comment


          • #6
            essaye de joué sur le timeout de la requete snmp
            StatusMap Module - NDO Tools Module - ImportCSV Module - SNMP-UI Module - PDFReports Module
            Dons Paypal

            Comment


            • #7
              OKI je vais jeter un coup d'oeil aussi mais la ca marche avec 7500 pour tous donc pas de pbs 8) Merci encore
              Oreon 1.2.2 oOo Nagios 1.3 oOo Red Hat Enterprise Linux AS (v.4 for 32 bits x86)

              Proc: Intel Xeon 2,8Ghz oOo RAM: 1024Mb

              Comment


              • #8
                VOILA LA SUITE DU POSTE AVEC UN NOUVEAU SOUCIS AU NIVEAU DES SERVICES WIN.

                J'ai un phenomene incomprehensible. J'utilise toujours le meme plugin, mais avec l'argument -v j'ai une liste vide des services présents sur le serveur !!!!

                Si qqun sait d'ou cela peut-il bien venir???

                Voila l'erreur retournée:

                ERROR: Process name table : Requested table is empty or does not exist.
                Oreon 1.2.2 oOo Nagios 1.3 oOo Red Hat Enterprise Linux AS (v.4 for 32 bits x86)

                Proc: Intel Xeon 2,8Ghz oOo RAM: 1024Mb

                Comment


                • #9
                  C'est le plugin qui doit etre buggé non?
                  Il doit chercher au mauvais endroit dans la mib.

                  Regarde un peu les oid qu'il utilise et teste les avec la commande smpwalk
                  RedHat Advanced Server 4.0
                  Nagios 2.3.1
                  Oreon 1.3b1

                  Comment


                  • #10
                    Originally posted by pepito
                    C'est le plugin qui doit etre buggé non?
                    Il doit chercher au mauvais endroit dans la mib.

                    Regarde un peu les oid qu'il utilise et teste les avec la commande smpwalk
                    Je pense plutôt que l'agent SNMP sous Windows ne dit pas tout.
                    En effet, par défaut, il ne présente pas entièrement les objets disponibles, à l'image des agents net-snmp distribués par RedHat et Debian.
                    Vérifie dans les propriétés du service SNMP si tous les modules sont bien activés.
                    Raphaël 'SurcouF' Bordet
                    Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
                    Dons Paypal

                    Comment


                    • #11
                      Rien a faire le service snmp est configuré comme sur les autres machines et le plugin avec l'argument -v verbose affiche une liste de services actifs vide ????
                      Oreon 1.2.2 oOo Nagios 1.3 oOo Red Hat Enterprise Linux AS (v.4 for 32 bits x86)

                      Proc: Intel Xeon 2,8Ghz oOo RAM: 1024Mb

                      Comment

                      Working...
                      X